Bug 819757 - Can not view by click "year", "Month", "Week", "Day" ,"Pre","Next" in Events page.
Can not view by click "year", "Month", "Week", "Day" ,"Pre","Next" in Events ...
Status: CLOSED CANTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: Triaged
: 855995 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 03:21 EDT by yquan
Modified: 2015-05-14 21:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-18 11:25:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The shot of year page (64.80 KB, image/png)
2012-05-08 03:21 EDT, yquan
no flags Details

  None (edit)
Description yquan 2012-05-08 03:21:34 EDT
Created attachment 582890 [details]
The shot of year page

Description of problem:
While viewing by "year", "Month", "Week", "Day" in Events page,
The content is blank.


Version-Release number of selected component (if applicable):
devenv_1761

How reproducible:
always

Steps to Reproduce:
1.Go to the openshift website.
2.Go to the community page.
3.Click the Events in left navigator bar.
4.Click the Calendar View
5.Click the "year", "Month", "Week", "Day" links.
  
Actual results:
The pages are gone.

Expected results:
The page should present correctly .

Additional info:
Comment 1 Clayton Coleman 2012-05-09 01:08:50 EDT
Moving this to low because those aren't terribly useful.  We can exit this sprint like this (they've been broken for at least a sprint.
Comment 2 mcao 2012-06-11 05:36:07 EDT
I have also found this bug on devenv_1827. In Events page "/community/calendar", the linked URL of "Year" is "https://openshifttest.redhat.com/community//community/calendar/2012", and the linked URL of "Month","Week","Day" are separately redirected to "https://openshifttest.redhat.com/community//community/calendar/2012-06","https://openshifttest.redhat.com/community//community/calendar/2012-W22","https://openshifttest.redhat.com/community//community/calendar/2012-06-01".
These URL are wrong Obviously.
Comment 3 Clayton Coleman 2012-06-18 11:25:50 EDT
This is only a bug in the devenv, because the default configuration sets $base_url = "/community", which triggers a bug in how drupal generates URLs.  In production we set $base_url to the full URL of the server which is why it works there.

To verify locally with the workaround, open /etc/drupal6/default/settings.php and find the line with $base_url.  Change it from '/community' to the fully qualified URL of your devenv, e.g.: 

$base_url = 'https://ec2-23-20-107-39.compute-1.amazonaws.com/community';

and then refresh the events page.  It should be functional.
Comment 4 N. Harrison Ripps 2012-09-11 14:11:38 EDT
*** Bug 855995 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.