Bug 819915 - e1000: Fix multi-descriptor packet checksum offload
Summary: e1000: Fix multi-descriptor packet checksum offload
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: jason wang
QA Contact: Virtualization Bugs
URL: http://git.qemu.org/?p=qemu.git;a=com...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-08 15:38 UTC by Joaquin
Modified: 2018-11-29 19:38 UTC (History)
12 users (show)

Fixed In Version: qemu-kvm-0.12.1.2-2.306.el6
Doc Type: Bug Fix
Doc Text:
Cause: E1000 emulation loads the field of POPTS for every descriptors of a multi-descriptors buffer, this conflicts with the spec which requires that the field is ignored excepted on the first data descriptor of a packet. Consequence: E1000 does not work well when it tries to use multi-descriptor for a packet. Fix: Check this field onyl for the first descriptor. Result: E1000 works well for solaris guest.
Clone Of:
Environment:
Last Closed: 2013-02-21 07:34:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0527 0 normal SHIPPED_LIVE qemu-kvm bug fix and enhancement update 2013-02-20 21:51:08 UTC

Description Joaquin 2012-05-08 15:38:56 UTC
Description of problem:
qemu emulation of e1000 nic does not follow the specification

Version-Release number of selected component (if applicable):
qemu versions below 0.15.1


How reproducible:
Start a virtual machine with some OS that has no virtio and does not work with the old e1000-emulator. 

At least all SunOS 5.10 or OpenSolaris and Illumos based systems like Solaris 10, Nexenta, SmartOS, Illumian, ...  are affected.


Steps to Reproduce:
1. create a virtual machine with e1000 NIC in a network with a DHCP-server
2. let it run the OpenIndiana live DVD
http://dlc-int.openindiana.org/repos/
Latest ISO at this moment is
oi_151a_prestable2_repo.tar.bz2
3. wait until the Gnome desktop is shown

or use any other affected OS and try to use the network
  
Actual results:
See that when the Gnome desktop is shown the system does not get a DHCP lease, the Network Manager icon remains orange
(sending out packets works, return packets are not received). 
(sudo) password when selecting the Network Manager is "openindiana"



Expected results:
The system will get a DHCP lease and the network is functional (i.e. in the Gnome desktop the network icon will turn green)


Additional info:
https://bugs.launchpad.net/qemu/+bug/638955

Comment 4 RHEL Program Management 2012-07-10 08:34:37 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 5 RHEL Program Management 2012-07-11 02:07:06 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 6 Ronen Hod 2012-07-23 07:21:04 UTC
Need to backport from upstream.

Comment 15 errata-xmlrpc 2013-02-21 07:34:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html


Note You need to log in before you can comment on or make changes to this bug.