Bug 819918 - Canon EOS DSLRs not working on USB 3 ports (ep 0x81, 0x2 - rounding interval to 32768 microframes, ep desc says 0 microframes)
Canon EOS DSLRs not working on USB 3 ports (ep 0x81, 0x2 - rounding interval ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libgphoto2 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 824719 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 11:50 EDT by James Ettle
Modified: 2013-05-23 08:48 EDT (History)
12 users (show)

See Also:
Fixed In Version: gphoto2-2.5.2-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-15 13:29:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsusb -vvvv with camera attached (51.77 KB, text/x-log)
2012-05-08 11:50 EDT, James Ettle
no flags Details
lspci -nnvv output (27.60 KB, text/plain)
2012-05-08 11:50 EDT, James Ettle
no flags Details
output from env LANG=C gphoto2 --debug --debug-logfile=gphoto2-debug.log -L (19.23 KB, text/plain)
2012-05-24 11:45 EDT, James Ettle
no flags Details

  None (edit)
Description James Ettle 2012-05-08 11:50:02 EDT
Created attachment 583026 [details]
lsusb -vvvv with camera attached

Description of problem:
My Canon EOS 60D and 400D DSLRs don't work when attached to a USB 3 port, but are fine on the USB 2 ports. (They work OK on these ports under Windows 7.)

Upon attaching the camera, I get:


[   72.674463] usb 3-1: new high-speed USB device number 2 using xhci_hcd
[   72.764255] usb 3-1: New USB device found, idVendor=04a9, idProduct=3215
[   72.764265] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   72.764272] usb 3-1: Product: Canon Digital Camera
[   72.764276] usb 3-1: Manufacturer: Canon Inc.
[   72.765264] usb 3-1: ep 0x81 - rounding interval to 32768 microframes, ep desc says 0 microframes
[   72.765275] usb 3-1: ep 0x2 - rounding interval to 32768 microframes, ep desc says 0 microframes


Running gphoto2 -L results in

                                                                 
*** Error ***              
PTP I/O error

*** Error ***              
An error occurred in the io-library ('Unspecified error'): No error description available
*** Error (-1: 'Unspecified error') ***       


lspci and lsusb outputs attached.

Other USB 2 devices seem to work OK on the USB 3 ports. I tested a USB 2 external disc drive; memory stick; and a Huawei mobile broadband modem. In all cases, however, there were messages of the form


[  402.718243] usb 3-2: ep 0x81 - rounding interval to 32768 microframes, ep desc says 0 microframes
[  402.718252] usb 3-2: ep 0x2 - rounding interval to 32768 microframes, ep desc says 0 microframes



Version-Release number of selected component (if applicable):
kernel-3.3.4-4.fc17.x86_64
libgphoto2-2.4.14-1.fc17.x86_64
libgphoto2-2.4.14-1.fc17.i686
udev-182-1.fc17.x86_64
Comment 1 James Ettle 2012-05-08 11:50:29 EDT
Created attachment 583027 [details]
lspci -nnvv output
Comment 2 James Ettle 2012-05-08 18:38:07 EDT
Just tried with a Panasonic compact camera on the same port in PTP mode, and it worked without any problems. Altered bug summary to reflect this.
Comment 3 James Ettle 2012-05-24 11:44:12 EDT
I've moved the component here to gphoto2 (clearly I have no idea which bit is at fault here), and I've attached the debugging output that gphoto2 suggests -- maybe this'll help shed some light on what's breaking.
Comment 4 James Ettle 2012-05-24 11:45:17 EDT
Created attachment 586669 [details]
output from env LANG=C gphoto2 --debug --debug-logfile=gphoto2-debug.log -L
Comment 5 James Ettle 2012-05-24 11:59:40 EDT
OK, another curious observation: gphoto2 -L *does* work with the Canons on a USB 3.0 port, but it only works ONCE, and then it has to be invoked quickly after attaching the camera (i.e., as soon as the computer recognises it).
Comment 6 Jarmo 2012-12-06 09:29:43 EST
This reproduces in F18 beta as well.
Comment 7 Fedora Admin XMLRPC Client 2013-04-09 11:19:36 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Hans de Goede 2013-05-02 03:55:08 EDT
This is likely fixed by this upstream commit:
https://sourceforge.net/p/gphoto/code/14268/

I'm preparing an update fixing this.
Comment 9 Hans de Goede 2013-05-02 03:55:45 EDT
*** Bug 824719 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2013-05-02 05:14:22 EDT
libgphoto2-2.5.1.1-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libgphoto2-2.5.1.1-3.fc19
Comment 11 Fedora Update System 2013-05-02 05:15:09 EDT
libgphoto2-2.5.1.1-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libgphoto2-2.5.1.1-3.fc18
Comment 12 Fedora Update System 2013-05-02 12:27:43 EDT
Package libgphoto2-2.5.1.1-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libgphoto2-2.5.1.1-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7246/libgphoto2-2.5.1.1-3.fc19
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2013-05-04 06:15:25 EDT
libgphoto2-2.5.1.1-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libgphoto2-2.5.1.1-4.fc19
Comment 14 Fedora Update System 2013-05-04 06:16:22 EDT
libgphoto2-2.5.1.1-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libgphoto2-2.5.1.1-4.fc18
Comment 15 Fedora Update System 2013-05-06 06:00:31 EDT
gphoto2-2.5.2-1.fc18, libgphoto2-2.5.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gphoto2-2.5.2-1.fc18,libgphoto2-2.5.2-1.fc18
Comment 16 Fedora Update System 2013-05-06 06:00:33 EDT
gphoto2-2.5.2-1.fc19, libgphoto2-2.5.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gphoto2-2.5.2-1.fc19,libgphoto2-2.5.2-1.fc19
Comment 17 Fedora Update System 2013-05-15 13:29:23 EDT
Package gphoto2-2.5.2-1.fc18, libgphoto2-2.5.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gphoto2-2.5.2-1.fc18 libgphoto2-2.5.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7548/gphoto2-2.5.2-1.fc18,libgphoto2-2.5.2-1.fc18
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2013-05-23 08:48:35 EDT
gphoto2-2.5.2-1.fc18, libgphoto2-2.5.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.