Bug 819985 - When a repo is unassociated from a CDS the content should be cleaned off the CDS
When a repo is unassociated from a CDS the content should be cleaned off the CDS
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: CDS (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: mkovacik
mkovacik
: Triaged
: 840477 (view as bug list)
Depends On:
Blocks: 802547
  Show dependency treegraph
 
Reported: 2012-05-08 15:31 EDT by James Slagle
Modified: 2012-08-24 07:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
For ISO versions prior to 2.1 for Red Hat Update Infrastructure (RHUI), contents are not removed from the CDS after a repository is unassociated from the CDS. Unassociated rpms still exists at /var/lib/pulp-cds/packages/. Fixed in cdslib.py, unassociated rpms are removed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 07:54:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Verifying screen log (34.20 KB, text/plain)
2012-08-02 07:28 EDT, mkovacik
no flags Details

  None (edit)
Description James Slagle 2012-05-08 15:31:48 EDT
When a repo is unassociated from a CDS the content should be cleaned off the CDS.  Optionally, we could have this behavior controlled by a parameter.
Comment 1 James Slagle 2012-05-08 15:33:20 EDT
This bug is for RHUI.  Make sure any commits are pulled down to the rhui branch.
Comment 2 James Slagle 2012-05-08 15:34:03 EDT
It would be nice if this could get done in Sprint 36 because the RHUI side of things will require changes to our documentation.
Comment 3 James Slagle 2012-05-09 12:25:17 EDT
Need to make sure the commit from Bug 800525 is pulled down into the rhui branch.
Comment 4 James Slagle 2012-07-16 20:49:00 EDT
*** Bug 840477 has been marked as a duplicate of this bug. ***
Comment 5 James Slagle 2012-07-16 20:49:35 EDT
cherry picked 1f52c49d459ed20c8971724147e961aa438df467 into pulp rhui branch
Comment 6 mkovacik 2012-08-02 07:28:16 EDT
Created attachment 601930 [details]
Verifying screen log

Having been deleted on the RHUA node, a repo is now deleted on CDS upon sync, too. The content is cached though (should be OK IMHO). See the screen log attached.

Build: RHEL-6.3-RHUI-2.1-20120801.0-Server-x86_64-DVD1.iso
Comment 7 Julie 2012-08-16 02:32:56 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
For ISO versions prior to 2.1 for Red Hat Update Infrastructure (RHUI), contents are not removed from the CDS after a repository is unassociated from the CDS. Unassociated rpms still exists at /var/lib/pulp-cds/packages/. Fixed in cdslib.py, unassociated rpms are removed.
Comment 9 errata-xmlrpc 2012-08-24 07:54:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1205.html

Note You need to log in before you can comment on or make changes to this bug.