Bug 820011 - gnome-terminal: pipe files leak
gnome-terminal: pipe files leak
Status: CLOSED DUPLICATE of bug 732391
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vte (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomáš Bžatek
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 17:32 EDT by Aristeu Rozanski
Modified: 2015-03-03 18:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-09 09:16:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aristeu Rozanski 2012-05-08 17:32:20 EDT
Description of problem:
Every time a new window is created then closed, two file descriptors remain open
if at least one terminal window is open, growing to the point it'll fail to open
further terminals because the file descriptor limit is hit.

Version-Release number of selected component (if applicable):
2.31.3-4.el6

How reproducible:
Always. Open a gnome-terminal window then run:

[aris@napanee ~]$ ls -1 /proc/$(pidof gnome-terminal)/fd | wc -l
31

keep the terminal window open. Run it again from the menu or a key binding
and then close the new window. repeat the command:

[aris@napanee ~]$ ls -1 /proc/$(pidof gnome-terminal)/fd | wc -l
33

while there's at least one gnome-terminal open, the open file number will keep
growing.
Comment 2 Tomáš Bžatek 2012-05-09 09:16:51 EDT

*** This bug has been marked as a duplicate of bug 732391 ***

Note You need to log in before you can comment on or make changes to this bug.