Bug 732391 - gnome-terminal gives "too many open files" error
Summary: gnome-terminal gives "too many open files" error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vte
Version: 6.4
Hardware: Unspecified
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Zeeshan Ali
QA Contact: Desktop QE
URL:
Whiteboard:
: 820011 917636 (view as bug list)
Depends On:
Blocks: 883503 963221
TreeView+ depends on / blocked
 
Reported: 2011-08-22 09:44 UTC by Taunus
Modified: 2018-12-04 14:28 UTC (History)
13 users (show)

Fixed In Version: vte-0.25.1-8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-14 10:46:45 UTC


Attachments (Terms of Use)

Description Taunus 2011-08-22 09:44:03 UTC
Description of problem:
After long usage of gnome-terminal without terminating the process, gnome-terminal gives "too many open files" error when open a new terminal.

Version-Release number of selected component (if applicable):
vte-0.25.1-6

How reproducible:
open gnome-terminal, open a new tabe by ctrl+shift+t, then close the newly opened tab, then look at the /proc/xxx/fd, you can see the newly opened fds are left unclosed.

Actual results:
"too many open files" error

Expected results:
Not too many open files

Additional info:
http://git.gnome.org/browse/vte/commit/?h=vte-0-26&id=c5ff71e924d7b3598e332392c4cc4c19e89a7d6f

Comment 1 Taunus 2011-08-26 13:11:37 UTC
I've tested the patch with vte-0.25.1-7.el6.x86_64 and 0.25.1-6 and it is ok.

Comment 4 Suzanne Yeghiayan 2012-02-14 23:14:05 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 5 karen cooper 2012-04-02 16:12:32 UTC

I'm using vte-0.25.1-7.el6.x86_64 and I am seeing this bug.  
running lsof shows that every time I open and close an xterm I get another open file and when I get to ~600 I start having problems and am unable to open new terminal windows.  The only way I have found to clear them is to restart X.

Comment 6 Tomáš Bžatek 2012-04-03 08:37:32 UTC
(In reply to comment #5)
> I'm using vte-0.25.1-7.el6.x86_64 and I am seeing this bug.  
> running lsof shows that every time I open and close an xterm I get another open
> file and when I get to ~600 I start having problems and am unable to open new
> terminal windows.  The only way I have found to clear them is to restart X.

No need to restart X, just make sure to close all windows of gnome-terminal. It shares a single process within a running desktop session across all windows and tabs.

There's a patch available, please escalate to your support representative if you need to have this issue fixed in reasonable time.

Comment 7 karen cooper 2012-04-03 14:27:13 UTC
Ah.  Yes if I close all terminal windows it drops back down.  

Can you tell me if this is going to be fixed in RedHat 6?  We have a number of systems where I work and only recently have we been pushing users to go to EL6, and I'm concerned this could be a problem for some of them.  

It is definitely a problem for me as a systems administrator.   I tend to have many terminal windows open and I ran into this problem relatively quickly.  There are some windows that I use for monitoring that I typically keep open all the time, so having to close all of my terminal windows, while do-able, is painful.

Comment 8 Tomáš Bžatek 2012-05-09 13:16:51 UTC
*** Bug 820011 has been marked as a duplicate of this bug. ***

Comment 10 RHEL Product and Program Management 2012-07-10 08:00:01 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 11 RHEL Product and Program Management 2012-07-11 02:03:27 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 12 Matthias Saou 2012-07-18 11:47:00 UTC
I've been using a custom rebuilt vte package that includes the patch mentioned above for a while, as otherwise my RHEL6 workstation becomes useless very quickly. I also really hope this gets resolved for 6.4.

Comment 13 RHEL Product and Program Management 2012-09-07 05:27:41 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 14 Mike Leech 2012-10-23 08:02:25 UTC
I can't believe this bug isn't going to be fixed in 6.4! The is badly affecting my users. I'll put in a support call and see if this can't be sorted out.

Comment 15 Tomáš Bžatek 2012-10-23 09:36:57 UTC
(In reply to comment #14)
> I can't believe this bug isn't going to be fixed in 6.4! The is badly
> affecting my users. I'll put in a support call and see if this can't be
> sorted out.

Please do, this is an easy fix from development perspective, proper escalation to support representative makes things faster.

Comment 17 Tomáš Bžatek 2013-03-04 15:09:00 UTC
*** Bug 917636 has been marked as a duplicate of this bug. ***

Comment 25 RHEL Product and Program Management 2013-05-06 21:18:15 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 26 Zeeshan Ali 2013-05-07 13:23:54 UTC
Fixed in vte-0.25.1-8.


Note You need to log in before you can comment on or make changes to this bug.