This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 820040 - [ja_JP] [RHSM CLI] repos module --help message_some strings displayed as question mark.
[ja_JP] [RHSM CLI] repos module --help message_some strings displayed as que...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
: i18n
Depends On: 752316 771751
Blocks: 738066 807971 771748
  Show dependency treegraph
 
Reported: 2012-05-08 20:45 EDT by Lijun Li
Modified: 2013-01-10 06:01 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 752316
Environment:
Last Closed: 2012-06-20 08:57:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 2 Ankit Patel 2012-05-10 01:35:04 EDT
isn't this bug duplicate of bug 820030 ?
Comment 3 Michael Stead 2012-05-10 08:26:30 EDT
The seem very similar but it is filed against separate subscription-manager modules -- each with different strings.

The fix for both will likely be the same.
Comment 4 Adrian Likins 2012-05-10 10:38:15 EDT
commit aa2020706aedac193f5f869f16610c43694ac3c5
Author: Adrian Likins <alikins@redhat.com>
Date:   Wed May 9 11:39:29 2012 -0400

    820040,820037,820030: don't break multibyte help blurbs
    
    Add a optparse.HelpFormatter subclass that includes
    a version of format_option that does not try to split
    long words.This behavior is broken for multibyte cases.
    
    This includes code cut&paste from optparse.py in
    the python dist.

Should show up in 0.99.18
Comment 7 Lijun Li 2012-05-18 03:11:15 EDT
Verified, it's fixed on subscription-manager-0.99.18-1.el6.x86_64.
Comment 10 errata-xmlrpc 2012-06-20 08:57:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.