Bug 82017 - [RFE] Integrated Virus/SPAM scanning.
[RFE] Integrated Virus/SPAM scanning.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Faustyn
: FutureFeature
: 89827 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-16 07:16 EST by Oliver Jones
Modified: 2007-11-30 17:10 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-29 01:17:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Jones 2003-01-16 07:16:03 EST
Request for enhancement.
------------------------

Future versions of RedHat Linux would benefit from having a pre-packaged mail
virus/spam scanner.

I've found that MailScanner (http://www.mailscanner.info) is a good scanner
under constant development.

It works in confunction with many virus scanners (commercial and free).  The
"clam" (http://clamav.elektrapro.com/) antivirus scanner could be packaged also
to provide the actual antivirus engine.

I think this would be a great addition to future versions of RH Linux.
Comment 1 Michael Lee Yohe 2003-01-16 11:25:37 EST
SpamAssassin, touted as one of the best SPAM finders, is already included with
Red Hat Linux 8.0.  I have seen, through my use of SpamAssassin, that it
captures most virus-attached emails and flags them as SPAM.
Comment 2 Florian La Roche 2003-01-20 09:23:52 EST
We are currently adding spamassassin and that seems to work pretty good.
Chip, can you take over RFE handling on this and decide if more rpm packages
should be added into future products in addition to spamas.?

Thanks,

Florian La Roche
Comment 3 Thomas M Steenholdt 2003-02-14 02:38:57 EST
Just casting my vote on this RFE!

I'm also under the impression that virus scanning software is becoming
increasingly vital for Linux servers... As more and more Linux servers are
posing as file servers for the aparently more voulnerable windows clients and
that also makes it more vital to have a solution in place to secure the shared
files from viral infections. Of course this can be done at corporate level by
purchasing proprietary antivirus software for Linux, Red Hat would certainly
benefit from having an open source alternative shipped with it! :o)
Comment 4 Stephen John Smoogen 2003-09-12 14:15:54 EDT
I would also like to see some sort of anti-virus/anti-attachment integrated into
the distribution. We are currently using mimedefang and hope to tie it in with
spam-assassin and clam to help cut down our virus checking problems. Having
these in official RPMS would help us sell it to management better (heck it would
get us instant approval for RHE).
Comment 5 Christian Rose 2003-10-26 11:26:34 EST
Seconded, I really would like to see an AV solution prepackaged in Fedora
Core/RHEL. clamav/mailscanner is what comes to mind in my case.
Comment 6 Thomas M Steenholdt 2004-01-02 07:15:12 EST
Just my vote for this RFE...

I absolutely agree that we need some antivirus/antiattachment stuff
included in the distro... clamav, clamdmail and/or amavis perhaps?!?

What's the status on this anyway? Any chance to see some of this any
time soon???
Comment 7 Thomas M Steenholdt 2004-01-28 09:42:27 EST
Please move this bug to devel (i'm not powerful enough to do so), so
that it will continue to be an outstanding RFE until somebody actually
takes the time to include it in the distro!!!
Comment 8 Paul Eden 2004-04-30 01:30:03 EDT
I completely agree to adding mailscanner and clamav (in addition to
the already packaged spamassassin) as official rpms.
Comment 9 Paul Eden 2004-04-30 01:45:36 EDT
This would make the setup and justification of Red Hat linux email
servers in hetergenious environments much easier.
Comment 10 Doncho N. Gunchev 2004-05-29 19:57:28 EDT
    SpamAssassin can be easily integrated with sendmail. To do so with
postfix I changed in /etc/postfix/master.cf the following:
--- cut ---
#smtp   inet  n       -       n       -       -       smtpd
smtp    inet  n       -       n       -       -       smtpd
        -o content_filter=postfixsa:
postfixsa unix   -   n       n       -       -       pipe
        flags=Rq user=spamassassin:spamassassin
argv=/etc/postfix/filters/safilter -f ${sender} -- ${recipient}
--- cut ---
and added user and group spamassassin:spamassassin. Now spamassassin
works for the whole system and stores it's data in /home/spamassassin
(should be /var/something I think).
    It would be nice to have this at least as a note somewhere in the
spamassassin's docs. I don't know if this is the best way to do this,
but it seems to me that sendmail is much better supported than
postfix(which looks better to me). Antivirus software like clamav
would be great to have too...
Comment 11 Marius Andreiana 2004-06-01 07:26:25 EDT
There's also Amavis
http://www.amavis.org/
as alternative to mail scanner. I don't know which is better.

Both amavis and clamav are already packaged by other fedora
repositories, but they aren't integrated with postfix.
Would be great to have more integration, ideally only a on/off
parameter in a postfix/sendmail config file to enable server-side
spamassasin and clamav.
Comment 12 Thomas M Steenholdt 2004-06-01 08:51:49 EDT
How about just making clamav available (based on the clamav contrib.
available from here http://crash.fce.vutbr.cz/crash-hat/1/clamav/ -
these are of much higher quality and much easier to use than what was
available on fedora.us last time i checked) Then simply include a
procmail based scanner for a start... trashscan, clamassassin or
something like that. 
Comment 13 Doncho N. Gunchev 2004-06-01 17:49:15 EDT
    I use sagator (http://sagator.sf.net/) at one machine and it 
works well. The project seems quite alive and quite promising - there 
are versions for FC1 and FC2 in yum repository maintained by the 
author. It integrates well with postfix, clamav(clamlib/clamd) and 
spamassassin, runs in chrooted jail and has %trigger-s which does add 
needed packages to the chrooted jail like zoo when the package is 
installed. The program is written in Python and C. 
Comment 14 Elliot Lee 2004-08-24 17:01:39 EDT
*** Bug 89827 has been marked as a duplicate of this bug. ***
Comment 15 Doncho N. Gunchev 2004-11-30 09:27:09 EST
    I use sagator with all my mail servers now. The only problem for
now is the lack of good documentation, but it does full postfix/mrtg
integration itself (+ rpm triggers). The new version (0.5.4 from
2004-11-29) is faster, adds /etc/yum.repos.d/sagator.repo (autoupdate)
and is available for FC1, FC2 and FC3. It can drop/quarantine mail
with attachments based on their file extension and mime type (I got
lot's of .wav executables these days). Works with bouth postfix and
sendmail (should work with any MTA).
    What about reassigning this bug to FC4/devel? I voute for sagator,
amavis/amavis-new and clamav for inclusion.
Comment 16 Oliver Jones 2004-11-30 18:43:03 EST
If there was to be some packaging of AV, Anti-Spam, etc into FC and
RHEL  (and there appears to be some movement in this direction with
SpamAssassin etc) it would be best to have it be a complete solution.
 Ie, something with an easy to use management interface.

Others have pointed out a number of different solutions.  I personally
have experience with sendmail, ClamAV, MailScanner and SpamAssassin. 
But from a total package perspective this might not be the best
combination.  A recent article in Linux Journal (or was it Linux
Magazine?) regarding Maia Mailguard
(http://www.renaissoft.com/projects/maia/) suggests that a
amavisd-new, ClamAV, sendmail, and Maia suite might provide a more
complete and user/admin friendly package.

Probably the best way of getting this sort of suite into a future FC
release would be to start creating (or aggregating/tweaking existing)
RPM packages.  Then deploy yum and apt repositories for this package
set.  After a reasonable period of user testing it could be proposed
for inclusion into Feodra Core or Fedora Extras.
Comment 17 Warren Togami 2005-04-29 01:17:23 EDT
Fedora Extras now contains great clamav packages along with optional
spamassassin helpers like pyzor, razor and dcc.  More anti-spam tools can be
added to Extras if you join the project and help in packaging.

Note You need to log in before you can comment on or make changes to this bug.