Bug 820180 - Request for watch 0.3.0
Request for watch 0.3.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
:
: 801626 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 06:54 EDT by Tom Klingenberg
Modified: 2016-01-31 20:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-27 14:52:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Klingenberg 2012-05-09 06:54:17 EDT
Currently in Fedora 16 I have watch 0.2.0.

I'd like to have watch 0.3.0 which is available because it has the `--color` switch.
Comment 1 Jaromír Cápík 2012-05-09 07:33:20 EDT
Hello Tom.

AFAIK watch 0.3.0 has never been officially released by the procps (legacy) upstream. The change is available only in form of unofficial patches and as it introduces also UTF8/widechar related changes, it's questionable if such change is minor enough to be considered appropriate for inclusion in already released Fedora 16.
Anyway ... Fedora 18 brings completely reborn next generation procps tools (called procps-ng) including the --color switch. The legacy version became almost unmaintainable and that's why we decided to drop it completely and replace it with procps-ng in Fedora 18.
Please, let me know if you can wait for Fedora 18 or if you really need the requested feature in Fedora 16.

Thank you and have a nice day.

Regards,
Jaromir.
Comment 2 Tom Klingenberg 2012-05-10 07:55:27 EDT
Hello Jaromir,

thanks for the clarification. I was wondering as well because on sourceforge.net I could only find the sources updated until the year 2009 and that codebase was without the --color switch. But found it in some git tree.

Would it be appropriate to get in contact with the current fedora package maintainer and ask to patch for the color switch? AFAIK it's something minor and so probably easily done. Or can I just patch it on my own and rebuild the package (technically this should be possible right? - but I've never done that only tested some rawhide packages in bugreporting).
Comment 3 Jaromír Cápík 2012-05-11 04:45:15 EDT
Hello Tom.

I'm the Fedora's procps maintainer. It is not about the patch creation. It's about the Fedora's update policy I have to follow. If we talk about package updates in scope of stable Fedora releases, then the updates should only aim to fix bugs, and not introduce new features, particularly when those features would materially affect the user or developer experience. Moreover procps can be considered a critical path package and therefore it shouldn't be touched unless it's major functions are broken. So, even if the feature introduction might be easy, we can't simply touch it unless we have a really good reason to do so. And I must admit that I'm really struggling to do that in this case.
I could create something like diagnostic build and share it for testing purposes here, but it would be easier to do a scratch-build of procps-ng for f16 and share it instead of patching the legacy procps version.

Please, let me know if you would like to test the procps-ng 3.3.2 on Fedora 16 instead. That wouldn't be so time consuming and could work better than the currently available F16 version. Just note, that any of these testing packages would probably never get to the official F16 repository.

Please, let me know.

Thank you.

Regards,
Jaromir.
Comment 4 Tom Klingenberg 2012-05-11 09:56:28 EDT
Hi Jaromir,

thanks again for the detailed and well understandable feedback.

You can ask me anytime to test those packages, I'm planing to migrate to Fedora 17 relativly early (after stable release) so if I should test on that version as well, let me know. I also have a Fedora 17 beta install on some other location so I can test there as well (if this helps you).

Thank you!

Kind regards,
Tom
Comment 5 Jaromír Cápík 2012-05-21 12:03:22 EDT
Hi Tom.

You can download the procps-ng scratch-builds from the following two locations:

http://jcapik.fedorapeople.org/files/procps-ng/f16/
http://jcapik.fedorapeople.org/files/procps-ng/f17/

Please, let me know if you like the new version or not. Just a note. The new version is not 100% compatible with the previous one. If there's any important feature missing, then let me know, please.

Thank you and have a nice day.

Regards,
Jaromir.
Comment 6 Tom Klingenberg 2012-05-23 06:08:46 EDT
Hi Jaromir,

I could install the rpm with no problem, the output is not working as expected but I have not analyzed it so far, it looks like two characters are "eaten". Just for reference, I should file a proper bug-report instead maybe, let me know which kind of feedback you prefer:

Standard command, as expected, with colors in output:

    $ phpunit tests/Composer/Test/Util/SpdxLicenseIdentifierTest.php

Watch command, w/o colors:

    $ watch -n 1 phpunit tests/Composer/Test/Util/SpdxLicenseIdentifierTest.php

Gives the "ansi codes" (I do not even know if these are really the correct terms) like:

    [30;42m[2KOK (196 tests, 196 assertions)
    [0m[2K

Now with colors enabled:

    $ watch -c -n 1 phpunit tests/Composer/Test/Util/SpdxLicenseIdentifierTest.php

It gives no colored output, but the ansi codes are stripped and a space and the opening bracket ( is missing, compare:

    tests, 196 assertions)

This is just for refrence / quick feedback. I have not verified if the phpunit software does actually use the standard codes here (I assume it does). What I can say is, that it works in the terminal when called (here the first command line example). It does not work with using the watch --color (or -c) switch in the same terminal (I'm using the standard gnome terminal).

As some characters are stripped, I might should provide my locale info:


$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

I also tried with the -x switch but I think that's specially for ubuntu which uses dash and not bash for sh and it's behaving differently because of being more POSIX strict.
Comment 7 Jaromír Cápík 2012-06-04 07:56:45 EDT
Hi Tom.

Yes, please. Create a new bug report filled against procps-ng in Fedora Rawhide. I would close this one if you have no objections.

Thanks in advance.

Regards,
Jaromir.
Comment 8 Jaromír Cápík 2012-07-27 14:46:05 EDT
*** Bug 801626 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.