Bug 820367 - Creating kickstart profile fails after step 3 with "Internal Server Error"
Creating kickstart profile fails after step 3 with "Internal Server Error"
Status: CLOSED DUPLICATE of bug 817816
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.7
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-05-09 14:59 EDT by daniel
Modified: 2012-11-01 12:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-09 15:29:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description daniel 2012-05-09 14:59:56 EDT
Description of problem:
When setting up a spacewalk server for installing via kickstart I've run into trouble when trying to create a new kickstart profile in step three and get an internal server error. I found lots of similar posts but unfortunatelly no solution, so I open an new report


Version-Release number of selected component (if applicable):
Spacewalk server 1.7 and Centos 6.2 both installed and updated today (fresh install)


How reproducible:


Steps to Reproduce:
1.Step 1: Create Kickstart Profile ->next 
2.Step 2: Distribution File Location (default)-> next 
3.Step 3: Root Password -> enter pw -> next  --> 'Internal Server Error '

--> I get a Mail "WEB TRACEBACK from spacewalk.xxx.xxxx (5/9/12 8:29:31 PM CEST)"
  
Actual results:

-> failed, no result

Expected results:

-> having a working kickstart profile

Additional info:

Mail I get:


-----------------8<----------------------8<--------------
From dev-null@localhost.xxxx.xxx  Wed May  9 20:29:33 2012
Return-Path: <dev-null@localhost.xxxx.xxx>
X-Original-To: root@localhost
Delivered-To: root@localhost.xxxx.xxx
From: Spacewalk <dev-null@localhost.xxxx.xxx>
To: root@localhost.xxxx.xxx
Subject: WEB TRACEBACK from spacewalk.xxxx.xxx (5/9/12 8:29:31 PM CEST)
Content-Type: text/plain; charset=UTF-8
Date: Wed,  9 May 2012 20:29:33 +0200 (CEST)
Status: R

The following exception occurred while executing this request:
POST /rhn/kickstart/CreateProfileWizard.do

Date:5/9/12 8:29:31 PM CEST
Headers:
  host: localhost
  user-agent: Mozilla/5.0 (X11; Linux i686; rv:10.0.4) Gecko/20120425 Firefox/10.0.4
  accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  accept-language: en-us,en;q=0.5
  accept-encoding: gzip, deflate
  connection: keep-alive
  referer: https://localhost/rhn/kickstart/CreateProfileWizard.do
  cookie: JSESSIONID=2BEB12219A01AE6AB6B81DE3CB32612F; pxt-session-cookie=13xbde29948b48b8252fcbf79d194f8db0e
  content-type: application/x-www-form-urlencoded
  content-length: 260

Request:
Local Name = localhost
Server Name = localhost
Requested Session Id came from Cookie
Requested Session Valid = true
Session = org.apache.catalina.session.StandardSessionFacade@2ef2d7[session=StandardSession[2BEB12219A01AE6AB6B81DE3CB32612F]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, javax.servlet.jsp.jstl.fmt.timeZone.request, javax.servlet.error.status_code, javax.servlet.error.servlet_name, javax.servlet.request.key_s
ize, requestedUri, kickstartCreateWizardForm, javax.servlet.request.ssl_session, org.apache.struts.action.MESSAGE, javax.servlet.error.message, session, javax.servlet.reque
st.cipher_suite, javax.servlet.error.exception, org.apache.struts.action.mapping.instance, javax.servlet.error.request_uri, org.apache.struts.action.MODULE, 

Form Variables:
  prevStep: second
  rootPasswordConfirm: password
  rootPassword: password
  defaultDownload: true
  virtualizationTypeLabel: none
  nextStep: complete
  kickstartLabel: centos_58-ks
  kstreeId: 1
  userDefinedDownload: 
  submitted: true
  csrf_token: 6590605816377132148
  wizardStep: complete


User Information:
User admin (id 1, org_id 1)

Exception:
javax.servlet.ServletException: java.lang.reflect.InvocationTargetException
	at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:520)
	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:427)
	at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:228)
	at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:99)
	at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1913)
	at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:462)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:91)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.opensymphony.sitemesh.webapp.SiteMeshFilter.obtainContent(SiteMeshFilter.java:129)
	at com.opensymphony.sitemesh.webapp.SiteMeshFilter.doFilter(SiteMeshFilter.java:77)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:769)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:698)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:891)
	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
	at java.lang.Thread.run(Thread.java:679)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at com.redhat.rhn.frontend.struts.wizard.WizardStep.invoke(WizardStep.java:116)
	at com.redhat.rhn.frontend.struts.wizard.RhnWizardAction.dispatch(RhnWizardAction.java:103)
	at com.redhat.rhn.frontend.struts.wizard.RhnWizardAction.execute(RhnWizardAction.java:89)
	at com.redhat.rhn.frontend.action.kickstart.CreateProfileWizardAction.execute(CreateProfileWizardAction.java:104)
	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:425)
	... 40 more
Caused by: java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Double
	at org.cobbler.CobblerConnection.getVersion(CobblerConnection.java:174)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.getCobblerVersion(CobblerXMLRPCHelper.java:123)
	at com.redhat.rhn.manager.kickstart.KickstartFormatter.getFileData(KickstartFormatter.java:252)
	at com.redhat.rhn.domain.kickstart.KickstartFactory.saveKickstartData(KickstartFactory.java:359)
	at com.redhat.rhn.domain.kickstart.KickstartFactory.saveKickstartData(KickstartFactory.java:393)
	at com.redhat.rhn.manager.kickstart.KickstartWizardHelper.store(KickstartWizardHelper.java:189)
	at com.redhat.rhn.domain.kickstart.builder.KickstartBuilder.create(KickstartBuilder.java:545)
	at com.redhat.rhn.frontend.action.kickstart.CreateProfileWizardAction.runComplete(CreateProfileWizardAction.java:283)
	... 49 more

----------------->8---------------------->8--------------


and in the catalina.out:

-----------------8<----------------------8<--------------
2012-05-09 20:52:58,810 [TP-Processor1] WARN  org.apache.struts.action.RequestProcessor - Unhandled Exception thrown: class java.lang.reflect.InvocationTargetException
2012-05-09 20:52:58,811 [TP-Processor1] ERROR com.redhat.rhn.frontend.servlets.SessionFilter - Error during transaction. Rolling back
javax.servlet.ServletException: java.lang.reflect.InvocationTargetException
	at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:520)
	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:427)
	at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:228)
	at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:99)
	at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1913)
	at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:462)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:91)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.opensymphony.sitemesh.webapp.SiteMeshFilter.obtainContent(SiteMeshFilter.java:129)
	at com.opensymphony.sitemesh.webapp.SiteMeshFilter.doFilter(SiteMeshFilter.java:77)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:769)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:698)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:891)
	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
	at java.lang.Thread.run(Thread.java:679)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at com.redhat.rhn.frontend.struts.wizard.WizardStep.invoke(WizardStep.java:116)
	at com.redhat.rhn.frontend.struts.wizard.RhnWizardAction.dispatch(RhnWizardAction.java:103)
	at com.redhat.rhn.frontend.struts.wizard.RhnWizardAction.execute(RhnWizardAction.java:89)
	at com.redhat.rhn.frontend.action.kickstart.CreateProfileWizardAction.execute(CreateProfileWizardAction.java:104)
	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:425)
	... 40 more
Caused by: java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Double
	at org.cobbler.CobblerConnection.getVersion(CobblerConnection.java:174)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.getCobblerVersion(CobblerXMLRPCHelper.java:123)
	at com.redhat.rhn.manager.kickstart.KickstartFormatter.getFileData(KickstartFormatter.java:252)
	at com.redhat.rhn.domain.kickstart.KickstartFactory.saveKickstartData(KickstartFactory.java:359)
	at com.redhat.rhn.domain.kickstart.KickstartFactory.saveKickstartData(KickstartFactory.java:393)
	at com.redhat.rhn.manager.kickstart.KickstartWizardHelper.store(KickstartWizardHelper.java:189)
	at com.redhat.rhn.domain.kickstart.builder.KickstartBuilder.create(KickstartBuilder.java:545)
	at com.redhat.rhn.frontend.action.kickstart.CreateProfileWizardAction.runComplete(CreateProfileWizardAction.java:283)
	... 49 more

----------------->8---------------------->8--------------
Comment 1 Jan Pazdziora 2012-05-09 15:29:39 EDT

*** This bug has been marked as a duplicate of bug 817816 ***

Note You need to log in before you can comment on or make changes to this bug.