Bug 817816 - Error when adding/trying to modify kickstart profiles
Error when adding/trying to modify kickstart profiles
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: cobbler (Show other bugs)
el6
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: James C.
Fedora Extras Quality Assurance
:
: 819497 820367 834433 835878 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 08:20 EDT by kwyjibo
Modified: 2012-06-27 10:13 EDT (History)
15 users (show)

See Also:
Fixed In Version: 2.2.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 21:34:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Complete log file (111.14 KB, text/plain)
2012-05-01 08:20 EDT, kwyjibo
no flags Details

  None (edit)
Description kwyjibo 2012-05-01 08:20:26 EDT
Created attachment 581359 [details]
Complete log file

Description of problem:

When trying to modify or add to a kickstart profile I am getting the following error:
ERROR: redstone.xmlrpc.XmlRpcFault: unhandled internal exception: java.lang.String cannot be cast to java.lang.Double

This is only a recent development as it was working up until the latest batch of updates (which included cobbler)

Version-Release number of selected component (if applicable):
Spacewalk 1.6
cobbler 2.2.2.1

How reproducible:
100% (for me at least)

Steps to Reproduce:
1. Update cobbler to 2.2.2.1
2. spacecmd kickstart_addpackages <whatever profile> <any package>
  
Actual results:
ERROR: redstone.xmlrpc.XmlRpcFault: unhandled internal exception: java.lang.String cannot be cast to java.lang.Double

Expected results:
Success! Spacewalk love you long time!

Additional info:
Comment 1 fjacquet 2012-05-02 02:00:55 EDT
Got this exception with spacewalk 1.7

Caused by: java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Double
	at org.cobbler.CobblerConnection.getVersion(CobblerConnection.java:174)
Comment 2 Mat Kovach 2012-05-02 09:03:30 EDT
Has this problem yesterday.

Turns out that cobbler was upgraded that morning.

Did the following to backout cobbler:

tar -pczvf /var/tmp/cobbler-backup.tar.gz /etc/cobbler /var/log/cobbler

yum downgrade cobbler* 

 * one could also rpm -e --nodeps cobbler and then rpm -ivh <old cobbler rpm>

Copied the configuration files back.

The cobbler daemon didn't like the switch and I ended up rebooting. Of course, I could have forgotten to stop cobbler BEFORE the downgrade. But, it was early and my coffee level was low.

This brought me back to normal operation of Spacewalk.
Comment 3 Jan Pazdziora 2012-05-02 15:57:18 EDT
https://www.redhat.com/archives/spacewalk-devel/2012-April/msg00065.html

What OS do you use? This needs to be reported to either Fedora or Fedora EPEL, depending on what you use.
Comment 4 Mat Kovach 2012-05-02 15:59:47 EDT
Using cobbler from the Fedora EPEL repo.

I thought I reported it there, but .. like I said coffee underflow makes things sketchy.
Comment 5 Jan Pazdziora 2012-05-03 07:41:31 EDT
No worries. Flipping the product to Fedora EPEL.
Comment 6 Jan Pazdziora 2012-05-07 12:59:05 EDT
Fedora version of this bug is bug 819497.
Comment 7 Jan Pazdziora 2012-05-09 15:29:39 EDT
*** Bug 820367 has been marked as a duplicate of this bug. ***
Comment 8 Pascal Peltriaux 2012-05-14 23:45:12 EDT
Hi guys,

I had exactly the same issue running Spacewalk 1.6 and spacewalk 1.7 with cobbler 2.2.2.

This issue is due to a java code function that try to cast the cobbler version (that is returned as a string) to a double: (tomcat logs)

Caused by: java.lang.ClassCastException: java.lang.String cannot be cast to
java.lang.Double
 at org.cobbler.CobblerConnection.getVersion(CobblerConnection.java:174)

Until this issue is fixed in the code, you can fixed it temporarily by modifying the cobbler version file in :
   /etc/cobbler/version 

Changing the version line
   version: 2.2.2 
to 
   version: 2.2

Its not perfect but it will fix the issue until the java code is updated.

Regards,

Pascal
Comment 9 Tiago Pires 2012-05-18 09:39:36 EDT
Hi guys,

I'm using the spacewalk 1.7 on CentOS 6.2 with cobbler 2.2.2 , I had the same problem with tomcat.
After changing the line version of the file /etc/cobbler/version, I can create the kickstart, but I have a problem to view the file via kickstart interface spacewalk.

Error:

•There are errors in your kickstart template. Please check the <a href="/rhn/kickstart/KickstartFileDownload.do?ksid=2">template errors</a> to determine the problem with the template

In apache log:

[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33] mod_wsgi (pid=4733): Exception occurred processing WSGI script '/var/www/cobbler/svc/services.py'.
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33] Traceback (most recent call last):
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33]   File "/var/www/cobbler/svc/services.py", line 79, in application
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33]     content = func( **form )
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33]   File "/usr/lib/python2.6/site-packages/cobbler/services.py", line 76, in ks
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33]     data = self.remote.generate_kickstart(profile,system,REMOTE_ADDR,REMOTE_MAC)
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33]   File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33]     return self.__send(self.__name, args)
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33]   File "/usr/lib64/python2.6/xmlrpclib.py", line 1489, in __request
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33]     verbose=self.__verbose
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33]   File "/usr/lib64/python2.6/xmlrpclib.py", line 1253, in request
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33]     return self._parse_response(h.getfile(), sock)
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33]   File "/usr/lib64/python2.6/xmlrpclib.py", line 1387, in _parse_response
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33]     p.feed(response)
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33]   File "/usr/lib64/python2.6/xmlrpclib.py", line 601, in feed
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33]     self._parser.Parse(data, 0)
[Fri May 18 10:35:58 2012] [error] [client 10.0.3.33] ExpatError: not well-formed (invalid token): line 151, column 0


In my searches on google, I don't found the solution, someone could help me?
Comment 10 James C. 2012-05-21 21:34:12 EDT
This has been corrected in the current master branch, and will be fixed in version 2.2.3.

In the meantime, you can build an updated RPM by checking out the github release22 branch and issuing the command "make rpms". This branch is currently the beta of 2.2.3 and the RPMs built will have that version. 


commit 053f0c52f01a119fdb780bf4e4d39d8817ae5a2b
Author: James Cammarata <jimi@sngx.net>
Date:   Sat Apr 21 04:12:02 2012 -0500

    Reverting commit 1d6c53a97, which was breaking spacewalk
    Changed the web interface stuff to use the existing extended_version() remote call
Comment 11 James C. 2012-05-21 21:41:42 EDT
*** Bug 819497 has been marked as a duplicate of this bug. ***
Comment 12 Jan Pazdziora 2012-06-27 10:08:52 EDT
*** Bug 835878 has been marked as a duplicate of this bug. ***
Comment 13 Jan Pazdziora 2012-06-27 10:13:57 EDT
*** Bug 834433 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.