Bug 820584 - [as7] code in discovery that figures out System property (sysprop) values by parsing the server command line does not process -P/--properties option
[as7] code in discovery that figures out System property (sysprop) values by ...
Status: CLOSED DUPLICATE of bug 820570
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.4
Unspecified Unspecified
urgent Severity high (vote)
: ---
: JON 3.1.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On: 819145
Blocks: as7-plugin jon310-sprint11/rhq44-sprint11 820570
  Show dependency treegraph
 
Reported: 2012-05-10 08:23 EDT by Charles Crouch
Modified: 2015-02-01 18:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 819145
Environment:
Last Closed: 2012-05-10 08:25:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2012-05-10 08:23:50 EDT
+++ This bug was initially created as a clone of Bug #819145 +++

standalone.sh/bat and domain.sh/bat both support the following command line options:

    -P=<url>                            Load system properties from the given 
                                        url

    -P <url>                            Load system properties from the given 
                                        url

    --properties=<url>                  Load system properties from the given 
                                        url

--- Additional comment from mfoley@redhat.com on 2012-05-08 14:11:28 EDT ---

per BZ triage crouch, foley, loleary

--- Additional comment from ian.springer@redhat.com on 2012-05-09 20:18:00 EDT ---

Fixed in master: 

http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commitdiff;h=7b1a63a

Note, AS7 support more than one -P and/or --properties option on the same command line, and our code handles that.

--- Additional comment from ian.springer@redhat.com on 2012-05-10 08:06:51 EDT ---

Note, the unit test for this fix (AS7CommandLineTest) depends on the fix for bug 820445.
Comment 1 Charles Crouch 2012-05-10 08:25:31 EDT

*** This bug has been marked as a duplicate of bug 820570 ***

Note You need to log in before you can comment on or make changes to this bug.