Bug 820670 - Math TR1 isn't included
Math TR1 isn't included
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: boost (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Machata
Miroslav Franc
:
Depends On:
Blocks: FEniCS
  Show dependency treegraph
 
Reported: 2012-05-10 12:12 EDT by Jonathan Underwood
Modified: 2016-01-31 21:27 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-02 03:38:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2012-05-10 12:12:25 EDT
Description of problem:
It seems that the TR1 component (at least) of the booth-math library isn't shipped. This seems to have been fixed in Fedora BZ#771370 but not backported to RHEL6. 

Version-Release number of selected component (if applicable):
1.41.0-11.el6_1.2
Comment 2 Jonathan Underwood 2012-05-10 19:35:57 EDT
The SRPM here: 

http://jgu.fedorapeople.org/boost-1.41.0-11.el6.2.1.src.rpm

has a backport of the patch from Fedora commit 54ddcfc4141588bfa65356a1cd97aa2ecd8c3cdf which enables building of TR1, and also includes your patch for BZ #801534. I have it building overnight in mock presently.

Prospects for pushing an update?
Comment 3 Petr Machata 2012-05-11 17:57:29 EDT
This would be easy to backport and should be straightforward to test.  TR1 libraries are part of boost and it is an omission not to ship them.  People including headers from boost sub-tree (#include <boost/tr1/memory.hpp>) would notice this, otherwise (#include <memory>) I believe our core system is sufficiently complete to support TR1 even without boost.
Comment 4 Jonathan Underwood 2012-05-11 19:53:11 EDT
OK - I can confirm that the backported patch added to the RPM above does resolve this problem (as well as 801534). 

Thanks for your response. But I can't work out from your response whether you're saying a bug fix package will be pushed to rhel or not?

I am in the process of packaging up the FEniCS tools[1] for EPEL and Fedora, and without these two fixes we won't be able to include it in EPEL.

[1] http://fenicsproject.org
Comment 5 Petr Machata 2012-05-13 13:20:36 EDT
(In reply to comment #4)
> Thanks for your response. But I can't work out from your response whether
> you're saying a bug fix package will be pushed to rhel or not?

It was a statement that the engineering part is not a problem.  But there are more players in the process, and resource allocation compromises may prevent us from shipping this.
Comment 7 RHEL Product and Program Management 2012-07-10 04:10:42 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2012-07-10 19:08:06 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 9 Jonathan Underwood 2012-09-04 09:27:32 EDT
Chances of this being included as an update for 6.3, or as part of 6.4?
Comment 14 errata-xmlrpc 2013-09-02 03:38:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1187.html

Note You need to log in before you can comment on or make changes to this bug.