Bug 82070 - hwbrowser fails assertion `path != NULL`
Summary: hwbrowser fails assertion `path != NULL`
Status: CLOSED DUPLICATE of bug 74956
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: hwbrowser (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-17 02:31 UTC by Ron Hauptfleisch
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ron Hauptfleisch 2003-01-17 02:31:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
hwbrowser fails.  Here is the output:
----------------------------------------------------------------------------------------------------------------[root@arrakis
ron]# hwbrowser

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1050): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 203, in ?
    reread_device_type_list ()
  File "/usr/share/hwbrowser/DeviceList.py", line 150, in reread_device_type_list
    list.set (iter, 0, hardware.get_category_string (key), 1, key)
  File "/usr/share/hwbrowser/DeviceList.py", line 91, in get_category_string
    return self.type_mapping[key]
KeyError: 20


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.hwbrowser
2.
3.
    

Actual Results:  See Description

Expected Results:  gui displayed

Additional info:

Comment 1 Brent Fox 2003-01-17 03:21:37 UTC

*** This bug has been marked as a duplicate of 74956 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:12 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.