Bug 820742 - RFE: headpin cli method for removing a deletion record on a hypervisor
RFE: headpin cli method for removing a deletion record on a hypervisor
Status: CLOSED CURRENTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: Docs Installation Guide (Show other bugs)
1.0.0
Unspecified Unspecified
high Severity high
: rc
: 1.X
Assigned To: sachua
ecs-bugs
: FutureFeature, TestBlocker, Triaged
Depends On: 802263 812891
Blocks: sam11-tracker
  Show dependency treegraph
 
Reported: 2012-05-10 16:27 EDT by Chris Duryee
Modified: 2014-06-18 03:29 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 812891
Environment:
Last Closed: 2012-07-10 00:14:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the result (164.36 KB, image/png)
2012-05-22 05:26 EDT, yqiao
no flags Details
the new result against the latest sam (229.29 KB, image/png)
2012-05-30 22:48 EDT, yqiao
no flags Details

  None (edit)
Comment 2 RHEL Product and Program Management 2012-05-10 16:44:43 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.
Comment 3 RHEL Product and Program Management 2012-05-10 17:04:46 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.
Comment 7 yqiao 2012-05-22 05:26:20 EDT
Failed

From the UI i can see  the guest whose uuid=42372e7b-20e5-03fb-9435-e45f2fe5fb43
  has been registered to sam ,but when i delete it form the sam server via command line ,it doesn't work efficiently.  
      # headpin -u admin -p admin system remove_deletion --uuid=500
Comment 8 yqiao 2012-05-22 05:26:56 EDT
Created attachment 585975 [details]
the result
Comment 9 sachua 2012-05-23 23:34:18 EDT
Hi Chris, can you please assist with yqiao's comment? Thanks!
Comment 10 Chris Duryee 2012-05-24 14:26:37 EDT
yqiao,

what version of katello-cli-headpin are you running?
Comment 13 yqiao 2012-05-30 04:07:01 EDT
(In reply to comment #10)
> yqiao,
> 
> what version of katello-cli-headpin are you running?

the version of katello-cli-headpin which i was running on is katello-cli-headpin-0.2.0-1.el6_2.noarch
Comment 14 Chris Duryee 2012-05-30 14:33:21 EDT
Can you try again with katello-cli-headpin-0.2.2-1.el6_2 or higher? 0.2.0 does not have this feature.
Comment 15 yqiao 2012-05-30 22:46:41 EDT
Failed.

I have already checked again against the lastest sam with katello-cli-headpin-0.2.2-1.el6_2. the result still failed. But the error information has changed.you can check it with the new attachment.
Comment 16 yqiao 2012-05-30 22:47:11 EDT
(In reply to comment #14)
> Can you try again with katello-cli-headpin-0.2.2-1.el6_2 or higher? 0.2.0
> does not have this feature.

Failed.

I have already checked again against the lastest sam with katello-cli-headpin-0.2.2-1.el6_2. the result still failed. But the error information has changed.you can check it with the new attachment.
Comment 17 yqiao 2012-05-30 22:48:42 EDT
Created attachment 587927 [details]
the new result against the latest sam
Comment 18 sachua 2012-05-30 23:41:56 EDT
Hi Chris, can you please assist yqiao? Thanks!
Comment 19 Chris Duryee 2012-05-31 10:16:33 EDT
That error is correct.

The intent of the command is to allow users to undo an accidential deletion of a vmware hypervisor, since these hypervisors cannot be re-registered with a new UUID. Note that once the command is run, the hypervisor still has to check in again for it to show up in SAM.

If you delete the hypervisor in the sam UI, and then try the command again, it should return a success message. The command is intended for vmware, but any hypervisor will work in terms of testing the command.
Comment 23 Hui Wang 2012-06-04 01:52:06 EDT
Verified the bug. The result is PASS.
Build:
SAM-2012-05-31.1

step:
1. Restart virt-who service
[root@7234 ~]# service virt-who restart
Stopping virt-who:                                         [  OK  ]
Starting virt-who:                                         [  OK  ]
Listening for events is not available in VDSM or ESX mode
[root@7234 ~]# Virt-who is running in esx mode
Starting infinite loop with 3600 seconds interval and event handling
Sending update in hosts-to-guests mapping: {44454c4c-4c00-1031-8053-b8c04f4e3258: [421f875f-f7f1-4743-ad34-cffda0abc4a2, 421febe8-208a-3072-0a0d-c4d641f0dd01, 420a6910-75c5-ec7d-8890-186bed705daa], 44454c4c-4200-1034-8039-b8c04f503258: [421f1822-367a-dff2-837a-d0b63712ae27, 42372e7b-20e5-03fb-9435-e45f2fe5fb43, 421f931a-9067-d179-8a19-6f7a7c9993ef]}
Updated host: 44454c4c-4c00-1031-8053-b8c04f4e3258 with guests: [421f875f-f7f1-4743-ad34-cffda0abc4a2, 421febe8-208a-3072-0a0d-c4d641f0dd01, 420a6910-75c5-ec7d-8890-186bed705daa]
Updated host: 44454c4c-4200-1034-8039-b8c04f503258 with guests: [421f1822-367a-dff2-837a-d0b63712ae27, 42372e7b-20e5-03fb-9435-e45f2fe5fb43, 421f931a-9067-d179-8a19-6f7a7c9993ef]
2. Remove the ESX registered host to unregister the machine from SAM.
3. Remove the the deletion record of the ESX machine
# headpin -u admin -p admin system remove_deletion --uuid=44454c4c-4200-1034-8039-b8c04f503258
Successfully removed deletion record for hypervisor with uuid [ 44454c4c-4200-1034-8039-b8c04f503258 ]
4. Checking the systems that registered on SAM, the unregistered ESX machine re-registered to SAM.

Note You need to log in before you can comment on or make changes to this bug.