Bug 820829 - Guest will keep typing '~' after press F9 and F10 in same time.
Guest will keep typing '~' after press F9 and F10 in same time.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gtk-vnc (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Desktop QE
:
Depends On:
Blocks: 1002711
  Show dependency treegraph
 
Reported: 2012-05-11 02:02 EDT by Geyang Kong
Modified: 2017-02-21 07:06 EST (History)
12 users (show)

See Also:
Fixed In Version: virt-viewer-0.5.6-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 921008 (view as bug list)
Environment:
Last Closed: 2015-09-18 09:55:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output in terminal with --debug option (28.23 KB, text/plain)
2012-05-11 02:02 EDT, Geyang Kong
no flags Details
Completed log file (20.26 KB, text/plain)
2013-05-08 23:47 EDT, Geyang Kong
no flags Details

  None (edit)
Description Geyang Kong 2012-05-11 02:02:29 EDT
Created attachment 583743 [details]
Output in terminal with --debug option

Description of problem:
  Guest will keep typing '~' after press F9 and F10 in same time.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-8.el6.x86_64
libvirt-0.9.10-18.el6.x86_64
qemu-kvm-0.12.1.2-2.285.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Make sure there is a running rhel guest with gnome.
2. Open a terminal in guest.
3. Release the mouse pointer from console but keep focusing on the console form.
4. Press F9 and F10 in same time

Actual results:
1. After step 4. Guest will keep typing '~' in terminal

Expected results:
1. Guest should type only single '~' just like a physical machine.

Additional info:
1. This issue happens on both vnc and spice guest.
Comment 4 Geyang Kong 2012-11-04 22:22:36 EST
I can still reproduce this bug on virt-viewer-0.5.2-16.el6.x86_64, list my detailed steps here:
1. Have a running RHEL6 guest with gnome.
2. Open a terminal in the guest.
3. Release mouse pointer from guest.
4. Move pointer out of the screen zone but stayed in the virt-viewer form.(you can click title bar of the form for making sure of this step)
5. Press F9 and F10 in same time.
Comment 6 Marc-Andre Lureau 2013-05-08 11:15:19 EDT
I can't reproduce it.with virt-viewer-0.5.2-16.el6.x86_64 and spice-gtk-0.14-7.el6.x86_64.


Geyang, could you grab the log with SPICE_DEBUG=1 .. | grep key_event ?

thanks
Comment 7 Geyang Kong 2013-05-08 23:46:27 EDT
I can still reproduce this with following build:
virt-viewer-0.5.2-18.el6.x86_64
spice-gtk-python-0.14-7.el6.x86_64                                                                                     
spice-vdagent-0.12.0-4.el6.x86_64                                                                                            
spice-server-0.12.0-12.el6.x86_64                                                                                                       
spice-gtk-0.14-7.el6.x86_64                                                                                                             
spice-glib-0.14-7.el6.x86_64                                                                                                                    
spice-client-0.8.2-15.el6.x86_64

Steps:
Same as Comment 4

I have run export SPICE_DEBUG=1 and run virt-viewer $guest | grep key_event. But only got following output:
[root@intel-5130-16-2 ~]# virt-viewer T1 | grep key_event

(virt-viewer:16709): GSpice-WARNING **: Warning no automount-inhibiting implementation available
(virt-viewer:16709): GSpice-DEBUG: spice-widget.c:1168 key_event press: keycode: 75  state: 16  group 0 modifier 0

I will also attach the completed log, without grep key_event.
Comment 8 Geyang Kong 2013-05-08 23:47:22 EDT
Created attachment 745516 [details]
Completed log file
Comment 9 Marc-Andre Lureau 2013-05-09 08:54:21 EDT
Thanks, got it from you log: f10 isn't released. This is due to gtk focus and events, spice-gtk receives f10 press but doesn't receive release event since the menu is showing up and takes the focus...

Note this only happen when spice-gtk doesn't have the keyboard grab (when mouse is not over the display)

This is just like bug 924577, so I am tempting to close as dup.
Comment 10 Marc-Andre Lureau 2013-05-09 09:27:02 EDT
sent proposed fix to ML:
http://lists.freedesktop.org/archives/spice-devel/2013-May/013351.html
Comment 15 tingting zheng 2013-07-03 22:54:56 EDT
I can reproduce this bug with the below version,both vnc and spice guest hit the issue.
# rpm -qa virt-viewer
virt-viewer-0.5.2-18.el6_4.2.x86_64

# rpm -qa |grep spice
spice-vdagent-0.12.0-4.el6.x86_64
spice-usb-share-4.9-9.el6.x86_64
kmod-kspiceusb-rhel60-4.9-14.el6.x86_64
spice-glib-0.14-7.el6.x86_64
spice-gtk-python-0.14-7.el6.x86_64
spice-gtk-0.14-7.el6.x86_64
spice-xpi-2.7-22.el6.x86_64
spice-server-0.12.0-12.el6.x86_64

Tested with:
# rpm -qa virt-viewer
virt-viewer-0.5.6-1.el6.x86_64

# rpm -qa |grep spice
spice-gtk-tools-0.20-1.el6.x86_64
spice-glib-0.20-1.el6.x86_64
spice-vdagent-0.14.0-1.el6.x86_64
spice-server-0.12.3-1.el6.x86_64
spice-gtk-0.20-1.el6.x86_64
spice-gtk-python-0.20-1.el6.x86_64
spice-client-0.8.2-15.el6.x86_64
spice-protocol-0.12.2-1.el6.noarch

For vnc guest,the issue still exists,Press F9 and F10 in same time,Guest will keep typing '~' in terminal.
For spice guest,the issue doesn't exist,it type only single '~'.

Refer to the above comments,move the bug to ASSIGNED.
Comment 16 Marc-Andre Lureau 2013-07-04 05:43:21 EDT
(In reply to tingting zheng from comment #15)
> For vnc guest,the issue still exists,Press F9 and F10 in same time,Guest
> will keep typing '~' in terminal.
> For spice guest,the issue doesn't exist,it type only single '~'.
> 
> Refer to the above comments,move the bug to ASSIGNED.

I haven't looked at VNC, and I don't have good motivation to fix it there.

Moving the bug to gtk-vnc.
Comment 19 RHEL Product and Program Management 2013-10-13 20:40:05 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 21 Chris Williams 2015-09-18 09:55:05 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 6 and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.