Bug 820950 - Cannot build RichFaces Showcase with EAP 6.0.0.ER6 and WFK 2.0.0.ER5 Maven repo
Summary: Cannot build RichFaces Showcase with EAP 6.0.0.ER6 and WFK 2.0.0.ER5 Maven repo
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise WFK Platform 2
Classification: Retired
Component: RichFaces
Version: 2.0.0.ER5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 2.0.0.ER6
Assignee: Brian Leathem
QA Contact: Jan Papousek
URL:
Whiteboard:
Depends On: 820579
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-11 12:10 UTC by Jan Papousek
Modified: 2014-08-25 17:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 825802 (view as bug list)
Environment:
Last Closed: 2012-06-22 07:32:15 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 814112 None None None Never
Red Hat One Jira Issue Tracker RF-12243 Major Resolved Showcase: remove parent from pom 2014-09-01 07:57:39 UTC

Internal Links: 814112

Description Jan Papousek 2012-05-11 12:10:12 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. download and extract jboss-wfk-2.0.0.ER5-richfaces-demo.zip
2. build richfaces-showcase with EAP 6.0.0.ER6 and WFK 2.0.0.ER5 repository
  
Actual results:

The POM for org.apache.maven.plugins:maven-enforcer-plugin:jar:1.0-redhat-1 is missing, no dependency information available

Expected results:


Additional info:

Current inheritance chain:
richfaces-showcase -> richfaces-root-parent -> richfaces-parent -> jboss-parent (and here is defined version of maven-enforcer-plugin)

Comment 1 Pavol Pitonak 2012-05-28 14:44:58 UTC
richfaces-root-parent was removed from Showcase in 2.0.0.ER6. However, Showcase still cannot be built because of bug 825802.

Comment 2 JBoss JIRA Server 2012-06-18 12:05:16 UTC
Lukáš Fryč <lfryc@redhat.com> updated the status of jira RF-12243 to Coding In Progress

Comment 3 JBoss JIRA Server 2012-06-18 12:55:27 UTC
Lukáš Fryč <lfryc@redhat.com> made a comment on jira RF-12243

Pavol, could you clarify, what's the problem with example having parent?

Without parent, we need to duplicate the plugin settings and version informations from {{richfaces-root-parent}}.

I need to understand why you are suggesting to do that.

Comment 4 JBoss JIRA Server 2012-06-18 12:58:34 UTC
Pavol Pitonak <ppitonak@redhat.com> made a comment on jira RF-12243

Samples can't inherit from jboss-parent (neither directly nor indirectly) because then it is not possible to build them. Maven central doesn't contain our productized Maven plugins, i.e. plugins with -redhat-1 in version.

Comment 5 JBoss JIRA Server 2012-06-18 13:06:21 UTC
Lukáš Fryč <lfryc@redhat.com> made a comment on jira RF-12243

Samples can though depend on productized {{jboss-parent}}, which does declare productized versions of plugins, right?

Comment 6 JBoss JIRA Server 2012-06-18 13:15:24 UTC
Pavol Pitonak <ppitonak@redhat.com> made a comment on jira RF-12243

* productized sample cannot (shouldn't?) depend on community jboss-parent
* productized sample cannot depend on productized jboss-parent because of problems with Maven plugins described above
* community sample should be similar to productized sample as much as possible

Please ask Marek Novotny for his opinion.

Comment 7 JBoss JIRA Server 2012-06-18 14:28:45 UTC
Marek Novotny <mnovotny@redhat.com> made a comment on jira RF-12243

this is about examples in general.

It shouldn't inherit any build parent (and maven plugins) and would stay as standalone along the project build infrastructure.

Because examples should be clean and easy to understand.

Comment 8 JBoss JIRA Server 2012-06-18 14:32:11 UTC
Karel Piwko <kpiwko@redhat.com> made a comment on jira RF-12243

I agree with Marek, examples should have no parent, because it hides the complexity of the example itself.

If you really insist on examples having parent, for example if you have more then a single example, this parent should be the top in hierarchy.

Comment 9 JBoss JIRA Server 2012-06-18 14:54:08 UTC
Lukáš Fryč <lfryc@redhat.com> made a comment on jira RF-12243

I'm asking if it's technically impossible to have {{jboss-parent}} as parent, putting personal opinions aside.

----

RichFaces Showcase is not classical example: it is written to showcase components on many different containers,
thus it is implicitly hard to build and project descriptor is hard to understand.
We have other examples which shows how to start with RichFaces.

----

If you want to simplify the build of Showcase to act as valid sample, then you need to go deeper than removing parent:

* remove container-specific builds
* remove JMS initialization listeners
* do not select web resources based on used container (src/main/webapp-{container})

Comment 10 JBoss JIRA Server 2012-06-18 14:57:03 UTC
Lukáš Fryč <lfryc@redhat.com> made a comment on jira RF-12243

When separating parent, we can define {{build-bom}} as suggested in RF-11836.

When separating plugin configuration, we would need second parent-less parent, which would copy all the settings of {{richfaces-parent}} and {{richfaces-root-parent}}.

Comment 11 JBoss JIRA Server 2012-06-18 15:01:34 UTC
Marek Novotny <mnovotny@redhat.com> made a comment on jira RF-12243

I couldn't find any personal opinions in previous comments.

If you need to have technically a parent for examples, that is as Karel in https://issues.jboss.org/browse/RF-12243?focusedCommentId=12701912&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-12701912 fine.

My question is if you need to support many different containers, why is so important to inherit jboss-parent? That plugins and settings are valid for only last version of jboss projects. 

Again you can still have different profiles with different resources for other targeting platforms. Here is a discussion about inheriting not useful things for the example.

Comment 12 JBoss JIRA Server 2012-06-18 15:36:40 UTC
Marek Novotny <mnovotny@redhat.com> made a comment on jira RF-12243

Lukas, don't create any additional buld-bom. The current complexity is already too big.

Comment 14 JBoss JIRA Server 2012-09-18 18:40:39 UTC
Lukáš Fryč <lfryc@redhat.com> made a comment on jira RF-12243

We will take care about this in RF 5.0 build re-structure.

Comment 15 JBoss JIRA Server 2014-08-25 17:36:36 UTC
Brian Leathem <bleathem@gmail.com> updated the status of jira RF-12243 to Resolved


Note You need to log in before you can comment on or make changes to this bug.