Bug 820579 - RichFaces resources ordering load is broken
RichFaces resources ordering load is broken
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: RichFaces (Show other bugs)
2.0.0.ER5
Unspecified Unspecified
urgent Severity urgent
: ---
: 2.0.0.ER6
Assigned To: Marek Novotny
Karel Piwko
:
Depends On:
Blocks: 820950 821418
  Show dependency treegraph
 
Reported: 2012-05-10 08:19 EDT by Karel Piwko
Modified: 2014-02-07 18:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 03:32:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBEE-114 Major Resolved JSF-API from 2.0.1.Final introduces inclusion of JSF-IMPL resources 2015-12-17 10:35 EST
JBoss Issue Tracker RF-12240 Blocker Resolved Resource ordering load is broken with the Snowdrop Sports club sample 2015-12-17 10:35 EST

  None (edit)
Description Karel Piwko 2012-05-10 08:19:16 EDT
Description of problem:

RichFaces button cannot be clicked anymore. Seems to be the same manifestation as for https://bugzilla.redhat.com/show_bug.cgi?id=801172


Version-Release number of selected component (if applicable):

RichFaces 4.2.1.Final-redhat-1

How reproducible:

Always.

Steps to Reproduce:
1. Deploy sportsclub example
2. Go to http://localhost:8080/sportsclub/reservations
3. Try to click on anything
  
Actual results:

Button are not clickable. Firebug console shows that something is broken with JS:

[14:13:14.318] jQuery is not defined @ http://localhost:8080/sportsclub/reservations/org.richfaces.resources/javax.faces.resource/org.richfaces.staticResource/4.2.1.Final-redhat-1/PackedCompressed/packed/packed.js:885
[14:13:14.522] RichFaces.ui is undefined @ http://localhost:8080/sportsclub/reservations/:29
[14:13:14.596] Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead. @ http://localhost:8080/sportsclub/reservations/

Expected results:

It works.

Additional info:
Comment 3 Lukáš Fryč 2012-05-11 05:01:15 EDT
The same issues as with https://bugzilla.redhat.com/show_bug.cgi?id=801172 .

javax.faces\:jsf.js=org.richfaces.staticResource/4.2.1.Final-redhat-1/Packed/packed/packed.js
Comment 4 JBoss JIRA Server 2012-05-11 05:04:14 EDT
Lukáš Fryč <lfryc@redhat.com> updated the status of jira RF-12240 to Resolved
Comment 5 JBoss JIRA Server 2012-05-11 05:04:14 EDT
Lukáš Fryč <lfryc@redhat.com> made a comment on jira RF-12240

This issue occurs only with WFK bits.
Comment 7 Marek Novotny 2012-05-22 09:51:11 EDT
I and Lukas discovered that the cause is jboss jsf-api starting from 2.0.1.Final introduces inclusion of javax.faces resources.

Hack for fixing it is definition of changed scope for jsf-api in static-resources pom.xml:
             <dependency>
                    <groupId>org.jboss.spec.javax.faces</groupId>
                    <artifactId>jboss-jsf-api_2.1_spec</artifactId>
                    <scope>test</scope>
             </dependency>
Comment 8 Karel Piwko 2012-06-04 08:42:17 EDT
Verified with WFK ER7 via testsuite.
Comment 10 JBoss JIRA Server 2014-02-07 18:17:46 EST
Farah Juma <fjuma@redhat.com> updated the status of jira JBEE-114 to Resolved

Note You need to log in before you can comment on or make changes to this bug.