Bug 820980 - [abrt] rosegarden4-11.11.42-2.fc17: Process /usr/bin/rosegarden was killed by signal 11 (SIGSEGV)
[abrt] rosegarden4-11.11.42-2.fc17: Process /usr/bin/rosegarden was killed by...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rosegarden4 (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brendan Jones
Fedora Extras Quality Assurance
abrt_hash:e5b8526aa4b81dc270332420fe2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 09:26 EDT by Pavel Roskin
Modified: 2013-07-31 17:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 17:37:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (80.90 KB, text/plain)
2012-05-11 09:26 EDT, Pavel Roskin
no flags Details
File: maps (46.08 KB, text/plain)
2012-05-11 09:26 EDT, Pavel Roskin
no flags Details
File: dso_list (8.99 KB, text/plain)
2012-05-11 09:26 EDT, Pavel Roskin
no flags Details

  None (edit)
Description Pavel Roskin 2012-05-11 09:26:17 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        rosegarden Torna_a_Surriento.mid
comment:        I tried to export music in Lilypond format
crash_function: Rosegarden::Instrument::getProgramName
executable:     /usr/bin/rosegarden
kernel:         3.3.4-3.fc17.x86_64
pid:            5291
pwd:            /home/proski/local/vocal/Torne a Surriento/tmp
remote_result:  NOTFOUND
time:           Tue 08 May 2012 10:25:54 AM EDT
uid:            1000
username:       proski
xsession_errors: 

backtrace:      Text file, 82843 bytes
dso_list:       Text file, 9203 bytes
maps:           Text file, 47181 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/proski/1

core_backtrace:
:3a1166aebfed8c63d16bacc1158a0f8e87760a01 0x12a901 - [exe] -
:3a1166aebfed8c63d16bacc1158a0f8e87760a01 0x1ca401 - [exe] -
:3a1166aebfed8c63d16bacc1158a0f8e87760a01 0x2f2725 - [exe] -
:3a1166aebfed8c63d16bacc1158a0f8e87760a01 0x2f2f00 - [exe] -
:3a1166aebfed8c63d16bacc1158a0f8e87760a01 0x2f487d - [exe] -
:fe399c87ce3f6287a5ad99166ab1dc1775665d77 0x18c09f QMetaObject::activate(QObject*, libQtCore.so.4 -
:b646c880a71a01db3170547dfa9994b60478ae7e 0x1c42a2 QAction::triggered(bool) libQtGui.so.4 -
:b646c880a71a01db3170547dfa9994b60478ae7e 0x1c4490 QAction::activate(QAction::ActionEvent) libQtGui.so.4 -
:b646c880a71a01db3170547dfa9994b60478ae7e 0x5fd063 - libQtGui.so.4 -
:b646c880a71a01db3170547dfa9994b60478ae7e 0x603379 - libQtGui.so.4 -
:b646c880a71a01db3170547dfa9994b60478ae7e 0x219d00 QWidget::event(QEvent*) libQtGui.so.4 -
:b646c880a71a01db3170547dfa9994b60478ae7e 0x60462b QMenu::event(QEvent*) libQtGui.so.4 -
:b646c880a71a01db3170547dfa9994b60478ae7e 0x1ca47c QApplicationPrivate::notify_helper(QObject*, libQtGui.so.4 -
:b646c880a71a01db3170547dfa9994b60478ae7e 0x1cf20b QApplication::notify(QObject*, libQtGui.so.4 -
:fe399c87ce3f6287a5ad99166ab1dc1775665d77 0x17595e QCoreApplication::notifyInternal(QObject*, libQtCore.so.4 -
:b646c880a71a01db3170547dfa9994b60478ae7e 0x1cb2bb QApplicationPrivate::sendMouseEvent(QWidget*, libQtGui.so.4 -
:b646c880a71a01db3170547dfa9994b60478ae7e 0x24585c - libQtGui.so.4 -
:b646c880a71a01db3170547dfa9994b60478ae7e 0x244721 QApplication::x11ProcessEvent(_XEvent*) libQtGui.so.4 -
:b646c880a71a01db3170547dfa9994b60478ae7e 0x26a73c - libQtGui.so.4 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x475cc g_main_context_dispatch libglib-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x479e8 - libglib-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x47aa4 g_main_context_iteration libglib-2.0.so.0 -
:fe399c87ce3f6287a5ad99166ab1dc1775665d77 0x1a39e6 QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) libQtCore.so.4 -
:b646c880a71a01db3170547dfa9994b60478ae7e 0x26a41e - libQtGui.so.4 -
:fe399c87ce3f6287a5ad99166ab1dc1775665d77 0x17495f QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) libQtCore.so.4 -
:fe399c87ce3f6287a5ad99166ab1dc1775665d77 0x174be8 QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) libQtCore.so.4 -
:fe399c87ce3f6287a5ad99166ab1dc1775665d77 0x179718 QCoreApplication::exec() libQtCore.so.4 -
:3a1166aebfed8c63d16bacc1158a0f8e87760a01 0x4dba6 - [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=1
:SAL_USE_VCLPLUGIN=gtk
:HOSTNAME=x33
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:XDG_MENU_PREFIX=lxde-
:TERM=xterm
:SHELL=/bin/bash
:HISTSIZE=1000
:WINDOWID=27263010
:GNOME_KEYRING_CONTROL=/home/proski/.cache/keyring-37TfTn
:SYSFONT=True
:IMSETTINGS_MODULE=none
:USER=proski
:XTERM_SHELL=/bin/bash
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:MC_TMPDIR=/tmp/mc-proski
:DESKTOP_SESSION=LXDE
:PATH=/usr/lib64/ccache:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/proski/.local/bin:/home/proski/bin
:MAIL=/var/spool/mail/proski
:QT_IM_MODULE=xim
:'PWD=/home/proski/local/vocal/Torne a Surriento/tmp'
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=672
:LANG=en_US.UTF-8
:KEYTABLE=ru
:HISTCONTROL=ignorespace
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:_LXSESSION_PID=739
:'XTERM_VERSION=X.Org 7.6.0(278)'
:XTERM_LOCALE=en_US.UTF-8
:XDG_SEAT=seat0
:HOME=/home/proski
:SHLVL=3
:XDG_CONFIG_HOME=/home/proski/.config
:BOOT_IMAGE=/boot/vmlinuz-3.3.4-3.fc17.x86_64
:MC_SID=3999
:LOGNAME=proski
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ONSHBgRA9T,guid=f5b4a9969d9a34b4213914dd0000007e
:PREFERRED=/usr/bin/startlxde
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:XDG_RUNTIME_DIR=/run/user/proski
:DISPLAY=:0
:GTK_IM_MODULE=gtk-im-context-simple
:XDG_CURRENT_DESKTOP=LXDE
:XAUTHORITY=/home/proski/.Xauthority
:CCACHE_HASHDIR=
:'OLDPWD=/home/proski/local/vocal/Torne a Surriento'
:_=/bin/rosegarden

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 15878                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       15878                15878                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/pts/3
:pos:	0
:flags:	0102002
:1:/dev/pts/3
:pos:	0
:flags:	0102002
:2:/dev/pts/3
:pos:	0
:flags:	0102002
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:pipe:[1986702]
:pos:	0
:flags:	02004000
:5:pipe:[1986702]
:pos:	0
:flags:	02004001
:6:socket:[1986703]
:pos:	0
:flags:	02004002
:7:pipe:[1718155]
:pos:	0
:flags:	01
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:pipe:[1988446]
:pos:	0
:flags:	00
:10:pipe:[1988446]
:pos:	0
:flags:	01
:11:/home/proski/local/vocal/Torne a Surriento/tmp/Torna_a_Surriento-rg.ly
:pos:	703
:flags:	0100001

smolt_data:
:
:
:General
:=================================
:UUID: 7ec6a881-f195-4fff-8464-1628d8d110e2
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5000.19
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Quad  CPU   Q9300  @ 2.50GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 4
:CPU Speed: 2500
:System Memory: 2002
:System Swap: 4999
:Vendor: Gigabyte Technology Co., Ltd.
:System: P35-S3G 
:Form factor: Desktop
:Kernel: 3.3.4-3.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4887:2437:4887:1392) pci, tulip, ETHERNET, NC100 Network Everywhere Fast Ethernet 10/100
:(32902:10688:5208:20480) pci, None, HOST/PCI, 82G33/G31/P35/P31 Express DRAM Controller
:(32902:10689:5208:20480) pci, pcieport, PCI/PCI, 82G33/G31/P35/P31 Express PCI Express Root Port
:(32902:10544:5208:20481) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10531:5208:45061) pci, ahci, STORAGE, 82801IB (ICH9) 4 port SATA AHCI Controller
:(32902:10520:5208:20481) pci, None, PCI/ISA, 82801IB (ICH9) LPC Interface Controller
:(6164:770:5871:37473) pci, rt61pci, NETWORK, RT2561/RT61 rev B 802.11g
:(4172:44112:0:0) pci, yenta_cardbus, PCI/CARDBUS, PCI1410 PC card Cardbus Controller
:(32902:10549:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:9294:5208:20480) pci, None, PCI/PCI, GA-EP45-DS5 Motherboard
:(32902:10553:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:5208:20486) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:5208:20486) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(6523:9064:5208:45056) pci, pata_jmicron, STORAGE, JMB368 IDE controller
:(32902:10560:5208:20481) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10568:5208:20481) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:5208:40962) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10548:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(4098:43536:4163:43536) pci, snd_hda_intel, MULTIMEDIA, RV610 audio device [Radeon HD 2400 PRO]
:(4098:38083:4163:450) pci, radeon, VIDEO, RV610 video device [Radeon HD 2400 PRO]
:(32902:10552:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda2 / ext4 4096 4096 12785722 9293056 9165094 3203072 2899708 2899708
:

var_log_messages:
:May  8 10:22:59 x33 yum[5272]: Installed: rosegarden4-parmesan-fonts-11.11.42-2.fc17.noarch
:May  8 10:23:00 x33 yum[5272]: Installed: rosegarden4-feta-fonts-11.11.42-2.fc17.noarch
:May  8 10:23:01 x33 yum[5272]: Installed: rosegarden4-11.11.42-2.fc17.x86_64
:May  8 10:25:54 x33 kernel: [12493.881674] rosegarden[5291]: segfault at 89 ip 000000000052a901 sp 00007fffc862a2c0 error 4 in rosegarden[400000+b63000]
:May  8 10:25:54 x33 abrt[5311]: Saved core dump of pid 5291 (/usr/bin/rosegarden) to /var/spool/abrt/ccpp-2012-05-08-10:25:54-5291 (49491968 bytes)
Comment 1 Pavel Roskin 2012-05-11 09:26:22 EDT
Created attachment 583846 [details]
File: backtrace
Comment 2 Pavel Roskin 2012-05-11 09:26:24 EDT
Created attachment 583847 [details]
File: maps
Comment 3 Pavel Roskin 2012-05-11 09:26:26 EDT
Created attachment 583848 [details]
File: dso_list
Comment 4 Brendan Jones 2012-05-11 09:44:48 EDT
Is this consistently reproducible? 

I am about to push 12.04 to f17. I will attach this bug to the ticket.
Comment 5 Pavel Roskin 2012-05-11 10:08:04 EDT
Yes, it's reproducible.  Even exporting the simplest MIDI file to Lilypond with default options causes a crash.
Comment 6 Brendan Jones 2012-05-12 04:09:09 EDT
I cannot reproduce it here under KDE. What desktop are you using?
Comment 7 Pavel Roskin 2012-05-12 09:41:29 EDT
I'm using LXDE.  I'll happily retest rosegarden under KDE, but I won't see that system until Monday.  Are you on x64_64?
Comment 8 Pavel Roskin 2012-05-23 11:18:56 EDT
Sorry for delay.  I installed KDE with "yum install @kde" and could not reproduce the crash.  MIDI import worked just fine.  I'm still running LXDE.

Then I found which packages I installed in /var/log/yum.log and uninstalled them all.  Rosegarden is still not crashing, even with large MIDI files.

I'm still using rosegarden4-11.11.42-2.fc17.x86_64
Comment 9 Fedora End Of Life 2013-07-03 16:58:00 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 10 Fedora End Of Life 2013-07-31 17:37:38 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.