Bug 821016 - Allow sysconfig/cman to pass options to dlm_controld
Summary: Allow sysconfig/cman to pass options to dlm_controld
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster   
(Show other bugs)
Version: 6.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Fabio Massimo Di Nitto
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks: 849047 849048 849049
TreeView+ depends on / blocked
 
Reported: 2012-05-11 15:02 UTC by Alan Conway
Modified: 2013-02-21 07:42 UTC (History)
7 users (show)

Fixed In Version: cluster-3.0.12.1-33.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 07:42:29 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0287 normal SHIPPED_LIVE cluster and gfs2-utils bug fix and enhancement update 2013-02-20 20:36:42 UTC

Description Alan Conway 2012-05-11 15:02:10 UTC
Description of problem:

If you set FENCE_JOIN=no in sysconfig/cman then the node should not wait on fencing. However if you do this, start a cluster and then reboot a node running a relocatable service, the system hangs. Error logs show it is waiting on a fencing operation.

Version-Release number of selected component (if applicable): RHEL 6


How reproducible: 100%


Steps to Reproduce:
1. Configure a cluster with FENCE_JOIN=no and a relocatable service.
2. Reboot the node where the relocatable service is running
  
Actual results:

The service never gets relocated, log files indicate waiting on a fencing operation.

Expected results:

Service relocates, cluster functions normally.

Comment 2 RHEL Product and Program Management 2012-05-15 04:04:21 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 3 Fabio Massimo Di Nitto 2012-05-15 11:57:23 UTC
http://git.fedorahosted.org/git/?p=cluster.git;a=commitdiff;h=10ebf6e26eff7fd21ac245cac9876ef62ae049ca

Unit test results:

Add:

DLM_CONTROLD_OPTS="-f 0 -q 0 -r 1"

to /etc/sysconfig/cman

service cman start (doesn´t matter how many nodes)

[root@rhel6-node2 ~]# dlm_tool dump
[snip]
1337082738 set protocol 1

(for -r 1)

ps ax |grep dlm_controld
19330 ?        Ssl    0:00 dlm_controld -f 0 -q 0 -r 1

Comment 13 errata-xmlrpc 2013-02-21 07:42:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0287.html


Note You need to log in before you can comment on or make changes to this bug.