Bug 821052 - Changing sort order by clicking column head is not working
Changing sort order by clicking column head is not working
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
:
: 821053 (view as bug list)
Depends On:
Blocks: BZ42
  Show dependency treegraph
 
Reported: 2012-05-11 13:02 EDT by Marian Csontos
Modified: 2014-10-12 18:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.2.1-0.rc3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-13 18:30:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Csontos 2012-05-11 13:02:31 EDT
Description of problem:
Changing sort order by clicking column head is not working. Error page "You may not search, or create saved searches, without any search terms." is shown instead.

Version-Release number of selected component (if applicable):
4.2

How reproducible:
100%

Steps to Reproduce:
1. go to e.g. https://partner-bugzilla.redhat.com/buglist.cgi?query_format=specific&order=relevance+desc&bug_status=__open__&product=Red+Hat+Enterprise+Linux+6&content=device-mapper-multipath
2. click ID to change sort order
  
Actual results:
Error page saying "You may not search, or create saved searches, without any search terms."

Expected results:
Same search with diffrent order

Additional info:
Comment 1 Marian Csontos 2012-05-11 13:04:58 EDT
Manually editing URL works fine, it's just the links are incorrect.
Comment 3 Simon Green 2012-05-13 18:32:20 EDT
There was a Red Hat customisation that turned a simple search into a quicksearch. I've looked through the SVN logs, and cannot find a good reason why that was done, so have removed it and changing the header should work if you do a new search. Using the link in comment #0 won't work still, you'll need to do a new
search.

  -- simon
Comment 4 Simon Green 2012-05-13 18:35:58 EDT
*** Bug 821053 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.