Bug 821121 - [abrt] gnome-activity-journal-0.8.0-1.fc16: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.UnknownMethod: No such interface `org.gnome.zeitgeist.Log' on object at path /org/gnome/zeitgeist/journal/activity
[abrt] gnome-activity-journal-0.8.0-1.fc16: connection.py:630:call_blocking:D...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-activity-journal (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mads Villadsen
Fedora Extras Quality Assurance
abrt_hash:36ac26b762b109b0ea349df472e...
:
: 837683 840226 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-12 03:48 EDT by harsh1492
Modified: 2012-07-25 23:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-25 23:58:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description harsh1492 2012-05-12 03:48:06 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        python /usr/bin/gnome-activity-journal
comment:        just launch the gnome-activity-journal and it crashes
executable:     /usr/bin/gnome-activity-journal
kernel:         3.3.4-3.fc16.x86_64
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.UnknownMethod: No such interface `org.gnome.zeitgeist.Log' on object at path /org/gnome/zeitgeist/journal/activity
time:           Sat 12 May 2012 01:14:53 PM IST
uid:            1000
username:       a.harsh

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.UnknownMethod: No such interface `org.gnome.zeitgeist.Log' on object at path /org/gnome/zeitgeist/journal/activity
:
:Traceback (most recent call last):
:  File "/usr/bin/gnome-activity-journal", line 97, in <module>
:    from src.main import PortalWindow
:  File "/usr/share/gnome-activity-journal/src/main.py", line 31, in <module>
:    from activity_widgets import MultiViewContainer, TimelineViewContainer, ThumbViewContainer
:  File "/usr/share/gnome-activity-journal/src/activity_widgets.py", line 41, in <module>
:    from store import ContentStruct, CLIENT
:  File "/usr/share/gnome-activity-journal/src/store.py", line 588, in <module>
:    STORE = Store()
:  File "/usr/share/gnome-activity-journal/src/store.py", line 411, in __init__
:    days_population = CLIENT_EXTENSION.GetHistogramData()
:  File "/usr/lib/python2.7/site-packages/zeitgeist/client.py", line 133, in _ProxyMethod
:    lambda: getattr(self.__iface, name), *args, **kwargs)
:  File "/usr/lib/python2.7/site-packages/zeitgeist/client.py", line 122, in _disconnection_safe
:    return reconnecting_error_handler(e)
:  File "/usr/lib/python2.7/site-packages/zeitgeist/client.py", line 120, in _disconnection_safe
:    return method_getter()(*args, **kwargs)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.UnknownMethod: No such interface `org.gnome.zeitgeist.Log' on object at path /org/gnome/zeitgeist/journal/activity
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus._dbus.SessionBus (session) at 0x7f27d5ff9950>
:args: ()
:utf8_strings: False
:bus_name: 'org.gnome.zeitgeist.Engine'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: '/org/gnome/zeitgeist/journal/activity'
:timeout: -1.0
:signature: None
:dbus_interface: 'org.gnome.zeitgeist.Log'
:message: <dbus.lowlevel.MethodCallMessage object at 0x7f27d81a4be8>
:method: 'GetHistogramData'
Comment 1 Raphos 2012-05-23 13:34:07 EDT
1° Launch gnome-activity-journal
2° Crash


Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 Luya Tshimbalanga 2012-05-29 02:57:59 EDT
Crash occurred after selecting Gnome Activity

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 Deactivated 2012-05-29 19:34:05 EDT
GNOME Activity Journal crashes when trying to run.

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 4 Štefan Gurský 2012-06-03 05:15:16 EDT
I tried to run it from Gnome-shell

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 5 autarch princeps 2012-06-03 14:28:10 EDT
activity journal

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 6 Lari Tanase 2012-06-09 07:41:06 EDT
I tried to start program 
crash at first start


Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 7 Rohit 2012-06-10 01:01:54 EDT
Started gnome-activity-journal

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 Pierre-Yves Luyten 2012-06-12 17:24:53 EDT
Gnome activity journal crashes on startup.

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 9 Bernhard Kohl 2012-06-13 15:16:12 EDT
DBusException: org.freedesktop.DBus.Error.UnknownMethod: No such interface `org.gnome.zeitgeist.Log' on object at path /org/gnome/zeitgeist/journal/activity

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 10 Luya Tshimbalanga 2012-06-15 04:53:10 EDT
Attempt to start the application.

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 11 Marcus Ilgner 2012-06-16 11:28:15 EDT
Installed Activity Journal and tried to start it.

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 12 Davide Cardella 2012-06-18 09:21:27 EDT
1 - install zeitgeist and its dependencies 
2 - install gnome-shell extension to use journal (that works just fine)
3 - try to start gnome activity journal


Package: gnome-activity-journal-0.8.0-2.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 13 Chris Gilligan 2012-06-18 13:13:06 EDT
opened Activity Journal after installation of Zeitgeist via Add/Remove Software

Package: gnome-activity-journal-0.8.0-2.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 14 M. Edward (Ed) Borasky 2012-06-22 18:36:35 EDT
I typed "gnome-activity-journal" at the command line.

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 15 Paul Lange 2012-06-25 06:52:41 EDT
crashed on first start after install

Package: gnome-activity-journal-0.8.0-2.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 16 Szymon Gruszczynski 2012-06-27 17:22:31 EDT
I tried to run activity journal

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 17 Szymon Gruszczynski 2012-06-29 12:49:38 EDT
i've tried to run GAJ

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 18 Luya Tshimbalanga 2012-06-30 18:11:27 EDT
Attempt to start Gnome-Activity-Journal

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 19 M. Edward (Ed) Borasky 2012-07-02 03:10:22 EDT
I opened a gnome-terminal window and typed "gnome-activity-journal"

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 20 rbz 2012-07-03 15:56:53 EDT
I tried to start it.

Package: gnome-activity-journal-0.8.0-1.fc16
OS Release: Fedora release 16 (Verne)
Comment 21 Alex Lancaster 2012-07-12 10:41:36 EDT
Tried launching the program from the Favorites menu.  Got an immediate crash.

Package: gnome-activity-journal-0.8.0-1.fc16
OS Release: Fedora release 16 (Verne)
Comment 22 le.poittevin.laurent 2012-07-13 03:10:24 EDT
à chaque démarrage du journal d'activité

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 23 M. Edward (Ed) Borasky 2012-07-13 13:35:36 EDT
1. I installed gnome-activity-journal
2. I went to the Applications menu and clicked on the Activity Journal icon


Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 24 Matteo Settenvini 2012-07-14 08:38:44 EDT
Just starting the activity journal.

It seems it tries to try and connect to org.gnome.zeitgeist.Log in DBus on
/org/gnome/zeitgeist/journal/activity, but the Log interface is under
/org/gnome/zeitgeist/log/activity instead.


Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 25 ihatewindoze 2012-07-21 16:20:26 EDT
Just tried to start the application from the applications widget.

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 26 Mads Villadsen 2012-07-22 15:00:22 EDT
*** Bug 837683 has been marked as a duplicate of this bug. ***
Comment 27 Mads Villadsen 2012-07-22 15:00:35 EDT
*** Bug 840226 has been marked as a duplicate of this bug. ***
Comment 28 Fedora Update System 2012-07-22 15:51:00 EDT
gnome-activity-journal-0.8.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gnome-activity-journal-0.8.0-4.fc17
Comment 29 Alex Lancaster 2012-07-22 16:12:24 EDT
(In reply to comment #28)
> gnome-activity-journal-0.8.0-4.fc17 has been submitted as an update for
> Fedora 17.
> https://admin.fedoraproject.org/updates/gnome-activity-journal-0.8.0-4.fc17

Can you also push an update for f16? I get the same error as in this bug (see comment #21)
Comment 30 Fedora Update System 2012-07-22 16:46:14 EDT
gnome-activity-journal-0.8.0-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gnome-activity-journal-0.8.0-4.fc16
Comment 31 Fedora Update System 2012-07-23 16:27:22 EDT
Package gnome-activity-journal-0.8.0-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-activity-journal-0.8.0-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11016/gnome-activity-journal-0.8.0-4.fc17
then log in and leave karma (feedback).
Comment 32 le.poittevin.laurent 2012-07-24 08:57:56 EDT
Just trying to start activity journal 0.8.0-2.fc17 fedora 17 64bits  zeitgeist-0.9.0-1.fc17

Package: gnome-activity-journal-0.8.0-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 33 Pierre-Yves Luyten 2012-07-25 02:38:18 EDT
Great, 0.8.0-4.fc17 did correct crash on my config too
Comment 34 Fedora Update System 2012-07-25 23:58:42 EDT
gnome-activity-journal-0.8.0-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 35 Fedora Update System 2012-07-25 23:59:35 EDT
gnome-activity-journal-0.8.0-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.