Bug 821183 - RFE: Do not use a separate thread to handle signals and no rpath by default
RFE: Do not use a separate thread to handle signals and no rpath by default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ecl (Show other bugs)
16
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
:
Depends On: 822296
Blocks: 821188
  Show dependency treegraph
 
Reported: 2012-05-12 17:32 EDT by Paulo Andrade
Modified: 2012-06-27 23:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 23:39:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paulo Andrade 2012-05-12 17:32:16 EDT
While working on yet another RFE for maxima (to add support to ECL)
I again found a problem I had sometime ago with ecl and sagemath, that
was addressed in http://trac.sagemath.org/sage_trac/ticket/11752

  There is also a recent report in ecl mailing list, with the same
symptoms I had (maxima make check deadlock):
http://www.mail-archive.com/ecls-list@lists.sourceforge.net/msg00644.html

  I opened an upstream request to change the default at
https://sourceforge.net/tracker/?func=detail&aid=3526174&group_id=30035&atid=398053


  Another problem in ecl.spec is that the configure option to disable
rpath was removed in last upstream release, probably by mistake, so
I added it back, otherwise it would be added to ecl-config --libs
or ecl-config --ldflags output.

Spec URL: http://fedorapeople.org/~pcpa/ecl.spec
SRPM URL: http://fedorapeople.org/~pcpa/ecl-12.2.1-3.fc16.src.rpm

  Also please review this rpmlint warning:

ecl.src: W: file-size-mismatch ecl-12.2.1.tgz = 8974873, http://downloads.sourceforge.net/ecls/ecl-12.2.1.tgz = 8974948
(I am using the one from fedpkg sources)
Comment 1 Paulo Andrade 2012-05-13 15:49:45 EDT
I have another pending request that will require either ecl
behaviour change or a patch in sagemath, so, worth mentioning
in this bug report:

https://sourceforge.net/tracker/?func=detail&aid=3526370&group_id=30035&atid=398053

The problem is ecl built with unicode support and sagemath code
depending on behaviour of ecl built without unicode support.
Comment 2 Fedora Update System 2012-06-18 10:58:24 EDT
ecl-12.2.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ecl-12.2.1-3.fc17
Comment 3 Fedora Update System 2012-06-19 20:21:09 EDT
Package ecl-12.2.1-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ecl-12.2.1-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9647/ecl-12.2.1-3.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-06-27 23:39:33 EDT
ecl-12.2.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.