Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 822296 - ecl is broken in rawhide, probably gc related
ecl is broken in rawhide, probably gc related
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ecl (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
:
Depends On: 825473
Blocks: 821183
  Show dependency treegraph
 
Reported: 2012-05-16 20:49 EDT by Paulo Andrade
Modified: 2012-06-27 23:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 23:39:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paulo Andrade 2012-05-16 20:49:10 EDT
================================================================================
 Package       Arch             Version                 Repository         Size
================================================================================
Installing:
 ecl           x86_64           12.2.1-2.fc18           rawhide           3.7 M

Transaction Summary
================================================================================
Install  1 Package

Total download size: 3.7 M
Installed size: 18 M
Is this ok [y/N]: y
Downloading Packages:
ecl-12.2.1-2.fc18.x86_64.rpm                             | 3.7 MB     00:02     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
  Installing : ecl-12.2.1-2.fc18.x86_64                                     1/1 
  Verifying  : ecl-12.2.1-2.fc18.x86_64                                     1/1 

Installed:
  ecl.x86_64 0:12.2.1-2.fc18                                                    

Complete!
$ ecl
ecl: symbol lookup error: /usr/lib64/libecl.so.12.2: undefined symbol: GC_push_other_roots


I updated my system to rawhide to continue my work on porting sagemath
to fedora, so, now I guess I am in a wild land, but still :-) as the
target for sagemath should be fedora 18.

Initial discussion with upstream about it:
https://sourceforge.net/tracker/index.php?func=detail&aid=3526174&group_id=30035&atid=398053
Comment 1 Paulo Andrade 2012-05-20 14:39:17 EDT
I sent a message describing the problem to gc at linux.hpl.hp.com
asking for a suggestion to upstream ecl upstream.
Comment 2 Paulo Andrade 2012-05-20 15:22:03 EDT
BTW, just a few days after updating from fedora 16 to rawhide, now
what I see is:

$ ecl

Internal or unrecoverable error in:
Got signal before environment was installed on our thread.

;;; ECL C Backtrace
;;; /usr/lib64/libecl.so.12.2(si_dump_c_backtrace+0x31) [0x336a9655e1]
;;; /usr/lib64/libecl.so.12.2(ecl_internal_error+0x44) [0x336a94d384]
;;; /usr/lib64/libecl.so.12.2() [0x336a97c1c9]
;;; /usr/lib64/libpthread.so.0() [0x33cf60efe0]
;;; /usr/lib64/libecl.so.12.2(init_alloc+0x2b7) [0x336a992187]
;;; /usr/lib64/libecl.so.12.2(cl_boot+0x66) [0x336a85a0f6]
;;; ecl() [0x4009d9]
;;; /usr/lib64/libc.so.6(__libc_start_main+0xf5) [0x361ea21735]
;;; ecl() [0x400ab5]
Segmentation fault (core dumped)

that should be a side effect of some yum upgrade/update, what actually
would be a lot harder to figure out the cause (missing symbols).
Comment 3 Fedora Update System 2012-06-18 10:58:29 EDT
ecl-12.2.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ecl-12.2.1-3.fc17
Comment 4 Fedora Update System 2012-06-19 20:21:14 EDT
Package ecl-12.2.1-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ecl-12.2.1-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9647/ecl-12.2.1-3.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-06-27 23:39:39 EDT
ecl-12.2.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.