Bug 821187 - Replace Existing install, doesn't replace/delete 200MB HFS+ /boot/efi
Replace Existing install, doesn't replace/delete 200MB HFS+ /boot/efi
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 810646 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-12 18:05 EDT by Chris Murphy
Modified: 2013-01-10 03:30 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-16 12:50:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Murphy 2012-05-12 18:05:10 EDT
Description of problem:
Replace Existing installation type, does not replace/delete prior 200MB HFS+ /boot/efi partition. Instead, they accumulate, and appear in boot disk menus.

Version-Release number of selected component (if applicable):
F17 TC5 both Live Desktop & DVD
mactel-boot-0.9-5.fc17

How reproducible:
Always

Steps to Reproduce:
1. Start with a preexisting installation, already contains Mac OS & Fedora 17.
2. If DVD, choose "Fresh Installation" rather than upgrade.
3. Installation Type, default, Replace Existing Linux

  
Actual results:
Default partition layout does not replace/delete/reuse the previous installation's HFS+ /boot/efi, instead it creates a new one.

Translates into multiple non-functional Fedora boot icons at the option-key startup boot menu, and in System Preferences > Startup Disk. And it's not clear which one is functional.

Expected results:
Replace Existing should be able to identify prior installation's 200MB HFS+ /boot/efi partition and replace it, just as it replaces /boot, /home, and /.

Additional info:
The non-functional Fedora icon boot options, if chosen, result in a hang at GRUB that requires a forced power down. In the meantime, the computer gets rather hot, and the fan sounds like a hair dryer.
Comment 1 Chris Murphy 2012-05-12 18:08:16 EDT
The work around is to manually delete the superfluous (lower numbered) 200MB+ HFS+ partitions, leaving the most recent intact.
Comment 2 Chris Lumens 2012-05-14 10:08:28 EDT
dlehman has a fix for this on newui branch, strangely enough.
Comment 3 Chris Murphy 2012-05-16 11:19:40 EDT
Does not yet appear to be in today's TC6. Maybe RC1 hopefully.
Comment 4 Brian Lane 2012-05-16 12:50:43 EDT
This is not a blocker, it won't be in F17. It has been added to rawhide.
Comment 5 Chris Murphy 2012-05-16 13:15:58 EDT
Suggest a mention in Common Bugs:

Re-installing Fedora 17 on Macs in EFI mode creates superfluous 200MB HFS+ partitions.
When re-installing Fedora 17 on Macs using EFI boot, and choosing the "Replace Existing Linux" installation type, the previous 200MB HFS+ partition used as /boot/efi will not be replaced. Instead a new one will be created. Both old and new boot options will appear in the option-key startup boot menu, and in Mac OS System Preferences > Startup Disk panel. It will not be clear which option is functional. To avoid this ambiguity, delete the 200MB HFS+ partition prior to re-installing Fedora 17, either from within the Anaconda user interface, or a CLI tool capable of editing a GPT. This does not affect first time installs.
Comment 6 Adam Williamson 2012-05-16 13:32:38 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 David Lehman 2012-05-22 09:47:59 EDT
*** Bug 810646 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.