Bug 821201 - RFE: hardcode a volume name for LinuxHFS+ volume on Macs, so it doesn't appear as Untitled in OS X
RFE: hardcode a volume name for LinuxHFS+ volume on Macs, so it doesn't appea...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
: Reopened
: 822235 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-12 22:34 EDT by Chris Murphy
Modified: 2014-10-06 17:29 EDT (History)
8 users (show)

See Also:
Fixed In Version: blivet-0.61.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-06 17:29:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
program.log (256.51 KB, application/octet-stream)
2012-05-12 22:34 EDT, Chris Murphy
no flags Details
screen shot from within OS X Finder (99.61 KB, image/png)
2013-06-15 17:47 EDT, Chris Murphy
no flags Details
screen shot of Startup Disk panel (94.02 KB, image/png)
2013-06-15 17:48 EDT, Chris Murphy
no flags Details
anaconda 20.20-1 program.log (37.52 KB, text/plain)
2013-09-28 13:29 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2012-05-12 22:34:45 EDT
Created attachment 584084 [details]
program.log

Description of problem:
On EFI Macs, anaconda creates a 200MB HFS+ partition for /boot/efi and it lacks a label. This volume mounts in Mac OS X, and has a disk name of "untitled".

Version-Release number of selected component (if applicable):
Fedora-17.TC5-x86_64-Live-Desktop.iso

How reproducible:
Always

Steps to Reproduce:
1. Install on a Mac using EFI boot.
  
Actual results:
1. Option-key startup boot menu shows Fedora logo icon, label "untitled".
2. Mac OS System Preferences > Startup disk, shows label as:

     untitled
Linux, Fedora 17

3. The volume is mounted in Mac OS X, and has a name "untitled".
4. The volume name in Disk Utility, is "untitled".


Expected results:
The volume needs a name of some sort. Call it Beefy Miracle. Call it F17. Double up and call it Fedora. Anything but untitled which invites it being erased.

Additional info:
program.log contains a line:
18:47:12,978 ERR program: cp: cannot create regular file `/boot/efi/redhat/.disk_label': No such file or directory

Not sure if that's related. Or if -v "Fedora" should be used with mkfs.hfsplus which presently is not using -v to name the volume at creation time.
Comment 1 Chris Murphy 2012-05-16 11:28:36 EDT
Not completely fixed in Fedora-17.TC6-x86_64-Live-Desktop.iso.

Option-key+startup boot menu shows label "Fedora". However, the volume mounts in Mac OS X with label "untitled" as well as in System Preferences > Startup Disk.
Comment 2 Matthew Garrett 2012-05-16 11:37:15 EDT
Discussed this. It's not easily fixable, so certainly won't be happening for 17.
Comment 3 Chris Murphy 2012-05-16 12:07:38 EDT
If I copy the contents off /boot/efi and then reformat it with
mkfs.hfsplus -v Fedora /dev/sda3
then copy the contents back, I get "Fedora" as a label in Mac OS, mounted as well as in Startup Disk. On first reboot, option-key startup menu Fedora icon is now labeled "EFI Boot". Not ideal but I think tolerable. After rebooting Mac OS, and it becoming aware of this startup disks true label, subsequent reboots with option key shows the Fedora icon labeled as "Fedora".

Maybe there's some negative fallout to -v when creating the volume I'm not aware of, but it appears to resolve the problem.
Comment 4 Matthew Garrett 2012-05-16 12:20:13 EDT
Yes, we have no existing infrastructure for passing volume labels down through Anaconda.
Comment 5 Chris Murphy 2012-05-16 13:16:44 EDT
Got it. Might be worth a mention in release notes or common bugs.

Installing Fedora on Macs in EFI mode creates an "untitled" volume.
After installing Fedora 17 on a Mac using EFI boot, a 200MB volume named "untitled" will mount in Mac OS X, and also be visible in the System Preferences > Startup Disk panel. A limitation in Anaconda prevents this volume from being named. Users may optionally rename the volume, but should not otherwise modify its contents. Users familiar with vifs can edit fstab to prevent the volume from mounting if they wish.
Comment 6 Jesse Keating 2012-07-18 12:33:17 EDT
*** Bug 822235 has been marked as a duplicate of this bug. ***
Comment 7 Brian Lane 2013-06-14 20:05:27 EDT
I think this is fixed now. At least for my dual boot setup I get a nice Fedora logo to pick, not Untitled.
Comment 8 Chris Murphy 2013-06-15 17:45:54 EDT
Still a bug with Fedora-Live-Desktop-x86_64-19-TC3-1.iso. See screenshots.
Comment 9 Chris Murphy 2013-06-15 17:47:12 EDT
Created attachment 761708 [details]
screen shot from within OS X Finder
Comment 10 Chris Murphy 2013-06-15 17:48:00 EDT
Created attachment 761709 [details]
screen shot of Startup Disk panel
Comment 11 Chris Murphy 2013-06-15 17:48:48 EDT
Should be set to version 19.
Comment 12 Chris Murphy 2013-09-28 13:29:52 EDT
Created attachment 804461 [details]
anaconda 20.20-1 program.log

This is still a bug in F20, anaconda 20.20-1. It would be nice if a label could be set even if it's hard coded, so that the ESP doesn't appear as Untitled in OSX.

In the attached log if this line:
Running... mkfs.hfsplus /dev/sda4

Becomes:
Running... mkfs.hfsplus -v FedoraEFI /dev/sda4

Or some other reasonable name, this bug would be fixed.

Note You need to log in before you can comment on or make changes to this bug.