Bug 821224 - tntnet - A web application server for web applications
tntnet - A web application server for web applications
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On: 821220
Blocks: 821233 1045756
  Show dependency treegraph
 
Reported: 2012-05-13 05:27 EDT by MartinKG
Modified: 2015-10-06 16:13 EDT (History)
4 users (show)

See Also:
Fixed In Version: tntnet-2.2-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 15:00:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
michel: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description MartinKG 2012-05-13 05:27:35 EDT
A web application server for web applications, needed for vdr-live VDR
plugin.

Bugreport updstream:
Bugreport: zero-length files in tntnet-2.1
# https://sourceforge.net/tracker/?func=detail&aid=3525609&group_id=119301&atid=684048

Bugreport: shared-lib-calls-exit
# https://sourceforge.net/tracker/?func=detail&aid=3526265&group_id=119301&atid=684048

Bugreport: tntnet-devel-2.1 - no-documentation
https://sourceforge.net/tracker/?func=detail&aid=3526266&group_id=119301&atid=684048

Bugreport: tntnet-devel-2.1 - no manual-page-for-binary tntnet-config
https://sourceforge.net/tracker/?func=detail&aid=3526267&group_id=119301&atid=684048


SRPM URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-1.fc17.src.rpm?a=OfEaXzySruM

Spec URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet.spec?a=79HMFbYAEeI

rpmlint output:

rpmlint tntnet-2.1-1.fc17.src.rpm
tntnet.src: I: enchant-dictionary-not-found en_US
1 packages and 0 specfiles checked; 0 errors, 0 warnings.

rpmlint tntnet-2.1-1.fc17.x86_64.rpm
tntnet.x86_64: I: enchant-dictionary-not-found en_US
tntnet.x86_64: W: shared-lib-calls-exit /usr/lib64/libtntnet.so.10.0.0 exit@GLIBC_2.2.5
tntnet.x86_64: E: zero-length /usr/share/doc/tntnet-2.1/NEWS
tntnet.x86_64: E: zero-length /usr/share/doc/tntnet-2.1/TODO
1 packages and 0 specfiles checked; 2 errors, 1 warnings.

rpmlint tntnet-devel-2.1-1.fc17.x86_64.rpm
tntnet-devel.x86_64: I: enchant-dictionary-not-found en_US
tntnet-devel.x86_64: W: no-documentation
tntnet-devel.x86_64: W: no-manual-page-for-binary tntnet-config
1 packages and 0 specfiles checked; 0 errors, 2 warnings.
Comment 1 MartinKG 2012-05-29 15:20:50 EDT
changelog
* Tue May 29 2012 Martin Gansser <linux4martin@gmx.de> - 2.1-2
- removed license comment
- removed empty files
- fixed Requires and Group tag

SRPM URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-2.fc17.src.rpm?a=ShCi6YqDM8k

Spec URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet.spec?a=whNW54z8GWs

rpmlint output:
rpmlint tntnet-2.1-2.fc17.src.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.

rpmlint cxxtools-2.1.1-2.fc17.x86_64.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.

rpmlint cxxtools-devel-2.1.1-2.fc17.x86_64.rpm
cxxtools-devel.x86_64: W: no-documentation
cxxtools-devel.x86_64: W: no-manual-page-for-binary cxxtools-config
1 packages and 0 specfiles checked; 0 errors, 2 warnings.

rpmlint cxxtools-debuginfo-2.1.1-2.fc17.x86_64.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.
Comment 2 Robin Lee 2012-06-15 02:26:57 EDT
Upstream svn1364 patch is required to build with GCC 4.7
Comment 3 Robin Lee 2012-06-15 02:32:47 EDT
How about adding a systemd configuration?
Comment 4 MartinKG 2012-06-15 17:12:31 EDT
Robin,

is this the patch you mean ?

--- tntnet-2.1/framework/common/tnt/object.h    2012-02-09 19:47:38.000000000 +0100
+++ tntnet-svn1364/framework/common/tnt/object.h        2012-06-15 22:58:58.400842102 +0200
@@ -59,7 +59,7 @@
       ~PointerObject()
         { destroyPolicy<data_type>::destroy(ptr); }
       void set(data_type* ptr_)
-        { destroy(ptr); ptr = ptr_; }
+        { destroyPolicy<data_type>::destroy(ptr); ptr = ptr_; }
       data_type* get()  { return ptr; }
   };

~
Comment 5 Robin Lee 2012-06-16 14:14:50 EDT
This one:

$ svn diff -r 1363:1364
Index: framework/defcomp/static.cpp
===================================================================
--- framework/defcomp/static.cpp        (revision 1363)
+++ framework/defcomp/static.cpp        (revision 1364)
@@ -51,6 +51,7 @@
 #include <netinet/in.h>
 #include <netinet/tcp.h>
 #include <sys/poll.h>
+#include <unistd.h>
 #include <typeinfo>
 #include <errno.h>
 #endif
Comment 6 MartinKG 2012-06-16 15:20:40 EDT
changelog
* Sat Jun 16 2012 Martin Gansser <linux4martin@gmx.de> - 2.1-3
- gcc-4.7 patch
- added systemd service file
- removed sysv init stuff
- cleanup spec file

SRPM URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-3.fc17/tntnet-2.1-3.fc17.src.rpm?a=_U5sHZnowaA

Spec URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-3.fc17/tntnet.spec?a=36s7Yu8HXtQ
Comment 8 MartinKG 2012-06-17 08:04:22 EDT
changelog
* Sun Jun 17 2012 Martin Gansser <linux4martin@gmx.de> - 2.1-5
- fixed more missing slash in path
- fixed missing system unit file

SRPM URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-5.fc17/tntnet-2.1-5.fc17.src.rpm?a=VyadDn9veOk

Spec URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-5.fc17/tntnet.spec?a=qZFtm5BVgSM
Comment 9 MartinKG 2012-06-19 13:27:49 EDT
need Sponsor !
Comment 10 Ville Skyttä 2012-06-19 13:37:57 EDT
(In reply to comment #9)
> need Sponsor !

Nope, you don't need a sponsor (I'm your sponsor), you presumably mean that you need a reviewer for this package...
Comment 11 MartinKG 2012-06-19 16:50:34 EDT
right, i need a reviewer, I hope you had time.
Comment 12 MartinKG 2012-06-20 12:17:26 EDT
%changelog
* Wed Jun 20 2012 Martin Gansser <linux4martin@gmx.de> - 2.1-6
- changed group and user for fedora to apache

SRPM URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-6.fc17/tntnet-2.1-6.fc17.src.rpm?a=tFMXkddUWZc

Spec URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-6.fc17/tntnet.spec?a=kM34wjXeOIQ

reviewer are welcome !
Comment 13 Michel Alexandre Salim 2012-06-25 06:33:45 EDT
Taking this review
Comment 14 MartinKG 2012-06-25 12:43:59 EDT
%changelog
* Sun Jun 24 2012 Martin Gansser <linux4martin@gmx.de> - 2.1-8
- removed group and user apache from tntnet.conf
- added own group tntnet to tntnet.conf
- added creation of users and groups in pre section

SRPM URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-8.fc17/tntnet-2.1-8.fc17.src.rpm?a=mrLedpPhCkY

Spec URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-8.fc17/tntnet.spec?a=l2tVN0d4nz0
Comment 15 Michel Alexandre Salim 2012-06-25 23:29:11 EDT
Er, Martin, what's going on here? I see the reviewer flag reset and then switched to Ville Skytta (though according to Bugzilla's email, you did this, not Ville -- didn't even know that's possible), and for a while the component was changed from Package Review to 0xFFFF, that catch-all component for miscategorized bugs.

Let me know if you want me to do this review - seems like the flag change was inadvertent, but I'd of course let Ville do the review if that's your intention.
Comment 16 Ville Skyttä 2012-06-26 02:12:42 EDT
I'm assuming Martin did those changes by accident, I (being his sponsor) just tried to undo the mess. There's no way I could have affected who is the requestor of the fedora-review flag so it got set to me. So I think you're still very welcome to do this review.

BTW, 0xFFFF is not a catch-all component, it's real software.
http://www.nopcode.org/0xFFFF/
Comment 17 MartinKG 2012-06-26 03:24:52 EDT
Ville has alread pointed me out to do not change the flag. I am not aware of the fact that I have changed the flags,
I didn't know what is going on. Michael you're welcome to make this review.
Comment 18 Ville Skyttä 2012-06-26 12:17:34 EDT
I *guess* what happened is that the component was for some reason changed to 0xFFFF, and because the fedora-review flag is not valid for that component (it's only for Package Review), it got lost.
Comment 19 Michel Alexandre Salim 2012-06-27 00:49:14 EDT
Ah, that poor maintainer of 0xFFFF, how many bugs accidentally get assigned to it due to Bugzilla mix-ups? I think having a fake '0xDEAD' component might not be such a bad idea.

Clearing fedora-review, would have to set it again on the next update, I think. Sorry for the noise.
Comment 20 MartinKG 2012-07-03 13:17:48 EDT
%changelog
* Thu Jul 3 2012 Martin Gansser <linux4martin@gmx.de> - 2.1-9
- removed rm in install section
- removed systemd readme file
- added link to upstream systemd patch

SRPM URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-9.fc17/tntnet-2.1-9.fc17.src.rpm?a=nO4gxRikyFw

Spec URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-9.fc17/tntnet.spec?a=UEQ3_9_VG28
Comment 21 Michel Alexandre Salim 2012-07-11 07:51:07 EDT
Apologies for the delay, here's the review. There are some changes needed still, but the package looks almost ready for approval.


Package Review
==============

Key:
- = N/A
x = Pass
! = Fail
? = Not evaluated



==== C/C++ ====
[x]: MUST Package does not contain any libtool archives (.la)
[x]: MUST Package does not contain kernel modules.
[x]: MUST Package contains no static executables.
[x]: MUST Rpath absent or only used for internal libs.
[x]: MUST Package is not relocatable.


==== Generic ====
[x]: EXTRA Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: EXTRA Spec file according to URL is the same as in SRPM.
[x]: MUST Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: MUST Package successfully compiles and builds into binary rpms on at
     least one supported primary architecture.
[x]: MUST %build honors applicable compiler flags or justifies otherwise.
[x]: MUST All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: MUST Buildroot is not present
     Note: Unless packager wants to package for EPEL5 this is fine
[x]: MUST Package contains no bundled libraries.
[x]: MUST Changelog in prescribed format.
[x]: MUST Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
     Note: Clean would be needed if support for EPEL is required
[x]: MUST Sources contain only permissible code or content.
[x]: MUST %config files are marked noreplace or the reason is justified.
[x]: MUST Each %files section contains %defattr if rpm < 4.4
     Note: Note: defattr macros not found. They would be needed for EPEL5
[x]: MUST Macros in Summary, %description expandable at SRPM build time.
[-]: MUST Package contains desktop file if it is a GUI application.
[x]: MUST Package requires other packages for directories it uses.
[x]: MUST Package uses nothing in %doc for runtime.
[x]: MUST Package is not known to require ExcludeArch.
[x]: MUST Permissions on files are set properly.
[x]: MUST Package does not contain duplicates in %files.
[x]: MUST Fully versioned dependency in subpackages, if present.
[x]: MUST Package complies to the Packaging Guidelines
[x]: MUST Spec file lacks Packager, Vendor, PreReq tags.
[x]: MUST Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
     Note: rm -rf would be needed if support for EPEL5 is required
[-]: MUST Large documentation files are in a -doc subpackage, if required.
[x]: MUST If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %doc.
[!]: MUST License field in the package spec file matches the actual license.
     Note: Checking original sources for licenses Licenses found:
     "zlib/libpng", "UNKNOWN", "*No copyright* UNKNOWN", "GPL (v2 or later)",
     "LGPL (v2.1 or later)" For detailed output of licensecheck see file:
     /home/michel/sources/fedora/projects/FedoraReview/src/821224-tntnet/licensecheck.txt
     - framework/common/gcryptinit.c is GPLv2+, this should be added to the list
     of licenses (with a comment indicating which file is affected)
     - framework/common/unzip.h is under the zlib license -- ditto, add it to
     the list, so this should be e.g.:

     # GPLv2+: framework/common/gcryptinit.c
     # zlib:   framework/common/unzip.h
     License: LGPLv2+ and GPLv2+ and zlib

[x]: MUST License file installed when any subpackage combination is installed.
[x]: MUST Package consistently uses macros (instead of hard-coded directory
     names).
[x]: MUST Package is named using only allowed ascii characters.
[x]: MUST Package is named according to the Package Naming Guidelines.
[x]: MUST No %config files under /usr.
[x]: MUST Package does not generate any conflict.
[x]: MUST Package obeys FHS, except libexecdir and /usr/target.
[x]: MUST Package must own all directories that it creates.
[x]: MUST Package does not own files or directories owned by other packages.
[x]: MUST Package installs properly.
[x]: MUST Requires correct, justified where necessary.
[x]: MUST Rpmlint is run on all rpms the build produces.
     Note: No rpmlint messages.
[x]: MUST Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: MUST Spec file is legible and written in American English.
[x]: MUST Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: MUST Package contains systemd file(s) if in need.
[x]: MUST File names are valid UTF-8.
[x]: MUST Useful -debuginfo package or justification otherwise.
[x]: SHOULD Reviewer should test that the package builds in mock.
[-]: SHOULD If the source package does not include license text(s) as a
     separate file from upstream, the packager SHOULD query upstream to
     include it.
[x]: SHOULD Dist tag is present.
[x]: SHOULD No file requires outside of /etc, /bin, /sbin, /usr/bin,
     /usr/sbin.
[x]: SHOULD Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[?]: SHOULD Package functions as described.
[x]: SHOULD Latest version is packaged.
[x]: SHOULD Package does not include license text files separate from
     upstream.
[!]: SHOULD Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[-]: SHOULD Scriptlets must be sane, if used.
[x]: SHOULD SourceX / PatchY prefixed with %{name}.
[x]: SHOULD SourceX is a working URL.
[-]: SHOULD Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: SHOULD Package should compile and build into binary rpms on all supported
     architectures.
[-]: SHOULD %check is present and all tests pass.
     Upstream doesn't seem to ship unit tests  
[!]: SHOULD Packages should try to preserve timestamps of original installed
     files.
     Please try and replace invocations of 'install' with 'install -p', both
     in the spec file and in the Makefile
[x]: SHOULD Spec use %global instead of %define.

Issues:
[!]: MUST License field in the package spec file matches the actual license.
     Note: Checking original sources for licenses Licenses found:
     "zlib/libpng", "UNKNOWN", "*No copyright* UNKNOWN", "GPL (v2 or later)",
     "LGPL (v2.1 or later)" For detailed output of licensecheck see file:
     /home/michel/sources/fedora/projects/FedoraReview/src/821224-tntnet/licensecheck.txt
     - framework/common/gcryptinit.c is GPLv2+, this should be added to the list
     of licenses (with a comment indicating which file is affected)
     - framework/common/unzip.h is under the zlib license -- ditto, add it to
     the list, so this should be e.g.:

     # GPLv2+: framework/common/gcryptinit.c
     # zlib:   framework/common/unzip.h
     License: LGPLv2+ and GPLv2+ and zlib
[!]: SHOULD Patches link to upstream bugs/comments/lists or are otherwise
     justified.
     Please also upstream the gcc47 fixes and post the tracker URL
[!]: SHOULD Packages should try to preserve timestamps of original installed
     files.
     Please try and replace invocations of 'install' with 'install -p', both
     in the spec file and in the Makefile

Rpmlint
-------
Checking: 
0 packages and 0 specfiles checked; 0 errors, 0 warnings.


Rpmlint (installed packages)
----------------------------
Cannot parse rpmlint output:
Requires
--------
Provides
--------
MD5-sum check
-------------
/home/michel/sources/fedora/projects/FedoraReview/src/821224-tntnet/upstream/tntnet-2.1.tar.gz :
  MD5SUM this package     : a9c85aa6d624f7f88c48374f28730242
  MD5SUM upstream package : a9c85aa6d624f7f88c48374f28730242


Generated by fedora-review 0.2.0git
External plugins:
Comment 22 Michel Alexandre Salim 2012-07-13 00:29:08 EDT
The following snippet fixes the issue of files being installed without preserving modification timestamps:


--- tntnet.spec.orig	2012-07-06 13:58:16.506339380 +0700
+++ tntnet.spec	2012-07-13 11:27:45.005457825 +0700
@@ -34,7 +34,7 @@
 %patch1 -p1
 
 %build
-%configure --disable-static
+INSTALL="install -p" %configure --disable-static
 make %{?_smp_mflags}
 
 %install
Comment 23 MartinKG 2012-07-13 16:35:32 EDT
%changelog
* Fri Jul 13 2012 Martin Gansser <linux4martin@gmx.de> - 2.1-10
- added upstream link for gcc 4.7 patch
- changed license type
- make install preserve timestamps

SRPM URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-10.fc17/tntnet-2.1-10.fc17.src.rpm?a=PHr6ioR2ftc

Spec URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-10.fc17/tntnet.spec?a=hewbR_GWzS4
Comment 24 MartinKG 2012-07-18 14:54:54 EDT
Michel,

finally i need your approval for the review.

%changelog
* Wed Jul 18 2012 Martin Gansser <linux4martin@gmx.de> - 2.1-11
- added missing build requirement kernel-headers

SRPM URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-11.fc17/tntnet-2.1-11.fc17.src.rpm?a=nbJNcrhhSu0

Spec URL:
https://www.disk.dsl.o2online.de/FclyPlh/RPMS/VDR/tntnet/tntnet-2.1-11.fc17/tntnet.spec?a=RxrHP0VmxnE
Comment 25 Michel Alexandre Salim 2012-07-25 15:17:11 EDT
Everything looks fine; I'm approving this package, but could you add a new line between every changelog entry? Makes them easier to read.

Sorry for the delay (traveling for the past week)

APPROVED
Comment 26 MartinKG 2012-07-26 01:49:29 EDT
New Package SCM Request
=======================
Package Name: tntnet
Short Description: A web application server for web applications.
Owners: martinkg
Branches: f16 f17
InitialCC:
Comment 27 Jon Ciesla 2012-07-26 06:31:17 EDT
Git done (by process-git-requests).
Comment 29 Fedora Update System 2012-07-26 15:03:48 EDT
tntnet-2.1-13.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/tntnet-2.1-13.fc17
Comment 30 Fedora Update System 2012-07-26 15:04:52 EDT
tntnet-2.1-13.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/tntnet-2.1-13.fc16
Comment 31 Fedora Update System 2012-08-05 17:22:51 EDT
tntnet-2.1-13.fc17 has been pushed to the Fedora 17 stable repository.
Comment 32 Fedora Update System 2012-08-05 17:30:01 EDT
tntnet-2.1-13.fc16 has been pushed to the Fedora 16 stable repository.
Comment 33 Fedora Update System 2012-09-12 05:49:18 EDT
tntnet-2.1-15.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/tntnet-2.1-15.fc18
Comment 34 Fedora Update System 2012-09-17 19:29:58 EDT
tntnet-2.1-15.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 35 MartinKG 2012-10-18 14:35:10 EDT
Package Change Request
======================
Package Name: tntnet
New Branches: fc18
Owners: martinkg
InitialCC:
Comment 36 Jon Ciesla 2012-10-18 14:52:21 EDT
f18 branch exists.
Comment 37 Fedora Update System 2013-05-11 08:58:47 EDT
tntnet-2.2-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/tntnet-2.2-3.fc19
Comment 38 Ville Skyttä 2013-05-11 10:43:33 EDT
Martin: same thing here, please do not add ages old review tickets to package updates in bodhi, it's just unnecessary spam. The tntnet-2.2-3.fc19 update does not fix this bug - this one has been closed for about 7 months already.
Comment 39 Fedora Update System 2013-05-24 16:46:41 EDT
tntnet-2.2-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 40 MartinKG 2015-10-06 15:10:00 EDT
Package Change Request
======================
Package Name: tntnet
New Branches: fc23 devel
Owners: martinkg
InitialCC: 

[please untire tntnet, because package vdr-lieve depends on it]
Comment 41 Jon Ciesla 2015-10-06 16:13:40 EDT
This SCM request method has been deprecated. Please see https://fedoraproject.org/wiki/PackageDB_admin_requests.

Note You need to log in before you can comment on or make changes to this bug.