Bug 821418 - AJAX components not working in ER5
AJAX components not working in ER5
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: RichFaces (Show other bugs)
2.0.0.ER5
Unspecified Unspecified
urgent Severity urgent
: ---
: 2.0.0.ER6
Assigned To: Brian Leathem
Pavol Pitonak
:
Depends On: 820579
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 08:42 EDT by Pavol Pitonak
Modified: 2012-06-22 03:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 03:32:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavol Pitonak 2012-05-14 08:42:29 EDT
Description of problem:


Version-Release number of selected component (if applicable):
RichFaces 4.2.1.Final-redhat-1

How reproducible:


Steps to Reproduce:
1. deploy RichFaces Showcase (download war from https://hudson.qa.jboss.com/hudson/view/RF-Prod/job/richfaces-wfk-2.0-tests or build it yourself)
2. open a4j:ajax component
3. type something into input
4. select some other component from "Inputs" group
  
Actual results:
- a lot of JavaScript errors (Uncaught TypeError: Object #<Object> has no method 'ajax')
- menu doesn't work

Expected results:
output should be updated using ajax

Additional info:
the same problems are in Metamer (RichFaces testing application)
Comment 1 Karel Piwko 2012-05-14 09:50:09 EDT
This is likely caused by 820579
Comment 2 Marek Novotny 2012-05-30 15:56:55 EDT
Check that for ER6/ER7
Comment 3 Pavol Pitonak 2012-06-01 07:37:54 EDT
Works fine in both ER6 and ER7.

Note You need to log in before you can comment on or make changes to this bug.