Bug 821467 - F17 alpha PPC64: DMError - partition activation failed for multipathd
F17 alpha PPC64: DMError - partition activation failed for multipathd
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: device-mapper-multipath (Show other bugs)
17
ppc64 All
unspecified Severity urgent
: ---
: ---
Assigned To: Ben Marzinski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 11:21 EDT by IBM Bug Proxy
Modified: 2012-10-22 10:39 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 10:39:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
http-install-console-log.txt (359.53 KB, text/plain)
2012-05-14 11:22 EDT, IBM Bug Proxy
no flags Details
dmerror-exception-1.png (119.85 KB, image/png)
2012-05-14 11:22 EDT, IBM Bug Proxy
no flags Details
dmerror-exception-2.png (86.12 KB, image/png)
2012-05-14 11:22 EDT, IBM Bug Proxy
no flags Details
anaconda.log (5.44 KB, text/plain)
2012-05-14 11:22 EDT, IBM Bug Proxy
no flags Details
anaconda-tb-_pX3tc (297.34 KB, text/plain)
2012-05-14 11:23 EDT, IBM Bug Proxy
no flags Details
anaconda-yum.con (367 bytes, text/plain)
2012-05-14 11:23 EDT, IBM Bug Proxy
no flags Details
program.log (19.98 KB, text/plain)
2012-05-14 11:23 EDT, IBM Bug Proxy
no flags Details
storage.log (155.45 KB, text/plain)
2012-05-14 11:23 EDT, IBM Bug Proxy
no flags Details
syslog (73.15 KB, text/plain)
2012-05-14 11:23 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 81557 None None None Never

  None (edit)
Description IBM Bug Proxy 2012-05-14 11:21:59 EDT
While installing Fedora 17 beta PPC64 on a Juno IOCL P7 LPAR, an unhandled exception occurred.
Here is the details scenario which produced exception:

1) There are four multipath disk attached along with one native disk on the LPAR
2) First tried to install on one of the multipath disk which leads to Bug # 81329.
3) Then rebooted the system and tried to install on the basic storage using HTTP repo method
4) While anaconda tried to scan for all devices attached on to the server , it failed to do partition activation for multpathd and generated exception.

Installation got blocked there and could not proceed  further
Comment 1 IBM Bug Proxy 2012-05-14 11:22:13 EDT
Created attachment 584386 [details]
http-install-console-log.txt
Comment 2 IBM Bug Proxy 2012-05-14 11:22:31 EDT
Created attachment 584387 [details]
dmerror-exception-1.png
Comment 3 IBM Bug Proxy 2012-05-14 11:22:43 EDT
Created attachment 584388 [details]
dmerror-exception-2.png
Comment 4 IBM Bug Proxy 2012-05-14 11:22:55 EDT
Created attachment 584389 [details]
anaconda.log
Comment 5 IBM Bug Proxy 2012-05-14 11:23:09 EDT
Created attachment 584390 [details]
anaconda-tb-_pX3tc
Comment 6 IBM Bug Proxy 2012-05-14 11:23:21 EDT
Created attachment 584392 [details]
anaconda-yum.con
Comment 7 IBM Bug Proxy 2012-05-14 11:23:32 EDT
Created attachment 584393 [details]
program.log
Comment 8 IBM Bug Proxy 2012-05-14 11:23:44 EDT
Created attachment 584394 [details]
storage.log
Comment 9 IBM Bug Proxy 2012-05-14 11:23:57 EDT
Created attachment 584395 [details]
syslog
Comment 10 IBM Bug Proxy 2012-05-16 11:01:41 EDT
------- Comment From hamzy@us.ibm.com 2012-05-16 14:56 EDT-------
Okay, it seems that there is a problem with sdd.

09:45:26,841 INFO program: create: mpathd (3600a0b800013e38e000012644fa126dc) undef AIX,VDASD
09:45:26,841 INFO program: size=10G features='0' hwhandler='0' wp=undef
09:45:26,841 INFO program: `-+- policy='round-robin 0' prio=0 status=undef
09:45:26,842 INFO program:   |- 0:0:4:0 sdd 8:48  undef ready running
09:45:26,842 INFO program:   `- 1:0:3:0 sdh 8:112 undef ready running
09:45:35,191 INFO program: Running... udevadm settle --timeout=300
09:45:35,408 INFO program: Running... kpartx -a -p p /dev/mapper/mpathd
09:45:35,418 ERR program: device-mapper: resume ioctl on mpathdp1 failed: Invalid argument
09:45:35,419 ERR program: resume failed on mpathdp1
Comment 11 IBM Bug Proxy 2012-05-16 15:01:33 EDT
------- Comment From hamzy@us.ibm.com 2012-05-16 18:55 EDT-------
Hello Manas,

Can you list the exact steps to reproduce this defect?  I've tried twice now to install and it seems to be working for me.  Although I don't know if I am using the multipath setup correctly.
Comment 12 IBM Bug Proxy 2012-05-17 10:41:39 EDT
------- Comment From hamzy@us.ibm.com 2012-05-17 14:30 EDT-------
Oh and by the way Manas, you need to do the installation with the default Fedora 17 internet repository.  There is a bug ( https://bugzilla.redhat.com/show_bug.cgi?id=822495 ) that causes multipath not to be enabled when booting into the installed system.
Comment 13 IBM Bug Proxy 2012-05-17 13:41:43 EDT
------- Comment From maknayak@in.ibm.com 2012-05-17 17:32 EDT-------
(In reply to comment #16)
> Hello Manas,
>
> Can you list the exact steps to reproduce this defect?  I've tried twice now
> to install and it seems to be working for me.  Although I don't know if I am
> using the multipath setup correctly.

Hello Mark,
I have mentioned exact steps to reproduce this issue in my problem description part.
After that I tried many times by just rebooting the system and installed from http repo. Right after the installation starts looking for the devices present in system ...it gets dropped to the error mentioned in this bug report.

As you told you were succeeded  in getting ahead with installation and did not see the error, I have also similar experience when it did not get reproduced and installation went ahead. But it happened twice with my 6 to 7 retries . I could reproduce the issue many time , I can retry again and update you.

Thanks...
Manas
Comment 14 IBM Bug Proxy 2012-05-21 07:11:36 EDT
------- Comment From maknayak@in.ibm.com 2012-05-21 11:01 EDT-------
(In reply to comment #18)
> (In reply to comment #16)
. I could reproduce the issue many time , I can retry again and
> update you.
>
> Thanks...
> Manas

Hello Mark,
I retried with the ISO image of f17 beta mentioned in the Comment#12 but could not reproduce again. First installed on one of the multipath disk by selecting for special storage option , which got some boot loader installation error message before installation gets finished. Right after that, booted  from the same virtual DVD and installed on basic storage device , and this time did not reproduce the issue.

Thanks...
Manas

Note You need to log in before you can comment on or make changes to this bug.