Bug 82164 - Installer stops about to install with traceback error
Installer stops about to install with traceback error
Status: CLOSED DUPLICATE of bug 76123
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-18 12:04 EST by Luis de la Fuente
Modified: 2007-04-18 12:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis de la Fuente 2003-01-18 12:04:23 EST
Description of problem:
I tried to install RH 8.0, from CD ROM, in a Pentium III 666MHz, 64MB RAM 
computer and IDE/ATAPI disk drive with 10GB. When it was about to install it 
gave an traceback error that I will reproduce.

I tried the same process 4 times with the same error.

I searched for this error and patches here in Bugzilla and the internet. This 
error was present in previous versions of the installer and was suppossed to 
occur when less than 250MB were assigned to the /root partition, but as you 
can see I assigned 4500MB to that partition.

Thanks for reading. I hope it can be fixed.

Regards,
Luis


Version-Release number of selected component (if applicable): Red Hat Linux 8.0


How reproducible: Every time


Steps to Reproduce:
1. Installer correctly detected monitor, mouse and keyboard.
2. I selected Spanish as the language for installation. Same with keyboard.
3. Selected a 2 button generic PS2 mouse with 3 button emulation.
4. Selected personal desktop type installation.
5. Relied on automatic partitioning keeping all existing partitions and using 
free space, with the following result:

hda1 MSDOS/Windows 4800 MB(aprox)
hda2 /boot 102MB
hda3 / 4500MB (aprox)
hda4 swap partition 188MB

6. Selected GRUB loader (no password, no advanced options)
7. Left default network and firewall configuration.
8. Language support spanish and Spain's time zone.
9. Set root password and created user account. 
10. Customized package group selection, which mainly included X-Windows, 
Gnome, KDE and other utilities. No server or development tools.
11. Hit Install and obtained the error message.

    
Actual results:
This is the error message I obtained (it didn't allow to save to floppy, so I 
may have copied it wrong):

Traceback (most recent call last):
File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
  self.currentWindow.renderCallback()
File "/usr/lib/anaconda/iw/progress_qui.py", line 149, in renderCallback
  self.intf.iew.nextClicked()
File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
  self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
  self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
 rc = apply (func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 430, in turnOnFilesystems
  partitions.doMetaDeletes(diskset)
File "/usr/lib/anaconda/lvm.py", line 54, in vgactivate
  searchPath = 1
File "/usr/lib/anaconda/iutil.py", line 66, in execWithRedirect
  childpid = os.fork()

OSError: [Erno 12] No se pudo asignar memoria

The last phrase means something like "Memory could not be assigned".


Expected results:
Packages should have been saved correctly.
Comment 1 Michael Lee Yohe 2003-01-21 08:54:54 EST
Please see Bug 76123.  You can install Red Hat Linux 8.0 in text mode with 64M
of RAM.
Comment 2 Jeremy Katz 2003-01-22 01:01:56 EST

*** This bug has been marked as a duplicate of 76123 ***
Comment 3 Greg Hinds 2003-01-29 23:24:53 EST
What is the resolution of this?
Comment 4 Red Hat Bugzilla 2006-02-21 13:51:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.