Bug 821703 - System subscription not done appropriately
System subscription not done appropriately
Status: CLOSED DUPLICATE of bug 769559
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Bryan Kearney
SAM QE List
:
Depends On:
Blocks: sam11-tracker 822105
  Show dependency treegraph
 
Reported: 2012-05-15 07:23 EDT by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 822105 (view as bug list)
Environment:
Last Closed: 2012-05-23 13:43:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Subscription Insufficient entitlements (160.68 KB, image/png)
2012-05-15 07:23 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2012-05-15 07:23:31 EDT
Created attachment 584643 [details]
Subscription Insufficient entitlements

Description of problem:
Created two organisations on SAM server.imported manifests for each.
tried to subscribe the system to the subscriptions.
one of the system did not subscribe appropriately.

Version-Release number of selected component (if applicable):
[root@dell-pe1950-01 ~]# rpm -qa  | grep katello
katello-cli-common-0.3.2-1.el6_2.noarch
katello-glue-candlepin-0.3.1-1.el6_2.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-headpin-0.2.0-1.el6_2.noarch
katello-selinux-0.2.4-1.el6_2.noarch
katello-headpin-0.2.6-1.el6_2.noarch
katello-certs-tools-1.1.5-1.el6_2.noarch
katello-configure-0.3.3-1.el6_2.noarch
katello-common-0.3.1-1.el6_2.noarch
katello-headpin-all-0.2.6-1.el6_2.noarch


How reproducible:
install a SAM server.
create two organisations
import manifests for both.
register the systems with SAM server
subscribe them.

Steps to Reproduce:
[root@dell-pe1950-01 ~]# headpin -u admin -p admin system list --org testorg
--------------------------------------------------------------------------------
                       Systems List For Org [ testorg ]

 Name                                  Ipv4 Address   Service Level  
--------------------------------------------------------------------------------
 hp-dl585-02.rhts.eng.bos.redhat.com   None                          
 ibm-hs22-03.rhts.eng.brq.redhat.com   None 

[root@hp-dl585-02 ~]# subscription-manager list 
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux Server
Version:            	6.2                      
Arch:               	x86_64                   
Status:             	Subscribed               
Starts:             	01/30/2012               
Expires:            	01/30/2013    
 
the cpu info for the system which did not subscribe appropriately.
http://pastebin.test.redhat.com/89073
Screen shot attached.

Actual results:
systems did not subscribe properly.


Expected results:
system should be subscribed correctly.

Additional info:
Comment 2 RHEL Product and Program Management 2012-05-15 07:24:30 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.
Comment 3 RHEL Product and Program Management 2012-05-15 07:44:37 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.
Comment 4 Eric Sammons 2012-05-17 12:43:36 EDT
Can you explain "systems did not subscribe properly"?
Comment 5 Tom McKay 2012-05-23 13:43:25 EDT
This is a known issue of lower priority. Closing as duplicate of 769559

*** This bug has been marked as a duplicate of bug 769559 ***

Note You need to log in before you can comment on or make changes to this bug.