Bug 821740 - synfigstudio-0.63.05-1.fc16: package contains wrong files
synfigstudio-0.63.05-1.fc16: package contains wrong files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: synfigstudio (Show other bugs)
16
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
: 829087 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 09:36 EDT by Daniel Koukola
Modified: 2012-06-09 21:35 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-02 19:59:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Koukola 2012-05-15 09:36:02 EDT
Description of problem:

Package contains shared MIME-Info database cache files.

Version-Release number of selected component (if applicable):

0.63.05-1.fc16

How reproducible:

Install the package.
  
Actual results:

Shared MIME-Info database cache gets overwritten which breaks file type recognition in many applications.

Expected results:

Only /usr/share/mime/packages/synfigstudio.xml should be installed and then update-mime-database should be run.
Comment 1 J. Randall Owens 2012-05-15 19:16:33 EDT
Would this be the reason my icons stopped showing up system-wide (KDE & Gnome), my panel buttons started opening .desktop files in text editors instead of launching applications, and KOrganizer started generating crashes repeatedly on login?  If so, then yes, very urgent, please fix ASAP!  It leaves the entire system very difficult to use.

Also, we might want to include some keywords here that will help people find this, since the symptoms don't seem to point at synfigstudio at all; I spent a lot of the last day trying to find what the problem might be.

The quick fix, for anyone who might find this and need a working system before the fixed package comes along, is to run (as root) the command:
/usr/bin/update-mime-database /usr/share/mime

At least, that seems to have worked for me, and seems like it should work generally in principle.  You'll have to log out and in before it really fixes things.
Comment 2 Daniel Koukola 2012-05-16 16:41:49 EDT
Yes, the symptoms you describe are all very likely to be caused by this bug.
Comment 3 Luya Tshimbalanga 2012-05-17 21:59:22 EDT
I am unable to reproduce this bug with synfigstudio. Could it be an issue related to share-mime?
Comment 4 Alexander Boström 2012-05-20 03:27:43 EDT
Perhaps on your system something else regenerated mime.cache after synfigstudio-0.63.05-1.fc16 was installed. If you remove and install it again then you will probably see the problem.

Remove %{_datadir}/mime from %files and add the proper scriptlets to regenerate the files:
https://fedoraproject.org/wiki/PackagingDrafts/ScriptletSnippets#mimeinfo_.28Needs_description.29
Comment 5 Luya Tshimbalanga 2012-05-22 01:47:38 EDT
(In reply to comment #4)
> Perhaps on your system something else regenerated mime.cache after
> synfigstudio-0.63.05-1.fc16 was installed. If you remove and install it
> again then you will probably see the problem.
> 
> Remove %{_datadir}/mime from %files and add the proper scriptlets to
> regenerate the files:
> https://fedoraproject.org/wiki/PackagingDrafts/ScriptletSnippets#mimeinfo_.
> 28Needs_description.29

Following your suggestion, I got an error from the build using rawhide:
http://koji.fedoraproject.org/koji/buildinfo?buildID=320027
Comment 6 Luya Tshimbalanga 2012-05-23 19:10:12 EDT
(In reply to comment #2)
> Yes, the symptoms you describe are all very likely to be caused by this bug.

Could you test
http://koji.fedoraproject.org/koji/buildinfo?buildID=320311 ?

I cannot push the fix for F17 yet because of the release freeze. After f17 release, I will push the  fixes and please provides karma for faster pushes on stable.
Comment 7 Daniel Koukola 2012-05-24 01:57:42 EDT
(In reply to comment #6)
> (In reply to comment #2)
> > Yes, the symptoms you describe are all very likely to be caused by this bug.
> 
> Could you test
> http://koji.fedoraproject.org/koji/buildinfo?buildID=320311 ?
> 
> I cannot push the fix for F17 yet because of the release freeze. After f17
> release, I will push the  fixes and please provides karma for faster pushes
> on stable.

synfigstudio-0.63.05-2.fc16 still contains those MIME-Info database cache files, but they get rebuilt immediately after the package installation, so the problem no longer manifests itself. But those files are then still owned by this package, which is not desirable.
Comment 8 Luya Tshimbalanga 2012-05-29 14:52:33 EDT
(In reply to comment #7)
> synfigstudio-0.63.05-2.fc16 still contains those MIME-Info database cache
> files, but they get rebuilt immediately after the package installation, so
> the problem no longer manifests itself. But those files are then still owned
> by this package, which is not desirable.

Could you test 
https://koji.fedoraproject.org/koji/taskinfo?taskID=4112886 ?

The binary package should only contain xml files on /usr/share/mime/package. I am pushing the fix in a few moment and please add karma.
Comment 9 Alexander Boström 2012-05-30 01:27:34 EDT
# rpm -qf /usr/share/mime
shared-mime-info-0.91-5.fc16.x86_64

# rpm -i synfigstudio-0.63.05-3.fc16.x86_64.rpm 

# rpm -qf /usr/share/mime
shared-mime-info-0.91-5.fc16.x86_64
synfigstudio-0.63.05-3.fc16.x86_64

The package owns the common directory, which I believe it should not do. Probably you need to be more specific in %files and specify the file(s) instead of the directory.
Comment 10 Luya Tshimbalanga 2012-05-30 13:00:22 EDT
Could you test
https://koji.fedoraproject.org/koji/taskinfo?taskID=4113908 ?

$ rpm -qa | grep synfigstudio
synfigstudio-0.63.05-3.fc16.x86_64

$ rpm -qf /usr/share/mime
shared-mime-info-1.0-4.fc17.x86_64
Comment 11 Daniel Koukola 2012-05-30 13:55:38 EDT
The common directory isn't owned by the package on my system:

# rpm -qf /usr/share/mime
shared-mime-info-0.91-5.fc16.x86_64

# rpm -qf /usr/share/mime/packages/synfigstudio.xml 
synfigstudio-0.63.05-3.fc16.x86_64

But there is still one file that shouldn't be there:

# rpm -qf /usr/share/mime/application/x-sif.xml 
synfigstudio-0.63.05-3.fc16.x86_64

That one is generated automatically by update-mime-database.
Comment 12 Luya Tshimbalanga 2012-05-30 17:16:42 EDT
Could you test
https://koji.fedoraproject.org/koji/taskinfo?taskID=4115356
?

Here is my result

$ rpm -qf /usr/share/mime
shared-mime-info-1.0-4.fc17.x86_64

$ rpm -qf /usr/share/mime/packages/synfigstudio.xml 
synfigstudio-0.63.05-3.fc16.x86_64

$rpm -qf /usr/share/mime/application/x-sif.xml 
file /usr/share/mime/application/x-sif.xml is not owned by any package
Comment 13 Daniel Koukola 2012-05-30 17:40:45 EDT
(In reply to comment #12)
> Could you test
> https://koji.fedoraproject.org/koji/taskinfo?taskID=4115356
> ?
> 
> Here is my result
> 
> $ rpm -qf /usr/share/mime
> shared-mime-info-1.0-4.fc17.x86_64
> 
> $ rpm -qf /usr/share/mime/packages/synfigstudio.xml 
> synfigstudio-0.63.05-3.fc16.x86_64
> 
> $rpm -qf /usr/share/mime/application/x-sif.xml 
> file /usr/share/mime/application/x-sif.xml is not owned by any package

Same here, looks good to me.
Comment 14 Fedora Update System 2012-05-31 00:26:25 EDT
synfigstudio-0.63.05-3.1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/synfigstudio-0.63.05-3.1.fc16
Comment 15 Fedora Update System 2012-05-31 00:26:40 EDT
synfigstudio-0.63.05-3.1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/synfigstudio-0.63.05-3.1.fc15
Comment 16 Fedora Update System 2012-05-31 00:28:47 EDT
synfigstudio-0.63.05-3.1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/synfigstudio-0.63.05-3.1.fc17
Comment 17 Fedora Update System 2012-06-01 12:56:57 EDT
Package synfigstudio-0.63.05-3.1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing synfigstudio-0.63.05-3.1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8689/synfigstudio-0.63.05-3.1.fc15
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2012-06-02 19:59:03 EDT
synfigstudio-0.63.05-3.1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Luya Tshimbalanga 2012-06-05 20:22:12 EDT
*** Bug 829087 has been marked as a duplicate of this bug. ***
Comment 20 Fedora Update System 2012-06-09 21:33:37 EDT
synfigstudio-0.63.05-3.1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2012-06-09 21:35:13 EDT
synfigstudio-0.63.05-3.1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.