Bug 829087 - mime types get corrupted, causing loss of use of many pic & icons, crashing GTK & Gnome3
mime types get corrupted, causing loss of use of many pic & icons, crashing G...
Status: CLOSED DUPLICATE of bug 821740
Product: Fedora
Classification: Fedora
Component: synfigstudio (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 18:34 EDT by YBnawtbug
Modified: 2012-06-05 20:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 20:22:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description YBnawtbug 2012-06-05 18:34:05 EDT
Description of problem:
     After upgrade of synfigstudio and its devel package, many to most icons and pics start to disappear, with reports of "Unrecognized file format" and "Couldn't recognize the image file format" on quite a few svgs. I hunted around and found this person with similar problem "http://forums.fedoraforum.org/showthread.php?p=1581865&mode=linear&s=6b6a9f03725631df1cf8c9106fbd3d67&", of which I was a helper in solving, and I found this solved post "http://www.spinics.net/linux/fedora/fedora-users/msg417967.html", which helped me.

To fix the corruption of the mime db (as root):

update-mime-database /usr/share/mime
chmod 664 /usr/share/applications/mimeinfo.cache

Version-Release number of selected component (if applicable):
synfigstudio-0.63.05-3.1.fc16.x86_64
synfigstudio-devel-0.63.05-3.1.fc16.x86_64

How reproducible:
Not quite known, and I don't want to go throught that again!

Steps to Reproduce:
1. Update synfigstudio
2.
3.
  
Actual results:
     loss of the use of many pics, svgs, pngs, etc.


Expected results:
     no loss of any pic format in any programs after update.

Additional info:
     Please fix the rpms & their scripts asap, as I know now of at least 3 people with said problem, one in F17, and, as this update gets applied, it will probably cause many others.
Comment 1 Luya Tshimbalanga 2012-06-05 20:22:12 EDT
Greetings,
The update related this bug is already available and should land on Fedora 16. Other version for both F15 and 17 needs testing to be pushed to stable repository.
https://admin.fedoraproject.org/updates/search/synfigstudio?_csrf_token=c7df9d8a570a322ffbabc707804106ee02318f51

Please, add karma for that effect. Thank you.

*** This bug has been marked as a duplicate of bug 821740 ***

Note You need to log in before you can comment on or make changes to this bug.