Bug 821856 - [abrt] rapidsvn-0.12.0-4.fc17: svn_wc_check_wc2: Process /usr/bin/rapidsvn was killed by signal 11 (SIGSEGV)
[abrt] rapidsvn-0.12.0-4.fc17: svn_wc_check_wc2: Process /usr/bin/rapidsvn wa...
Status: CLOSED DUPLICATE of bug 827102
Product: Fedora
Classification: Fedora
Component: rapidsvn (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Jackson
Fedora Extras Quality Assurance
abrt_hash:0e256f970bd8396c4917985da79...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 11:19 EDT by david.lewis
Modified: 2012-07-03 15:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-03 15:18:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (28.69 KB, text/plain)
2012-05-15 11:19 EDT, david.lewis
no flags Details
File: maps (64.04 KB, text/plain)
2012-05-15 11:19 EDT, david.lewis
no flags Details
File: dso_list (12.43 KB, text/plain)
2012-05-15 11:19 EDT, david.lewis
no flags Details
File: build_ids (5.37 KB, text/plain)
2012-05-15 11:19 EDT, david.lewis
no flags Details

  None (edit)
Description david.lewis 2012-05-15 11:19:33 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        rapidsvn
comment:        trying to check out a project
crash_function: svn_wc_check_wc2
executable:     /usr/bin/rapidsvn
kernel:         3.3.2-8.fc17.x86_64
pid:            7335
pwd:            /home/dlewis/imaging
remote_result:  NOTFOUND
time:           Tue 01 May 2012 01:43:23 PM EDT
uid:            1000
username:       dlewis
xsession_errors: 

backtrace:      Text file, 29380 bytes
build_ids:      Text file, 5494 bytes
dso_list:       Text file, 12727 bytes
maps:           Text file, 65572 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/dlewis/2

core_backtrace:
:2821d1f4dd6fca8a5f41f739a9146c2bdc0aeb0d 0x33120 svn_wc_check_wc2 libsvn_wc-1.so.0 -
:94a55e499752b3c3a03ebc750272a16f57f857f1 0x1b3ed svn_client__checkout_internal libsvn_client-1.so.0 -
:94a55e499752b3c3a03ebc750272a16f57f857f1 0x1b5f8 svn_client_checkout3 libsvn_client-1.so.0 -
:94a55e499752b3c3a03ebc750272a16f57f857f1 0x293fb svn_client_checkout2 libsvn_client-1.so.0 -
:326a957533a40aada7b174301a0ad3520f0ff405 0xe8b9 svn::Client::checkout(char libsvncpp.so.3 -
:ac7d5543a5d51278315c90503e49d5199c002dc6 0x29a2a - [exe] -
:ac7d5543a5d51278315c90503e49d5199c002dc6 0x792c3 - [exe] -
:1930c8cd9ca42879da095fd8b54478483f71d785 0xe56ab wxThreadInternal::PthreadStart(wxThread*) libwx_baseu-2.8.so.0 -
:70f10a584fcf32ef4994cc1bc209964515ad49c9 0x7d14 start_thread libpthread.so.0 -
:11d196ee9220c6039404f4ba675abf3a24d8f0aa 0xf194d clone libc.so.6 -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=CND0290WW9
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=6c568b56c1453d6689a6c7e50000001b-1335876395.892957-1695888773
:QTDIR=/usr/lib64/qt-3.3
:GNOME_KEYRING_CONTROL=/run/user/dlewis/keyring-sT2vCc
:QTINC=/usr/lib64/qt-3.3/include
:IMSETTINGS_MODULE=none
:USER=dlewis
:MAIL=/var/spool/mail/dlewis
:PATH=/usr/lib64/qt-3.3/bin:/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/dlewis/.local/bin:/home/dlewis/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/dlewis
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1670
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/dlewis
:SHLVL=1
:LOGNAME=dlewis
:QTLIB=/usr/lib64/qt-3.3/lib
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-oaC0xKKzIY,guid=959fca10114baf0571eaee2300000053
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/dlewis
:DISPLAY=:0
:CCACHE_HASHDIR=
:XAUTHORITY=/var/run/gdm/auth-for-dlewis-vnzefY/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1674,unix/unix:/tmp/.ICE-unix/1674
:GPG_AGENT_INFO=/run/user/dlewis/keyring-sT2vCc/gpg:0:1
:SSH_AUTH_SOCK=/run/user/dlewis/keyring-sT2vCc/ssh
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/fedora-rapidsvn.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=7335

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 62631                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       62631                62631                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/dlewis/.xsession-errors
:pos:	1489428
:flags:	0102002
:2:/home/dlewis/.xsession-errors
:pos:	1489428
:flags:	0102002
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:socket:[676071]
:pos:	0
:flags:	02004002
:5:socket:[676074]
:pos:	0
:flags:	02004002
:6:anon_inode:inotify
:pos:	0
:flags:	02004000
:7:/dev/urandom
:pos:	0
:flags:	02100000
:8:socket:[679135]
:pos:	0
:flags:	02000002
:9:socket:[808734]
:pos:	0
:flags:	02004002
:10:/dev/urandom
:pos:	0
:flags:	02100000

smolt_data:
:
:
:General
:=================================
:UUID: cf2ebb54-0ffb-4e65-b8c8-0ee9d33acdd5
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 4788.15
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5 CPU       M 520  @ 2.40GHz
:CPU Stepping: 2
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 2400
:System Memory: 7848
:System Swap: 9951
:Vendor: Hewlett-Packard
:System: HP EliteBook 8540p 
:Form factor: Notebook
:Kernel: 3.3.4-5.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4147:404:4156:5409) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:16953:32902:4881) pci, iwlwifi, NETWORK, Centrino Advanced-N 6200 2x2 AGN
:(32902:11362:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:11521:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:68:4156:5409) pci, None, HOST/PCI, Core Processor DRAM Controller
:(32902:69:4156:5409) pci, pcieport, PCI/PCI, Core Processor PCI Express x16 Root Port
:(32902:11536:32902:32902) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11537:32902:32902) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11538:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(32902:11539:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15151:4156:5409) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 6 port SATA AHCI Controller
:(32902:15111:4156:5409) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(32902:15154:4156:5409) pci, intel ips, NONE, 5 Series/3400 Series Chipset Thermal Subsystem
:(32902:4330:4156:5409) pci, e1000e, ETHERNET, 82577LM Gigabit Network Connection
:(32902:9288:4156:5409) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:15164:4156:5409) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15156:4156:5409) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15204:4156:5409) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:15176:4156:5409) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 4
:(32902:15170:4156:5409) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15172:4156:5409) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 2
:(32902:15184:4156:5409) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 8
:(32902:15190:4156:5409) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(32902:15207:4156:5409) pci, serial, 16550_SERIAL, 5 Series/3400 Series Chipset KT Controller
:(4318:3042:4156:5409) pci, snd_hda_intel, MULTIMEDIA, High Definition Audio Controller
:(4318:2604:4156:5409) pci, nouveau, VIDEO, GT216 [NVS 5100M]
:(4480:1426:4156:5409) pci, r592, BASE, R5C592 Memory Stick Bus Host Adapter
:(4480:2130:4156:5409) pci, None, BASE, xD-Picture Card Controller
:(4480:2098:4156:5409) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:(4480:2082:4156:5409) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(4480:1142:4156:5409) pci, yenta_cardbus, PCI/CARDBUS, RL5c476 II
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_cnd0290ww9-lv_root / ext4 4096 4096 13081819 9397812 8742452 3276800 2870858 2870858
:/dev/sda1 /boot ext4 1024 1024 508745 409082 383482 128016 127785 127785
:/dev/mapper/vg_cnd0290ww9-lv_home /home ext4 4096 4096 45203547 2990351 727311 11321344 11004975 11004975
:

var_log_messages:
:May  1 13:23:58 cnd0290ww9-medpro-com kernel: [16697.345818] rapidsvn[7289]: segfault at 0 ip 0000003f79837703 sp 00007fff55ec84b0 error 4 in libsvn_wc-1.so.0.0.0[3f79800000+8d000]
:May  1 13:23:59 cnd0290ww9-medpro-com abrt[7296]: Saved core dump of pid 7289 (/usr/bin/rapidsvn) to /var/spool/abrt/ccpp-2012-05-01-13:23:58-7289 (15605760 bytes)
:May  1 13:43:23 cnd0290ww9-medpro-com kernel: [17860.539425] rapidsvn[7340]: segfault at 0 ip 0000003f79833120 sp 00007f7c89d59848 error 4 in libsvn_wc-1.so.0.0.0[3f79800000+8d000]
:May  1 13:43:24 cnd0290ww9-medpro-com abrt[7571]: Saved core dump of pid 7335 (/usr/bin/rapidsvn) to /var/spool/abrt/ccpp-2012-05-01-13:43:23-7335 (45555712 bytes)
Comment 1 david.lewis 2012-05-15 11:19:38 EDT
Created attachment 584689 [details]
File: backtrace
Comment 2 david.lewis 2012-05-15 11:19:40 EDT
Created attachment 584690 [details]
File: maps
Comment 3 david.lewis 2012-05-15 11:19:43 EDT
Created attachment 584691 [details]
File: dso_list
Comment 4 david.lewis 2012-05-15 11:19:44 EDT
Created attachment 584692 [details]
File: build_ids
Comment 5 Juan Orti 2012-06-18 12:50:07 EDT
Checking out a repository

backtrace_rating: 4
Package: rapidsvn-0.12.0-4.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 6 Tim Jackson 2012-06-24 08:50:51 EDT
Possibly a duplicate of bug #827102
Comment 7 Jerry LeVan 2012-06-26 14:02:28 EDT
I dpn't seem to be able to 'checkout' a project.
The target directory gets created but rapidsvn
immediately dies with a seg violation  before
any files get moved from the repository.
Comment 8 Tim Jackson 2012-07-03 15:18:31 EDT
Check the latest update 0.12.1 over in bug #827102, I think that will fix it

*** This bug has been marked as a duplicate of bug 827102 ***

Note You need to log in before you can comment on or make changes to this bug.