Bug 827102 - [abrt] rapidsvn-0.12.0-4.fc17: svn_wc_read_kind: Process /usr/bin/rapidsvn was killed by signal 11 (SIGSEGV)
[abrt] rapidsvn-0.12.0-4.fc17: svn_wc_read_kind: Process /usr/bin/rapidsvn wa...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rapidsvn (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Jackson
Fedora Extras Quality Assurance
abrt_hash:93f31983cd0f134b35e851cb34e...
:
: 821856 827189 831517 837887 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 11:36 EDT by cgreenebaum
Modified: 2013-01-18 09:58 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 19:56:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (37.39 KB, text/plain)
2012-05-31 11:36 EDT, cgreenebaum
no flags Details
File: dso_list (11.73 KB, text/plain)
2012-05-31 11:36 EDT, cgreenebaum
no flags Details
File: build_ids (5.29 KB, text/plain)
2012-05-31 11:36 EDT, cgreenebaum
no flags Details
File: core_backtrace (8.87 KB, text/plain)
2012-05-31 11:36 EDT, cgreenebaum
no flags Details
File: backtrace (80.63 KB, text/plain)
2012-05-31 11:36 EDT, cgreenebaum
no flags Details

  None (edit)
Description cgreenebaum 2012-05-31 11:36:44 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        rapidsvn
crash_function: svn_wc_read_kind
executable:     /usr/bin/rapidsvn
kernel:         3.3.7-1.fc17.i686.PAE
pid:            1593
time:           Thu 31 May 2012 11:27:50 AM EDT
uid:            1000
username:       cgreenebaum

backtrace:      Text file, 82562 bytes
build_ids:      Text file, 5412 bytes
core_backtrace: Text file, 9081 bytes
dso_list:       Text file, 12014 bytes
maps:           Text file, 38287 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/cgreenebaum/1

comment:
:Right clicked Bookmarks
:Clicked Add Existing Working Copy
:Selected directory click Open

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=1
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:PATH=/usr/lib/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:XMODIFIERS=@im=none
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:SHLVL=1
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-jZoqRB4i9U,guid=9d53eb436e2c3279a76c61fe00000030
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0
:CCACHE_HASHDIR=
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/987,unix/unix:/tmp/.ICE-unix/987
:GPG_AGENT_INFO=/run/user/cgreenebaum/keyring-zCSL8d/gpg:0:1
:SSH_AUTH_SOCK=/run/user/cgreenebaum/keyring-zCSL8d/ssh
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/fedora-rapidsvn.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=1593

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 16014                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       16014                16014                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/cgreenebaum/.xsession-errors
:pos:	6559
:flags:	02002
:2:/home/cgreenebaum/.xsession-errors
:pos:	6559
:flags:	02002
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:socket:[20028]
:pos:	0
:flags:	02004002
:5:socket:[20549]
:pos:	0
:flags:	02004002
:6:anon_inode:inotify
:pos:	0
:flags:	02004000
:7:socket:[19227]
:pos:	0
:flags:	02004002

var_log_messages:
:May 29 21:43:01 F17-cg-vm yum[3033]: Installed: rapidsvn-0.12.0-4.fc17.i686
:May 30 17:28:03 F17-cg-vm kernel: [22872.078541] rapidsvn[8615]: segfault at 0 ip 4bb7fba4 sp bf945240 error 4 in libsvn_wc-1.so.0.0.0[4bb4a000+94000]
:May 30 17:28:03 F17-cg-vm abrt[8628]: Saved core dump of pid 8615 (/usr/bin/rapidsvn) to /var/spool/abrt/ccpp-2012-05-30-17:28:03-8615 (48410624 bytes)
:May 30 17:28:30 F17-cg-vm kernel: [22899.842130] rapidsvn[8662]: segfault at 0 ip 4bb7fba4 sp bfa59b50 error 4 in libsvn_wc-1.so.0.0.0[4bb4a000+94000]
:May 30 17:28:31 F17-cg-vm abrt[8673]: Saved core dump of pid 8662 (/usr/bin/rapidsvn) to /var/spool/abrt/ccpp-2012-05-30-17:28:30-8662 (39907328 bytes)
:May 30 17:34:46 F17-cg-vm kernel: [23274.863062] rapidsvn[8780]: segfault at 0 ip 4bb7fba4 sp bfff1b50 error 4 in libsvn_wc-1.so.0.0.0[4bb4a000+94000]
:May 30 17:34:46 F17-cg-vm abrt[8796]: Saved core dump of pid 8780 (/usr/bin/rapidsvn) to /var/spool/abrt/ccpp-2012-05-30-17:34:46-8780 (57200640 bytes)
:May 30 17:35:01 F17-cg-vm kernel: [23289.611060] rapidsvn[8824]: segfault at 0 ip 4bb7fba4 sp bfedb850 error 4 in libsvn_wc-1.so.0.0.0[4bb4a000+94000]
:May 30 17:35:01 F17-cg-vm abrt[8836]: Not dumping repeating crash in '/usr/bin/rapidsvn'
:May 30 17:37:08 F17-cg-vm kernel: [23416.968515] rapidsvn[8841]: segfault at 0 ip 4bb7af0c sp b71aee40 error 4 in libsvn_wc-1.so.0.0.0[4bb4a000+94000]
:May 30 17:37:08 F17-cg-vm abrt[8871]: Saved core dump of pid 8837 (/usr/bin/rapidsvn) to /var/spool/abrt/ccpp-2012-05-30-17:37:08-8837 (48640000 bytes)
:May 30 17:52:48 F17-cg-vm kernel: [24355.578261] rapidsvn[9194]: segfault at 0 ip 4bb7af0c sp b7235e40 error 4 in libsvn_wc-1.so.0.0.0[4bb4a000+94000]
:May 30 17:52:48 F17-cg-vm abrt[9200]: Saved core dump of pid 9188 (/usr/bin/rapidsvn) to /var/spool/abrt/ccpp-2012-05-30-17:52:48-9188 (31752192 bytes)
:May 31 11:27:50 F17-cg-vm kernel: [  372.857733] rapidsvn[1593]: segfault at 0 ip 4bb7fba4 sp bfcda3a0 error 4 in libsvn_wc-1.so.0.0.0[4bb4a000+94000]
:May 31 11:27:51 F17-cg-vm abrt[1612]: Saved core dump of pid 1593 (/usr/bin/rapidsvn) to /var/spool/abrt/ccpp-2012-05-31-11:27:50-1593 (48357376 bytes)
Comment 1 cgreenebaum 2012-05-31 11:36:48 EDT
Created attachment 588140 [details]
File: maps
Comment 2 cgreenebaum 2012-05-31 11:36:50 EDT
Created attachment 588141 [details]
File: dso_list
Comment 3 cgreenebaum 2012-05-31 11:36:52 EDT
Created attachment 588142 [details]
File: build_ids
Comment 4 cgreenebaum 2012-05-31 11:36:53 EDT
Created attachment 588143 [details]
File: core_backtrace
Comment 5 cgreenebaum 2012-05-31 11:36:55 EDT
Created attachment 588144 [details]
File: backtrace
Comment 6 Olivier Penhoat 2012-06-05 09:15:26 EDT
Launch rapidsvn and click on a bookmark (working copy)

backtrace_rating: 4
Package: rapidsvn-0.12.0-4.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 7 Olivier Penhoat 2012-06-08 12:44:44 EDT
click on a bookmark, then the application crashes

backtrace_rating: 4
Package: rapidsvn-0.12.0-4.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 Olivier Penhoat 2012-06-10 07:15:22 EDT
Click on any bookmark (working copy or svn repo), then rapidsvn crashes

backtrace_rating: 4
Package: rapidsvn-0.12.0-4.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 9 Dirk 2012-06-13 09:25:40 EDT
Clicking on a bookmark for a working copy.

backtrace_rating: 4
Package: rapidsvn-0.12.0-4.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 10 Adelino Rocha 2012-06-16 20:38:49 EDT
Segmentation fault easily reproducible whan selecting or trying to expand a local repository. Selecting and expanding remote svn repos works fine.

This seems to be related to Fedora 17 only, as I have same RapidSVN version 0.12.0 on a Fedora 16 and it works fine


backtrace_rating: 4
Package: rapidsvn-0.12.0-4.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 11 Tim Jackson 2012-06-24 08:42:09 EDT
I can reproduce this too on local working copies.

At first I thought it might be related to working copies that needed upgrading (svn upgrade), but even after that it still crashes.

I also tried rebuilding RapidSVN but that also didn't help.

Will send upstream.
Comment 13 Adelino Rocha 2012-07-02 04:34:51 EDT
(In reply to comment #12)
> Reported upstream: 
> http://rapidsvn.tigris.org/ds/viewMessage.
> do?dsForumId=671&dsMessageId=2972891

Hi,

  any progress on this issue ?

  response from RapidSVN team seems to indicate this has been fixed in rapidsvn trunk.
Comment 14 Tim Jackson 2012-07-02 06:38:08 EDT
I haven't tried it yet, but RapidSVN 0.12.1 has been released, which is from a newer SVN rev so hopefully contains the fix. Will try it when I have time. See bug #836618.
Comment 15 Adelino Rocha 2012-07-02 11:58:00 EDT
Hi Tim,

     I just compiled new 0.12.1 from source and it works fine.

Thanks a lot for the information and support.
Comment 16 Tim Jackson 2012-07-02 15:06:30 EDT
Yes, I did the same and it seems to be working for me. It's building now in Fedora and I'll push an updated package later: http://koji.fedoraproject.org/koji/taskinfo?taskID=4214201
Comment 17 Fedora Update System 2012-07-02 15:15:45 EDT
rapidsvn-0.12.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/rapidsvn-0.12.1-1.fc17
Comment 18 Fedora Update System 2012-07-03 11:51:08 EDT
Package rapidsvn-0.12.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rapidsvn-0.12.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10204/rapidsvn-0.12.1-1.fc17
then log in and leave karma (feedback).
Comment 19 Tim Jackson 2012-07-03 15:16:20 EDT
*** Bug 831517 has been marked as a duplicate of this bug. ***
Comment 20 Tim Jackson 2012-07-03 15:17:31 EDT
*** Bug 827189 has been marked as a duplicate of this bug. ***
Comment 21 Tim Jackson 2012-07-03 15:18:31 EDT
*** Bug 821856 has been marked as a duplicate of this bug. ***
Comment 22 Alex 2012-07-05 03:11:33 EDT
open rapid svn add existing working copy -> crash

backtrace_rating: 4
Package: rapidsvn-0.12.0-4.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 23 Tim Jackson 2012-07-06 09:47:37 EDT
*** Bug 837887 has been marked as a duplicate of this bug. ***
Comment 24 Fedora Update System 2012-07-11 19:56:42 EDT
rapidsvn-0.12.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 NM 2013-01-18 09:58:09 EST
Can you please push it too FC18 too?

Note You need to log in before you can comment on or make changes to this bug.