Bug 821948 - [BUG] fails to clear console logs
[BUG] fails to clear console logs
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.9.0
: ---
Assigned To: Dan Callaghan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 16:40 EDT by Bill Peck
Modified: 2012-06-26 02:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 02:40:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2012-05-15 16:40:19 EDT
Description of problem:
regression from 0.8 where we cleared console logs before install.

Version-Release number of selected component (if applicable):
0.8.99
Comment 1 Dan Callaghan 2012-05-16 02:29:47 EDT
On Gerrit: http://gerrit.beaker-project.org/1073
Comment 3 Dan Callaghan 2012-06-19 02:11:15 EDT
The clear_logs command we added for this does work, but not always in time. The command might not have run before beaker-watchdog starts monitoring the console log, in which case the old log (before truncation) will be uploaded to Beaker and the new log will never be visible (because after truncation it is shorter than the log already uploaded).

We probably need to make this synchronous. Or else make the watchdog code do the truncation before it starts monitoring the log.
Comment 5 Dan Callaghan 2012-06-21 08:16:14 EDT
Second try posted to Gerrit: http://gerrit.beaker-project.org/1160
Comment 6 Dan Callaghan 2012-06-21 18:29:00 EDT
This bug has been addressed in Beaker 0.9.0-3 which is currently running on stage:

https://beaker-stage.engineering.redhat.com/
Comment 7 Dan Callaghan 2012-06-26 02:40:35 EDT
Beaker 0.9.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.