Bug 82210 - Dia renders UTF-8 text wrong
Dia renders UTF-8 text wrong
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: dia (Show other bugs)
8.0
i586 Linux
medium Severity low
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-19 17:52 EST by Andreas Rogge
Modified: 2007-04-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-12 08:19:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Rogge 2003-01-19 17:52:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i586; U;) Gecko/20020830

Description of problem:
With LANG set to de_DE.UTF-8 dia seems to render all text wrong.
There is a spacing between the characters

With LANG set to de_DE or en_EN it works.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start dia with "LANG=de_DE.UTF-8"
2.create a new worksheet
3.insert a text
    

Actual Results:  The text is rendered with spacings between the letters

Expected Results:  The text should be rendered as it is in non-UTF-8 environment

Additional info:

I think this might be related to Bug #76851 (dia does not find some fonts) or
#75950 (dia's fonts do not display correctly in german localization)
Comment 1 Alexander Larsson 2003-01-21 07:50:36 EST
Yes. Dia is not UTF8 clean yet.
Comment 2 Alexander Larsson 2003-08-12 08:19:10 EDT
This works in dia 0.91, which is in rawhide.

Note You need to log in before you can comment on or make changes to this bug.