Bug 822123 - Graphical grub is unusable slow
Graphical grub is unusable slow
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-05-16 08:10 EDT by Kamil Páral
Modified: 2015-06-12 01:44 EDT (History)
12 users (show)

See Also:
Fixed In Version: anaconda-17.28-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-19 03:12:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console with distorted font (1.09 MB, image/jpeg)
2012-05-16 08:29 EDT, Kamil Páral
no flags Details
console with OK font (1.10 MB, image/jpeg)
2012-05-16 08:29 EDT, Kamil Páral
no flags Details
grub photo (597.78 KB, image/jpeg)
2012-05-17 06:49 EDT, Kamil Páral
no flags Details
grub screenshot from VM (256.59 KB, image/png)
2012-05-17 06:49 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-05-16 08:10:22 EDT
Description of problem:
F17 TC6 introduced a graphical grub. On my TravelMate 4650 it is so slow, that I can't control it at all. Grub responds to key presses with several seconds delay. In 90% of attempts I can't even select a different kernel to boot, because recognizing the first key press takes longer than 5 seconds, which is the default timeout. Therefore I am forced to boot the default item and can't navigate grub at all. Sometimes I am able to cancel that countdown. In that case the delay between key press and action seems to shorten a bit, usually being "only" 1-2 seconds in the end.

The graphical grub is a complete no-go for that computer.

I have 1400x1050 screen and 1.7GHz Pentium M.

Version-Release number of selected component (if applicable):
F17 TC6
http://www.smolts.org/client/show/pub_d327bb93-9807-4253-bc57-04e91a528bff

How reproducible:
always
Comment 1 Kamil Páral 2012-05-16 08:28:29 EDT
I also suspect the graphical grub to distort my font in console (I installed minimal install, so I boot directly to console). See the images. When booting with graphical grub, my font is almost every time squished and hardly readable. When booting with classical grub (comment out GRUB_THEME in /etc/default/grub and regenerate grub.cfg), my font is usually normal and well readable. But it's not 100%, so I can't say it for sure, maybe it's a different bug (but I haven't seen it prior to TC6).

As for the slowness, classical grub works perfect, so the slowness is definitely caused by the graphical theme.
Comment 2 Kamil Páral 2012-05-16 08:29:37 EDT
Created attachment 584952 [details]
console with distorted font

Please note this is not a problem of too large resolution. The display resolution seems to be the same. The font is distorted (squished).
Comment 3 Kamil Páral 2012-05-16 08:29:59 EDT
Created attachment 584953 [details]
console with OK font
Comment 4 Mads Kiilerich 2012-05-16 11:16:20 EDT
Yes, it is slow on slow machines - I have seen it on my old 5 year old Dell Latitude D610 with similar specs. Upstreams theory was that it was caused by missing MTRR capabilities.

Distorted fonts would be a different issue - please file it separately. Please also attach a better photo where the distortion can be seen - both from the boot menu and from the linux console.
Comment 5 Adam Williamson 2012-05-16 13:10:18 EDT
So just to be clear: this happens only with graphical-mode-grub-with-theme, right? It doesn't have with graphical-mode-grub-unthemed, as in TC5?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Mads Kiilerich 2012-05-16 14:23:52 EDT
I think the slowness depends on the complexity of what is shown. Graphical text might be a bit sluggish but usable - full theming seemed to be worse.
Comment 7 Adam Williamson 2012-05-16 14:58:15 EDT
Data:

pjones and bcl are not sure that two reports of a workaroundable problem on two old systems merit ripping out the graphical splash. There is not yet much more data available, nothing in the forums but it seems like no forum users have yet got around to installing TC6/RC1. I have been unable to locate the upstream reports/discussion Mads refers to.

Ubuntu, FWIW, defaults to a non-themed grub2 with a 0 timeout. At least when installed alone, I guess the timeout may be more than 0 if installed alongside Windows. I don't know whether they intentionally chose not to theme grub2 because of this bug, figured it didn't matter because of the 0 timeout default, or just didn't get around to it yet.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Kamil Páral 2012-05-16 15:14:08 EDT
(In reply to comment #5)
> So just to be clear: this happens only with graphical-mode-grub-with-theme,
> right? It doesn't have with graphical-mode-grub-unthemed, as in TC5?
> 

Correct, the new grub in TC6 (background picture, pretty borders, etc) is unusable on that machine. Commenting out GRUB_THEME in /etc/default/grub and regenerating grub.cfg reverts to old plain grub as in TC5 (text only, borders using ASCII art) and that is fully usable.

> pjones and bcl are not sure that two reports of a workaroundable problem on two
> old systems merit ripping out the graphical splash. There is not yet much more
> data available,

Exactly, there is no data available. This is a high risk change, especially when introduced few days before final release. It's completely untested. I installed it on the first computer available and it is broken. What are the odds?

Also I'm not sure why the change happened. I don't remember a NTH request that we would vote on.

I want to stress out - I am unable to control grub on that computer. It is "workaroundable" as long as my system boots fine (I might not even find out until them). But when I have a problem, I can't select an older kernel, I can't edit kernel options, nothing. I would have to boot LiveCD to edit my grub.cfg in that case. So true, workaroundable it is.

I think the new grub needs more tweaking before we introduce it by default. Maybe we will need some blacklists for certain types of machines. I understand we want to have pretty bootloader in F17, but I'm afraid the current solution is only half-finished.
Comment 9 Peter Jones 2012-05-16 15:27:17 EDT
> Also I'm not sure why the change happened. I don't remember a NTH request that
we would vote on.

The NTH request is in https://bugzilla.redhat.com/show_bug.cgi?id=820637 , where it is approved.
Comment 10 Adam Williamson 2012-05-16 15:35:57 EDT
I can see both Peter's and Kamil's points here, honestly, but I think I have to shade to Kamil's side, from a QA perspective. The change was very late and has received very little testing. As soon as it landed - 12 hours later - this problem showed up. That worries me. In all honesty the previous setup - graphical, but unthemed - didn't have a huge amount of testing either, but at least it got more, and it's what Ubuntu uses by default, which is obviously helpful in terms of confidence.

In the end, the prettiness of a themed splash just isn't a big enough reason to keep a possibly problematic change, I think, and the safest thing to do is push a new anaconda which reverts the theme (but keeps the other changes from 17.27). So, voting +1 blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Peter Jones 2012-05-16 15:44:56 EDT
Yeah, since we're seeing this on a couple of machines that /aren't/ old-as-the-hills, it's probably a blocker.  I'm still wondering if anybody can reproduce it on a 64-bit install.
Comment 12 Adam Williamson 2012-05-16 16:47:57 EDT
with +1s from me, pjones, spot and kparal, accepting as blocker. We will get a new anaconda build with the /etc/default/grub line commented out.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Fedora Update System 2012-05-16 16:51:39 EDT
anaconda-17.28-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.28-1.fc17
Comment 14 Adam Williamson 2012-05-16 20:47:56 EDT
For data, a couple more reports from the forums:

"I have had almost the same behaviour: 'responds to key presses with some delay', and a few times (3 or 4) 'no respond to key presses' during the last month (when I manually installed the graphical grub). I'm using F17 x86_64. Laptop Asus K93SV (i7 - 16GB RAM - Optimus intel 3000 + nvidia GT540M). So, not only in old PCs."

and

"I can confirm this error, tested with a tc5 netinstall
my box:
core2quad 2.66 khz
mb: asus P5Qdeluxe
nvidia 240gt

First i try it with vbe 1600x1200x32
with that solution grub is complete unusable, when i switch from default kernel to advanced option entry it takes 4 -5 seconds.
I see that the theme build up again very slow from the top to the button of the screen.
This happen by by every switch to to another entry, same with the finaly start window."

http://forums.fedoraforum.org/showthread.php?t=279709



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Kamil Páral 2012-05-17 06:49:20 EDT
Created attachment 585171 [details]
grub photo

The GRUB background is also very low-quality on that computer. Compare this photo (not high quality, but the real representation is nearly the same, really) and screenshot from VM. The GRUB background on my bare metal is not colorful at all, it's just black and grey, heavily dithered. It might be somehow connected to the slowness issue.

I have NV43 graphics card.
Comment 16 Kamil Páral 2012-05-17 06:49:43 EDT
Created attachment 585172 [details]
grub screenshot from VM
Comment 17 Account closed by user 2012-05-17 15:13:12 EDT
(In reply to comment #11)

> Yeah, since we're seeing this on a couple of machines that /aren't/
> old-as-the-hills, it's probably a blocker.  I'm still wondering if anybody can
> reproduce it on a 64-bit install.

It happens here.

HP Cupertino2 MOBO (H61): Intel Core i3-2120 3.30GHz (Sandy Bridge) + 8GB RAM + SSD OCZ-AGILITY3 + Dell U2410 24" 1920×1200

and also with grub2-2.0-0.26.beta5
Comment 18 Wolfgang Ulbrich 2012-05-17 17:59:07 EDT
Why you don't add
GRUB_BACKGROUND="/boot/grub2/themes/system/background.png"
to /etc/default/grub ?
Correct the font color for having a good contrast and add the fedora logo in the background.

This works pretty good and we have nice displayed grub in fedora 17 release.
Comment 19 Mads Kiilerich 2012-05-17 18:50:17 EDT
(In reply to comment #18)

What evidence do you have that it will be any better? Have you seen the slow theme? How responsive is it with just the background compared to the theme?
Comment 20 Fedora Update System 2012-05-17 18:55:58 EDT
Package anaconda-17.28-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.28-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7970/anaconda-17.28-1.fc17
then log in and leave karma (feedback).
Comment 21 Account closed by user 2012-05-17 18:59:53 EDT
(In reply to comment #19)

> (In reply to comment #18)
> 
> What evidence do you have that it will be any better? Have you seen the slow
> theme? How responsive is it with just the background compared to the theme?

BACKGROUND is as fast as no_BACKGROUND, THEME is slooooow.
Comment 22 satellitgo 2012-05-17 20:38:24 EDT
Fedora-17.TC6-x86_64-Live-LXDE.iso as dd USB boots nicely to graphical boot after install to USB HD then goes to Firstboot (which fits the 10" screen of the Acer Aspire ONE n450)-logs in normally -shuts down quickly. bottom line of commands run off screen to right and are not all visible
Comment 23 Wolfgang Ulbrich 2012-05-17 20:43:15 EDT
exactly, the slowness is caused by the theme
without the theme and only with a background the issue don't exits.
It's tested...

and yes i see the slow theme, this is my comment

"I can confirm this error, tested with a tc5 netinstall
my box:
core2quad 2.66 khz
mb: asus P5Qdeluxe
nvidia 240gt

First i try it with vbe 1600x1200x32
with that solution grub is complete unusable, when i switch from default kernel
to advanced option entry it takes 4 -5 seconds.
I see that the theme build up again very slow from the top to the button of the
screen.
This happen by every switch to to another entry, same with the finaly start
window."


... and don't think my box is slow

2 ssd3 disk with raid0 at a hardware raid
Comment 24 Tim Flink 2012-05-18 17:18:24 EDT
Discussed in the 2012-05-18 blocker bug review meeting. anaconda-17.28-1 was included in the Fedora 17 final RC2 build and this needs testing to determine whether or not this bug can be closed.
Comment 25 Fedora Update System 2012-05-19 03:12:00 EDT
anaconda-17.28-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Kamil Páral 2012-05-21 09:46:11 EDT
This is fixed with F17 RC2, grub is not themed.
Comment 27 seb93250 2015-06-12 01:44:58 EDT
I have the same problem with grub2 2.02~beta2 on Fedora 21.
Whatever resolution, it's very slow...

Note You need to log in before you can comment on or make changes to this bug.