Bug 822232 - virt-manager not displaying properly some dialogs on non-gnome window managers
virt-manager not displaying properly some dialogs on non-gnome window managers
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.3
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: virt-mgr-maint
Virtualization Bugs
:
Depends On: 749928
Blocks: 782183 840699
  Show dependency treegraph
 
Reported: 2012-05-16 13:56 EDT by Raul Cheleguini
Modified: 2014-02-24 18:48 EST (History)
27 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 749928
Environment:
Last Closed: 2012-07-24 14:10:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raul Cheleguini 2012-05-16 13:56:41 EDT
+++ This bug was initially created as a clone of Bug #749928 +++

Created attachment 530747 [details]
virt-manager.log

Description of problem:
In virt-manager an ISO-file can be connected to IDE CDROM 1 with a Connect button. But this button is doing nothing.

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-6.fc16.noarch

How reproducible:
Always

Steps to Reproduce:
1. Open a VM (Open button)
2. Go to Details (Show Virtual Hardware Details)
3. Go to IDE CDROM 1
4. Press Connect button (In F15 a dialog box opens, in F16 this fails)

  
Actual results:
Nothing happens


Expected results:
A dialog box opens where I can select an ISO-file.

Additional info:
I've looked in .xsession-errors, virt-manager.log. Nothing is in there :-(. For your reference I'll attach virt-manager.log



Plausible comments from the original bug:

--- Additional comment from crobinso@redhat.com on 2012-01-24 19:22:49 EST ---

*** Bug 755372 has been marked as a duplicate of this bug. ***

--- Additional comment from crobinso@redhat.com on 2012-01-24 22:36:10 EST ---

Scott, don't worry about it, I reproduced the issue in a KDE vm before it crashed  :)  so I'm pretty sure it's KDE (or at least non-gnome-shell) specific.

I'll investigate tomorrow what I can do to fix this in virt-manager.

--- Additional comment from crobinso@redhat.com on 2012-01-25 10:45:35 EST ---

Fixed upstream now:

http://git.fedorahosted.org/git?p=virt-manager.git;a=commit;h=5efe079158b7b6e1fb9e8fcc00af8b27a08dbde3

If any one wants to do the fix by hand, edit /usr/share/virt-manager/virtManager/choosecd.py and change the only occurence of topwin.show() to topwin.present()
The dialog will flicker once, but click the 'choose' button again and it will show up from then on.

--- Additional comment from lists.kho@gmail.com on 2012-01-25 11:03:01 EST ---

Hi Cole,

The fix works :-)

Great and Thanks,

Martin Kho

You can close this report?

--- Additional comment from crobinso@redhat.com on 2012-01-25 11:39:42 EST ---

Not yet, I haven't pushed the fix to fedora yet. When that happens I'll close the bug.

--- Additional comment from crobinso@redhat.com on 2012-01-25 18:33:40 EST ---

*** Bug 700560 has been marked as a duplicate of this bug. ***

--- Additional comment from updates@fedoraproject.org on 2012-02-01 12:06:01 EST ---

virt-manager-0.9.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/virt-manager-0.9.1-1.fc16

--- Additional comment from updates@fedoraproject.org on 2012-02-02 12:30:47 EST ---

Package virt-manager-0.9.1-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.9.1-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1206/virt-manager-0.9.1-1.fc16
then log in and leave karma (feedback).

--- Additional comment from crobinso@redhat.com on 2012-02-05 14:29:41 EST ---

*** Bug 787497 has been marked as a duplicate of this bug. ***

--- Additional comment from updates@fedoraproject.org on 2012-02-05 16:50:44 EST ---

virt-manager-0.9.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 2 Raul Cheleguini 2012-05-16 14:08:42 EDT
Hello,

I cloned this BZ because this issue is reproducible on the Red Hat Enterprise Linux 6.3 Beta.

Package version:

virt-manager-0.9.0-11.el6.x86_64.rpm

Reproducible steps:

The steps described on the original bug are applicable, but you can also experience problems when you try to create a new volume during the VM creation:

1. Open virt-manager
2. Click "new"
3. Give it a name, set PXE as the boot source
4. OS: linux, variety: 5.6 or later
5. defaults for RAM and CPUs
6. "Select managed or other existing storage" radio button
7. Click "browse"
8. Select an LVM volume group storage pool created previously
9. Click "new volume"

The changes proposed by Cole Robinson fix the problems with dialogs/top level windows:

--- Additional comment from crobinso@redhat.com on 2012-01-25 10:45:35 EST ---

Fixed upstream now:

http://git.fedorahosted.org/git?p=virt-manager.git;a=commit;h=5efe079158b7b6e1fb9e8fcc00af8b27a08dbde3

If any one wants to do the fix by hand, edit
/usr/share/virt-manager/virtManager/choosecd.py and change the only occurence
of topwin.show() to topwin.present()
The dialog will flicker once, but click the 'choose' button again and it will
show up from then on.
Comment 4 Scott Dowdle 2012-06-21 12:52:42 EDT
I noticed this yesterday after upgrading to RHEL 6.3 with virt-manager-0.9.0-14.el6.x86_64... when I try to add an .iso to an existing CD device it won't open up a dialog.  The work around is to delete the CD device and make a new one and while doing so, associate an .iso to it.
Comment 5 RHEL Product and Program Management 2012-07-10 04:43:38 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 21:57:09 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Note You need to log in before you can comment on or make changes to this bug.