Bug 82229 - non existent label mounts even with the 'noauto' option cause boot time drop to emergency shell
non existent label mounts even with the 'noauto' option cause boot time drop ...
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
Reported: 2003-01-19 23:50 EST by Matthew Galgoci
Modified: 2014-03-16 22:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-29 16:34:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matthew Galgoci 2003-01-19 23:50:47 EST
Description of problem:

I have a removable disk drive that I want to mount using a filesystem label.

The drive contains an ext3 filesystem labeled as /mnt/shemp

/mnt/shemp exists

I also have the following entry in /etc/fstab:

LABEL=/mnt/shemp   /mnt/shemp              ext3    noauto        1 1

Upon rebooting without /mnt/shep available in the system, I am dropped to 
a filesystem repair shell (of course first prompting for the root password).

Version-Release number of selected component (if applicable):


How reproducible:

Every time.

Steps to Reproduce:
1. Add a non-existent label mount to /etc/fstab with the noauto option
2. reboot
3. watch it prompt you for your root password and to fix your filesystem
Actual results:

You are prompted to fix the filesystem

Expected results:

The non-existent label with the noauto option should simply be ignored since 
you are not going to mount the filesystem automagically anyhow.
Comment 1 Bill Nottingham 2003-01-20 15:40:15 EST
Did this happen previously?
Comment 2 Matthew Galgoci 2003-01-20 16:07:03 EST
I could have sworn it worked before, but I just tried on an advanced server
2.1 with all current updates and it indeed failed.

However, on a hunch I changed the fs_freq and fs_passno fields both to 0 and 
the system booted without complaint. Weird.

Is it semantically correct behaviour? 

I will test the beta4 box again tonight when I get home to ensure that the same
behaviour holds.
Comment 3 Bill Nottingham 2005-09-29 16:34:56 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.