This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 822314 - /bin/vi is missing
/bin/vi is missing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
: 825814 832347 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 23:37 EDT by James Szinger
Modified: 2012-06-15 19:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 19:49:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Szinger 2012-05-16 23:37:40 EDT
Description of problem:
The most recent update removed /bin/vi

Version-Release number of selected component (if applicable):
2:vim-minimal-7.3.515-1.fc16.x86_64


How reproducible:
Always

Steps to Reproduce:
1. try to execute /bin/vi
2.
3.
  
Actual results:
command not found

Expected results:
vi compatible editor

Additional info:

$ repoquery --provides 2:vim-minimal-7.3.515-1.fc16.x86_64
/bin/vi
config(vim-minimal) = 2:7.3.515-1.fc16
vi = 7.3.515-1.fc16
vim-minimal = 2:7.3.515-1.fc16
vim-minimal(x86-64) = 2:7.3.515-1.fc16

$ repoquery -l 2:vim-minimal-7.3.515-1.fc16.x86_64
/etc/virc
/usr/bin/ex
/usr/bin/rvi
/usr/bin/rview
/usr/bin/vi
/usr/bin/view

Note the difference between the provides and the file list.

The vim-minimal that shipped with F16 has /bin/vi:
$ repoquery -l 2:vim-minimal-7.3.315-1.fc16.x86_64
/bin/ex
/bin/rvi
/bin/rview
/bin/vi
/bin/view
/etc/virc
Comment 1 Paul Sand 2012-05-22 13:36:14 EDT
This breaks (at least) "crontab -e", which expects /bin/vi to be there if you don't have the EDITOR environment variable set.
Comment 2 Fedora Update System 2012-05-23 05:49:21 EDT
vim-7.3.515-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/vim-7.3.515-2.fc16
Comment 3 Fedora Update System 2012-05-24 19:57:42 EDT
Package vim-7.3.515-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing vim-7.3.515-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8354/vim-7.3.515-2.fc16
then log in and leave karma (feedback).
Comment 4 Karsten Hopp 2012-05-29 04:47:25 EDT
*** Bug 825814 has been marked as a duplicate of this bug. ***
Comment 5 Marcela Mašláňová 2012-06-15 07:43:41 EDT
*** Bug 832347 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2012-06-15 19:49:39 EDT
vim-7.3.515-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.