Bug 825814 - vi moved from /bin to /usr/bin
vi moved from /bin to /usr/bin
Status: CLOSED DUPLICATE of bug 822314
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-05-28 10:23 EDT by Nadav Har'El
Modified: 2012-05-29 04:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-05-29 04:47:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nadav Har'El 2012-05-28 10:23:47 EDT
Apparently in the latest update to Fedora 17, the vim-minimal package vim-minimal-7.3.515-1.fc16.x86_64 now contains the file "/usr/bin/vi" instead of "/bin/vi" which it always used to contain.

Generally, I wouldn't have considered this a bug, and Fedora 18 is planned (or at least, was planned originally) to move everything to /usr/bin, but I don't understand why doing this was important for a last moment (one day before the release of Fedora 18) update to Fedora 17. It bothered me on a long-running system, where a certain program looked for "vi" in the path in the beginning, and then ran the same thing later - and after the update suddenly vi moved and confused it :-) It's not a big problem, but I also don't see the benefit of changing something like this in an update...

Another annoying fact is this output:

$ yum whatprovides /bin/vi
2:vim-minimal-7.3.515-1.fc16.x86_64 : A minimal version of the VIM editor
Repo        : @updates
Matched from:
Filename    : /bin/vi

Clearly, this is not true - this package does *not* contain /bin/vi:

$  rpm -q vim-minimal 
$  rpm -ql vim-minimal

So something is broken in some metadata somewhere?
Comment 1 Nadav Har'El 2012-05-28 10:26:13 EDT
Sorry - I'm not a time-traveller, I just confused the numbers. Obviously the current release is Fedora 16, and the next is Fedora 17 - and not the numbers I wrote above ;-) But the rest of the details are correct.
Comment 2 Karsten Hopp 2012-05-29 04:47:25 EDT
A fixed package vim-7.3.515-2.fc16 is already in f16-testing, please test and give karma at https://admin.fedoraproject.org/updates/FEDORA-2012-8354/vim-7.3.515-2.fc16

*** This bug has been marked as a duplicate of bug 822314 ***

Note You need to log in before you can comment on or make changes to this bug.