This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 822804 - Weird status: CLOSED/ERRATA of [...]
Weird status: CLOSED/ERRATA of [...]
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
4.2
Unspecified Unspecified
low Severity low (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
: Reopened
: 652294 875020 882165 (view as bug list)
Depends On: 913098
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 04:41 EDT by Petr Šplíchal
Modified: 2016-05-31 21:43 EDT (History)
6 users (show)

See Also:
Fixed In Version: 4.4-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 07:04:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screengrab (605.18 KB, image/png)
2012-05-18 07:56 EDT, Simon Green
no flags Details
Screenshot of the status area (13.28 KB, image/png)
2012-05-21 02:35 EDT, Petr Šplíchal
no flags Details

  None (edit)
Description Petr Šplíchal 2012-05-18 04:41:13 EDT
Description of problem:

The "Mark as duplicate" field is displayed even when the status is
CLOSED/ERRATA, furthermore hitting it does not have any effect.

Version-Release number of selected component (if applicable):
3.6, 4.2

Steps to Reproduce:
https://partner-bugzilla.redhat.com/show_bug.cgi?id=227655
  
Actual results:
Status: CLOSED [ERRATA] of <empty input field>
Mark as duplicate

Expected results:
Status: CLOSED [ERRATA]
Comment 1 Simon Green 2012-05-18 07:56:04 EDT
Created attachment 585393 [details]
screengrab
Comment 2 Simon Green 2012-05-18 07:57:43 EDT
Seems fine to me, as per the attached screenshot. If you have javascript disabled, the section below the comment box will allow you to enter a duplicate bug number, but that is expected.
Comment 3 Petr Šplíchal 2012-05-21 02:35:21 EDT
Created attachment 585740 [details]
Screenshot of the status area

That's strange, here's what I get when viewing that bug. I'm even
not able to update the status as it's just a plan text. I double
checked that I'm logged in.
Comment 4 Simon Green 2012-10-09 03:23:12 EDT
*** Bug 652294 has been marked as a duplicate of this bug. ***
Comment 5 Paolo Bonzini 2012-10-16 11:04:36 EDT
Yet another bug looking like this: bug 827163
Comment 7 Simon Green 2012-11-14 06:00:49 EST
*** Bug 875020 has been marked as a duplicate of this bug. ***
Comment 10 Simon Green 2012-12-16 22:00:53 EST
*** Bug 882165 has been marked as a duplicate of this bug. ***
Comment 11 Chen Chen 2013-02-17 03:50:58 EST
Verify version 4.4 on qe server --> FAIL

Verify steps:
1.Log in bugzilla with a public account.
2.Create a bug which product contained 'bugzilla'.
3.Change the bug status to CLOSED/ERRATA.
4.Chick Status of this bug at the bottom of the page.
  
Actual results:
Status: CLOSED [ERRATA]
Mark as duplicate

Expected results:
Status: CLOSED [ERRATA]
Comment 15 Chen Chen 2013-02-20 06:35:37 EST
simon: 

- Please ignore the comments 12 and 14. 

- I added a new bug 913098 to deal with the issue in comment 12.

- and I updated the Verify result:

Verify version 4.4-1 on test server --> Depend on bug 913098

Verify steps:
1.1. Login bugzilla with public@redhat.com.					                                --pass
1.2. Create a rhel6 bug, update the bug, and set bug status closed [errata]					--blocked by a new bug 913098
1.3. Refresh the bug page, check the status field under the page.						--not test
1.4. Update the bug's status and resolutions.									--not test
2.1. Login bugzilla with redhat@redhat.com. 									--pass
2.2. Create a rhel6 bug, set public@redhat.com as assignee.							--pass
2.3. Login bugzilla with public@redhat.com, then update the bug's status to closed [errata].			--blocked by a new bug 913098
2.4. Refresh the bug page, check the status field under the page.						--not test
2.5. Update the bug's status and resolutions.									--not test
3.1. Login bugzilla with redhat@redhat.com.									--pass
3.2. Create a rhel6 bug, set public@redhat.com as qa contact. 							--pass
3.3. Login bugzilla with public@redhat.com, then update the bug's status to closed [errata]. 			--pass
3.4. Refresh the bug page, check the status field under the page. 						--pass
3.5. Update the bug's status and resolutions.									--pass
4.1. Login bugzilla with public@redhat.com.									--pass
4.2. Search a rhel6 bug that public@redhat.com is not the reporter, assignee and qa contact of this bug.	--pass
4.3. Update the bug's status to closed [errata].								--pass
5.1. Login bugzilla with redhat@redhat.com.									--pass
5.2. Search a rhel6 bug and set the bug's status to closed [errata].						--pass
5.3. Refresh the bug page, check the status field under the page.						--pass
5.4. Update the bug's status and resolutions.									--pass
6.1. Login bugzilla with admin@redhat.com.									--pass
6.2. Search a rhel6 bug and set the bug's status to closed [errata].						--pass
6.3. Refresh the bug page, check the status field under the page.						--pass
6.4. Update the bug's status and resolutions.									--pass
  
Actual results:
see above.

Expected results:
1. After step 1.3, Status is only CLOSED [ERRATA] and there is no 'Mark as duplicate' and no 'of <empty input field>'
2. After step 1.4, bug status and resolution can not be changed.
3. After step 2.4, Status is only CLOSED [ERRATA] and there is no 'Mark as duplicate' and no 'of <empty input field>'
4. After step 2.5, bug status and resolution can not be changed.
5. After step 3.4, Status is only CLOSED [ERRATA] and there is no 'Mark as duplicate' and no 'of <empty input field>'
6. After step 3.5, bug status and resolution can not be changed.
7. After step 4.3, bug status can not be changed.
8. After step 5.3, Status is only CLOSED [ERRATA] and there is no 'Mark as duplicate' and no 'of <empty input field>'
9. After step 5.4, bug status and resolution can not be changed.
10. After step 6.3, Status is only CLOSED [ERRATA] and there is 'Mark as duplicate' link.
11. After step 6.4, admin account can update the bug's status and resolution.

Note You need to log in before you can comment on or make changes to this bug.