Bug 882165 - need to enhance the restrictions for reopening a 'CLOSED/ERRATA' bug of RHEL product
Summary: need to enhance the restrictions for reopening a 'CLOSED/ERRATA' bug of RHEL ...
Keywords:
Status: CLOSED DUPLICATE of bug 822804
Alias: None
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs
Version: 4.2
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ---
Assignee: Simon Green
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-30 10:16 UTC by wangjing
Modified: 2014-10-12 22:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-17 03:00:53 UTC


Attachments (Terms of Use)

Description wangjing 2012-11-30 10:16:57 UTC
Description of problem:
a redhat account(not admin) can reopen a 'CLOSED/ERRATA' bug of RHEL product by changing the resolution from 'ERRATA' to others.

Version-Release number of selected component (if applicable):
version 4.2.4-7.b01 qe test env

How reproducible:
always

Steps to Reproduce:
1.create a  bug for RHEL, and set status to 'CLOSED/ERRATA'.
2.login with a user who is not in 'admin' group but in red hat internal group.
3.open the bug(step1) and try to change its status to 'ASSIGNED'.
4.change the resolution from 'ERRATA' to 'NOTABUG'.
5.try to change its status to 'ASSIGNED'.
  
Actual results:
after step3:A redhat user who is not in 'admin' group can not reopen a 'CLOSED/ERRATA' bug of product RHEL.
after step5:the bug was reopened in the end.

Expected results:
after step4:the resolution cannot be changed also.
A redhat user who is not in 'admin' group can not reopen a 'CLOSED/ERRATA' bug of product RHEL.

Additional info:
bug 406141 was 'closed NEXTRELEASE' in 2008, on current version the feature just affect RHEL product, not RHEL Beta, RHEL Public Beta, it's different from the 'Description' of bug 406141, so add another bug for this.

Comment 1 Simon Green 2012-12-17 03:00:53 UTC

*** This bug has been marked as a duplicate of bug 822804 ***


Note You need to log in before you can comment on or make changes to this bug.