Bug 822848 - rhev-h ethernet nic losts its configuration after rhev-h upgrade
rhev-h ethernet nic losts its configuration after rhev-h upgrade
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: Regression, TestBlocker
: 823737 826956 (view as bug list)
Depends On:
Blocks: 822925
  Show dependency treegraph
 
Reported: 2012-05-18 06:28 EDT by yuanquan chen
Modified: 2016-04-26 10:31 EDT (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-11.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 10:13:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ovirt.log , message and network-scripts (69.83 KB, application/x-gzip)
2012-05-22 04:10 EDT, yuanquan chen
no flags Details
ovirt.log (18.13 KB, text/plain)
2012-05-29 22:59 EDT, Guohua Ouyang
no flags Details
71-biosdevname.rules (958 bytes, text/plain)
2012-05-31 03:44 EDT, Harald Hoyer
no flags Details

  None (edit)
Description yuanquan chen 2012-05-18 06:28:25 EDT
Description of problem:
The rhev-h node will lost network configuration after upgrade due to the
new integrated biosdevname.

Usually, the udev recognizes the ethernet nic as ethX, but the
biosdevname will recognize it as emX, p0pX, then the original network
configuration, such as ip, up/down status, won't be effective. 



Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120516.0.el6

How reproducible:
100%

Steps to Reproduce:
1. install an old(older than rhev-hypervisor6-6.3-20120516.0.el6) rhev-h
to the machine
2. boot the installed rhev-h and configure the network, register to
rhev-m and so on
3. upgrade the rhev-h to latest version
rhev-hypervisor6-6.3-20120516.0.el6 via TUI or cmdline
4. boot the upgraded rhev-h, check the network

  
Actual results:
The ethernet nic will be recognize as em1, p0pX and so on, and the nic
is down. The connection between rhev-h and rhev-m will be lost.

Expected results:
The ethernet nic should be up, the rhevm bridge ip  the connection
between rhev-h and rhev-m remain after upgrade 

Additional info:
Comment 3 Mike Burns 2012-05-18 07:43:42 EDT
This is due to biosdevname fix.  We need to handle this during upgrade.  

Options:

1.  somehow block biosdevname from being used on upgraded machines
2.  migrate data during upgrade


Note for option 2:  This is probably the *right* solution, but we have to be careful that we can fall back to the old scripts if upgrade fails for some reason.
Comment 7 yuanquan chen 2012-05-22 04:10:18 EDT
Created attachment 585958 [details]
ovirt.log , message and network-scripts
Comment 9 Douglas Schilling Landgraf 2012-05-22 18:11:03 EDT
*** Bug 823737 has been marked as a duplicate of this bug. ***
Comment 13 yuanquan chen 2012-05-28 06:24:44 EDT
For upgrade of snap3 -> snap5 or any 6.2  version -> snap5, it successes with some machines, such as Dell R510 and Dell optiplex 990, while it also fails with HP 8200E MT and intel-5550-12-2 in lab. The nics of the successful machines are renamed as emX or pXpY, while the nics of the failed machines are still named as ethX.
Comment 15 Guohua Ouyang 2012-05-29 01:50:02 EDT
I also reproduced the bug on my lenovo machine, upgrade from 6.2 GA build (6.2-20111117) to 6.3-20120523.1 in rhevm:
1. after upgrade and reboot, network is not connected and report failed to establish libvirt connection.  check the /etc/sysconfig/networking-scripts/, can see both ifcfg-em1, ifcfg-eth0  etc.

ls ifcfg-*
ifcfg-em1   ifcfg-eth1  ifcfg-lo    ifcfg-p3p1
ifcfg-eth0  ifcfg-eth2  ifcfg-p2p1  ifcfg-rhevm

2. reboot one more time, check the /etc/sysconfig/networking-scripts/, cannot see ifcfg-ethX now, 

$ls /etc/sysconfig/network-scripts/ifcfg-*
/etc/sysconfig/network-scripts/ifcfg-em1
/etc/sysconfig/network-scripts/ifcfg-lo
/etc/sysconfig/network-scripts/ifcfg-p2p1
/etc/sysconfig/network-scripts/ifcfg-p3p1
/etc/sysconfig/network-scripts/ifcfg-rhevm

$ls /sys/class/net/
bond0    bond1    bond2    bond3    bond4    bonding_masters
eth0    eth1    eth2    lo    rhevm

under /sys/class/net,  can see ethX, but cannot see emX, so the renamed device is not existed, that should be the reason the network cannot up.

3.service network restart  
will get error Device em1 does not seem to be present.


Actually do local clean install, the network device did not rename to emX, don't know why upgrade will rename the device name and which cause the network failed up.
Comment 20 Guohua Ouyang 2012-05-29 22:59:28 EDT
Created attachment 587582 [details]
ovirt.log

(In reply to comment #16)
> The console keeps hanging on this machine for me, can you save
> /var/log/ovirt.log to a flash drive for me and attach to the bz or some
> other method. Also output of biosdevname would be helpful.
> 
> If you need to get the network up on the machine you can. rm -rf
> /config/etc/sysconfig/network-scripts, reboot, setup the network again, just
> make sure to save /var/log/ovirt.log and all the
> /etc/sysconfig/network-scripts to /config by copying rather than persisting.

Attach ovirt.log and biosdevname output:

$biosdevname -i eth0
em1
$biosdevname -i eth1
p2p1
$biosdevname -i eth2
p3p1
Comment 24 Harald Hoyer 2012-05-31 03:44:52 EDT
Created attachment 587964 [details]
71-biosdevname.rules

standard biosdevname rules file without smbios version restrictions
Comment 25 Mike Burns 2012-05-31 15:22:30 EDT
*** Bug 826956 has been marked as a duplicate of this bug. ***
Comment 32 errata-xmlrpc 2012-07-19 10:13:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.