Bug 823019 - Mouse clicks are not synchronized with cursor when display is scaled up
Mouse clicks are not synchronized with cursor when display is scaled up
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-vdagent-win (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Arnon Gilboa
Desktop QE
: ZStream
: 834999 (view as bug list)
Depends On:
Blocks: 835194
  Show dependency treegraph
 
Reported: 2012-05-18 15:25 EDT by Marc-Andre Lureau
Modified: 2015-09-22 09 EDT (History)
10 users (show)

See Also:
Fixed In Version: vdagent-win-0.1-11
Doc Type: Bug Fix
Doc Text:
spice-gtk relies on agent best resolution match when resizing the display.There is a mouse offset when there is no exact match between the client display and the guest resolution. An update has been made to ensure that the vdagent starts correctly and these problems will no longer occur. As a result the guest's mouse will now respond correctly to user input.
Story Points: ---
Clone Of:
: 835194 (view as bug list)
Environment:
Last Closed: 2012-12-04 13:17:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc-Andre Lureau 2012-05-18 15:25:34 EDT
Description of problem:

spice-gtk rely on agent best resolution match when resizing the display.

There is a mouse offset when there is no exact match between the client display and the guest resolution

Version-Release number of selected component (if applicable):
vdagent from git, and previous releases (probably current supported rhev release too), unfortunately, the tags seems to be missing in upstream repo.

How reproducible:
100%

Steps to Reproduce:
1. run spicy with "Resize guest to best match"
2. resize client to a non-exact match (for example, 1400x480)
3. move cursor to bottom-right corner

  
Actual results:
observe the mouse is off (depending on ratio client/guest)

Expected results:
Guest mouse should be under client pointer.
Comment 1 Christophe Fergeau 2012-06-25 04:36:18 EDT
This is fixed by http://cgit.freedesktop.org/spice/win32/vd_agent/commit/?id=b4e9afc721882ae14fe9e720a3cd113701cf9f8e if I'm not mistaken
Comment 4 Marc-Andre Lureau 2012-07-02 10:04:39 EDT
*** Bug 834999 has been marked as a duplicate of this bug. ***
Comment 9 errata-xmlrpc 2012-12-04 13:17:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1502.html

Note You need to log in before you can comment on or make changes to this bug.