Bug 834999 - maximize screen from viewer, results in mouse pointer out of sync
maximize screen from viewer, results in mouse pointer out of sync
Status: CLOSED DUPLICATE of bug 823019
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
x86_64 Windows
unspecified Severity urgent
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 04:22 EDT by Grant Williamson
Modified: 2012-07-02 10:04 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-02 10:04:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spice gtk debug log. (109.93 KB, text/plain)
2012-06-25 04:22 EDT, Grant Williamson
no flags Details

  None (edit)
Description Grant Williamson 2012-06-25 04:22:00 EDT
Created attachment 594126 [details]
Spice gtk debug log.

Description of problem:
Running RHEL 6.3.
Start a Windows 7 guest session using virt-viewer or remote-viewer.
Click on Maximize Windows.
Mouse pointer becomes out of sync i.e. where you click is on in sync with the screen. 

Version-Release number of selected component (if applicable):
spice-gtk-0.11-11.el6
Comment 1 Grant Williamson 2012-06-25 04:24:33 EDT
Sorry bug not clear.

Start Windows 7 Guest
Open Screen Resolution inside the Windows 7 Guest KVM.
Click on a windows close X - works.
Click on remote-viewer maximize screen.
Open Screen Resolution inside the Windows 7 Guest KVM.
Click on the windows close X - Cannot select. 
Displace mouse 1cm south east and it can be selected and closed.
Comment 3 Grant Williamson 2012-06-25 04:34:45 EDT
vdagent is running inside the Windows 7 Guest.
Comment 4 Grant Williamson 2012-06-25 04:36:45 EDT
Stop the agent and maximize works without an issue, although screen is not auto resizd.
Comment 5 Christophe Fergeau 2012-06-25 05:14:37 EDT
Looks similar to https://bugzilla.redhat.com/show_bug.cgi?id=823019
Comment 6 Grant Williamson 2012-06-25 08:34:52 EDT
Tested
http://elmarco.fedorapeople.org/vdagent.exe
http://elmarco.fedorapeople.org/vdservice.exe

This seems to resolve the issue.
Comment 7 Marc-Andre Lureau 2012-07-02 10:04:39 EDT
thanks for checking the new agent, we are handling the release of windows vdagent in RHEV in bug 823019.

*** This bug has been marked as a duplicate of bug 823019 ***

Note You need to log in before you can comment on or make changes to this bug.