Bug 823178 - xpdf : pdfdetach Conflicts with poppler-utils
xpdf : pdfdetach Conflicts with poppler-utils
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xpdf (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
: 823179 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-19 14:33 EDT by Michael Schwendt
Modified: 2012-11-28 06:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 06:37:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2012-05-19 14:33:48 EDT
=> xpdf-3.03-2.fc17.src.rpm
=> 1:xpdf-3.03-2.fc17.i686 in fedora-development-i386
  File conflict with: poppler-utils-0.20.0-1.fc18.i686
     /usr/bin/pdfdetach
     /usr/share/man/man1/pdfdetach.1.gz

[semi-automated bug report]
Comment 1 Rex Dieter 2012-05-19 15:09:54 EDT
Seems how this has been handled in the past was to allow poppler-utils to own anything that conflicts, would doing the same in this case be acceptable?
Comment 2 Michael Schwendt 2012-05-19 15:21:11 EDT
That would be very difficult to accomplish, because poppler-utils would need to build a pdfdetach executable whose file checksum matches xpdf's. And once exactly the same file (not directory entry) were included in two separate packages, this would ask for a shared subpackage.

https://fedoraproject.org/wiki/Packaging:Conflicts#Implicit_Conflicts
Comment 3 Rex Dieter 2012-05-19 15:30:09 EDT
By "allow poppler-utils to own", I didn't mean to share it, I meant to explicitly exclude/delete it from xpdf packaging.
Comment 4 Fedora Update System 2012-05-25 15:17:45 EDT
xpdf-3.03-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xpdf-3.03-3.fc17
Comment 5 Rex Dieter 2012-05-25 15:21:44 EDT
*** Bug 823179 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2012-05-26 04:06:24 EDT
Package xpdf-3.03-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xpdf-3.03-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8394/xpdf-3.03-3.fc17
then log in and leave karma (feedback).
Comment 7 Tom "spot" Callaway 2012-05-30 06:37:50 EDT
I withdrew this f17 update because someone noted (correctly) that the conflicting poppler with pdfdetach is poppler 0.20 which is only in rawhide. There is a fixed package already in rawhide, so I'm closing this out.
Comment 8 Fedora Update System 2012-11-14 16:25:01 EST
xpdf-3.03-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xpdf-3.03-5.fc17
Comment 9 Fedora Update System 2012-11-14 16:25:18 EST
xpdf-3.03-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xpdf-3.03-5.fc18
Comment 10 Fedora Update System 2012-11-14 16:25:34 EST
xpdf-3.03-1.fc16.1 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xpdf-3.03-1.fc16.1
Comment 11 Fedora Update System 2012-11-23 03:06:06 EST
xpdf-3.03-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-11-28 06:26:56 EST
xpdf-3.03-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2012-11-28 06:39:11 EST
xpdf-3.03-1.fc16.1 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.