Bug 823315 - [abrt] yumex-3.0.5-2.fc17: backend-launcher.py:36:dispatcher:AttributeError: 'exceptions.IOError' object has no attribute 'err'
[abrt] yumex-3.0.5-2.fc17: backend-launcher.py:36:dispatcher:AttributeError: ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
abrt_hash:61ed407c56c5df2a0ff790155ff...
: Reopened
: 1000667 1009322 1013354 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-20 16:50 EDT by Raphos
Modified: 2013-10-12 00:38 EDT (History)
19 users (show)

See Also:
Fixed In Version: yumex-3.0.12-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 22:02:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphos 2012-05-20 16:50:39 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python -E /usr/share/yumex/backend-launcher.py
executable:     /usr/share/yumex/backend-launcher.py
kernel:         3.3.6-3.fc17.x86_64
time:           dim. 20 mai 2012 22:45:30 CEST
uid:            0
username:       root

backtrace:
:backend-launcher.py:36:dispatcher:AttributeError: 'exceptions.IOError' object has no attribute 'err'
:
:Traceback (most recent call last):
:  File "/usr/share/yumex/backend-launcher.py", line 56, in <module>
:    rc = dispatcher()
:  File "/usr/share/yumex/backend-launcher.py", line 36, in dispatcher
:    err, msg = (e.err, e.msg)
:AttributeError: 'exceptions.IOError' object has no attribute 'err'
:
:Local variables in innermost frame:
:e: IOError(5, 'Input/output error')

comment:
:1° Launch Yumex
:2° Tape root password
:3° Crash

smolt_data:
:
:
:Général
:=================================
:UUID: b3230d24-6919-4874-b931-263eb97ba4e4
:SE: Fedora release 17 (Beefy Miracle)
:Niveau d'exécution par défaut: Unknown
:Langue: fr_FR.utf8
:Plateforme: x86_64
:BogoMIPS: 4266.76
:Fabricant du processeurs: GenuineIntel
:Modèle de processeur: Intel(R) Core(TM)2 CPU          6420  @ 2.13GHz
:Stepping du processeur: 6
:Famille de processeur: 6
:Modèle du processeur: 15
:Nombre de processeurs: 2
:Vitesse du processeur: 2133
:Mémoire du système: 3011
:Swap du système: 1999
:Fabricant: Hewlett-Packard
:Système: HP xw4400 Workstation 
:Type d'ordinateur: Mini Tower
:Noyau: 3.3.6-3.fc17.x86_64
:SELinux activé: 1
:Stratégie SELinux: targeted
:SELinux strict: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(32902:10186:4156:10252) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(32902:10179:4156:10252) pci, ahci, RAID, 82801GR/GH (ICH7 Family) SATA RAID Controller
:(32902:10192:4156:10252) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10168:4156:10252) pci, None, PCI/ISA, 82801GB/GR (ICH7 Family) LPC Interface Bridge
:(32902:10208:4156:10252) pci, pcieport, PCI/PCI, 82801GR/GH/GHM (ICH7 Family) PCI Express Port 5
:(32902:10210:4156:10252) pci, pcieport, PCI/PCI, 82801GR/GH/GHM (ICH7 Family) PCI Express Port 6
:(32902:10207:4156:10252) pci, ata_piix, STORAGE, 82801G (ICH7 Family) IDE Controller
:(4098:43576:4098:43576) pci, snd_hda_intel, MULTIMEDIA, RV710/730
:(32902:9294:4156:10252) pci, None, PCI/PCI, 82801 PCI Bridge
:(5348:5755:4156:10252) pci, tg3, ETHERNET, NetXtreme BCM5755 Gigabit Ethernet PCI Express
:(4098:38046:4098:2) pci, radeon, VIDEO, RV370 [FirePro V5700]
:(32902:10185:4156:10252) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:4156:10252) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:10108:4156:10252) pci, i82975x_edac, HOST/PCI, 82975X Memory Controller Hub
:(32902:10200:4156:10252) pci, snd_hda_intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(32902:10187:4156:10252) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10188:4156:10252) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:(32902:10109:4156:10252) pci, pcieport, PCI/PCI, 82975X PCI Express Root Port
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 5103904 3617352 3361352 1281120 1106934 1106934
:/dev/sda4 /home ext4 4096 4096 55222952 51891488 49127021 13828096 13736366 13736366
:/dev/sda1 /boot ext4 1024 1024 508745 403775 378175 128016 127647 127647
:
Comment 1 Raphos 2012-05-31 14:07:37 EDT
Try to use Yumex.
Idon't know.


Package: yumex-3.0.5-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 LeRoy Madison JR 2012-06-02 13:13:53 EDT
while running yum to update system

Package: yumex-3.0.5-2.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 Tim Lauridsen 2012-06-06 10:10:22 EDT
Does this happens every time you start yumex ?

there is two issues here

1. yumex don't catch the exception and blow up.

2. the IOError(5, 'Input/output error') exception


1) is fixed upstream

https://github.com/timlau/yumex/commit/4ca9b260eb871461ff2c308c3c6f9cd416b08cab

2) this is some low level python there stops working, I cant fix that in yumex
Comment 4 Robert McBroom 2012-07-12 00:37:23 EDT
Accidentally killed yumex in the middle of installing from groups.  Running it again to finish the task.  Eliminating support for estoteric languages.  Program died while selection languages to erase.

Package: yumex-3.0.5-2.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 5 Fedora Update System 2012-08-08 04:42:19 EDT
yumex-3.0.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/yumex-3.0.6-1.fc16
Comment 6 Fedora Update System 2012-08-08 04:42:51 EDT
yumex-3.0.6-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/yumex-3.0.6-1.fc17
Comment 7 Fedora Update System 2012-08-09 18:51:05 EDT
Package yumex-3.0.6-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yumex-3.0.6-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11560/yumex-3.0.6-1.fc16
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-08-24 22:57:47 EDT
yumex-3.0.6-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-08-24 23:00:28 EDT
yumex-3.0.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 D. Charles Pyle 2012-11-11 02:10:24 EST
This error is now happening again in Fedora 18-Alpha. Abrt would not let me report it because it says it is already reported.
Comment 11 Andy Grover 2012-12-02 16:17:44 EST
reopened, still an issue in F18. I triggered it by enabling a repo that doesn't yet support F18.
Comment 12 D. Charles Pyle 2012-12-03 08:26:39 EST
Same thing as in Comment 10 but with Fedora 18-Beta. This occurred after a PackageKit crash a day previous to running Yumex. Databases were corrupted again.
Comment 13 mamii 2013-03-13 04:01:34 EDT
Description of problem:
packagekit create problemes 

Version-Release number of selected component:
yumex-3.0.10-1.fc18

Additional info:
cmdline:        /usr/bin/python -E /usr/share/yumex/backend-launcher.py
executable:     /usr/share/yumex/backend-launcher.py
kernel:         3.8.2-206.fc18.x86_64
uid:            0

Truncated backtrace:
backend-launcher.py:36:dispatcher:AttributeError: 'exceptions.IOError' object has no attribute 'err'

Traceback (most recent call last):
  File "/usr/share/yumex/backend-launcher.py", line 56, in <module>
    rc = dispatcher()
  File "/usr/share/yumex/backend-launcher.py", line 36, in dispatcher
    err, msg = (e.err, e.msg)
AttributeError: 'exceptions.IOError' object has no attribute 'err'

Local variables in innermost frame:
e: IOError(5, 'Input/output error')
Comment 14 mamii 2013-03-14 03:26:34 EDT
Description of problem:
packagekit crashed yumex

Version-Release number of selected component:
yumex-3.0.10-1.fc18

Additional info:
cmdline:        /usr/bin/python -E /usr/share/yumex/backend-launcher.py
executable:     /usr/share/yumex/backend-launcher.py
kernel:         3.8.2-206.fc18.x86_64
uid:            0

Truncated backtrace:
backend-launcher.py:36:dispatcher:AttributeError: 'exceptions.IOError' object has no attribute 'err'

Traceback (most recent call last):
  File "/usr/share/yumex/backend-launcher.py", line 56, in <module>
    rc = dispatcher()
  File "/usr/share/yumex/backend-launcher.py", line 36, in dispatcher
    err, msg = (e.err, e.msg)
AttributeError: 'exceptions.IOError' object has no attribute 'err'

Local variables in innermost frame:
e: IOError(5, 'Input/output error')
Comment 15 mamii 2013-03-14 03:31:18 EDT
Description of problem:
packagekit crashed yumex
nother app is currently holding the yum lock; waiting for it to exit...
  The other application is: yum_childtask.p
    Memory :  29 M RSS (1.3 GB VSZ)
    Started: Thu Mar 14 07:10:50 2013 - 19:14 ago
    State  : Sleeping, pid: 2463

Version-Release number of selected component:
yumex-3.0.10-1.fc18

Additional info:
cmdline:        /usr/bin/python -E /usr/share/yumex/backend-launcher.py
executable:     /usr/share/yumex/backend-launcher.py
kernel:         3.8.2-206.fc18.x86_64
uid:            0

Truncated backtrace:
backend-launcher.py:36:dispatcher:AttributeError: 'exceptions.IOError' object has no attribute 'err'

Traceback (most recent call last):
  File "/usr/share/yumex/backend-launcher.py", line 56, in <module>
    rc = dispatcher()
  File "/usr/share/yumex/backend-launcher.py", line 36, in dispatcher
    err, msg = (e.err, e.msg)
AttributeError: 'exceptions.IOError' object has no attribute 'err'

Local variables in innermost frame:
e: IOError(5, 'Input/output error')
Comment 16 KitchM 2013-04-11 23:57:56 EDT
I just upgraded from 17 to 18 using fedup.  Almost everything ran perfect.

However, when I attempt to open yumex, I get the following messages:

An exception was triggered

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 1393, in dispatcher
    self.parse_command(args[0], args[1:])
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 1321, in parse_command
    self.get_packages(args[0], args[1])
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 532, in get_packages
    ygh = self.doPackageLists(pkgnarrow=narrow, showdups=show_dupes)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2787, in doPackageLists
    instpo = self.getInstalledPackageObject(instTup)


And then it just closes.

No yumex, no updates.  Very serious.
Comment 17 KitchM 2013-04-12 14:30:58 EDT
Got another message again:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 1393, in dispatcher
    self.parse_command(args[0], args[1:])
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 1321, in parse_command
    self.get_packages(args[0], args[1])
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 532, in get_packages
    ygh = self.doPackageLists(pkgnarrow=narrow, showdups=show_dupes)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2787, in doPackageLists
    instpo = self.getInstalledPackageObject(instTup)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3881, in getInstalledPackageObject
    raise Errors.RpmDBError, _('Package tuple %s could not be found in rpmdb') % str(pkgtup)
RpmDBError: Package tuple ('eject', 'x86_64', '0', '2.1.5', '22.fc17') could not be found in rpmdb


It appears to be during the time it is looking for updates and is in the middle of processing the Virtualbox repo.
Comment 18 KitchM 2013-04-12 15:00:08 EDT
Removed the Virtualbox repo and got same:
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 1393, in dispatcher
    self.parse_command(args[0], args[1:])
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 1321, in parse_command
    self.get_packages(args[0], args[1])
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 532, in get_packages
    ygh = self.doPackageLists(pkgnarrow=narrow, showdups=show_dupes)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2787, in doPackageLists
    instpo = self.getInstalledPackageObject(instTup)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3881, in getInstalledPackageObject
    raise Errors.RpmDBError, _('Package tuple %s could not be found in rpmdb') % str(pkgtup)
RpmDBError: Package tuple ('eject', 'x86_64', '0', '2.1.5', '22.fc17') could not be found in rpmdb
Comment 19 KitchM 2013-04-12 15:59:52 EDT
It is still doing it.

Does this have something to do with the backend component since upgrading to 18?

Thanks.
Comment 20 KitchM 2013-04-12 17:05:02 EDT
Opened console as root.
Ran 'yum clean all'
Then ran 'yum makecache'
Problem went away.

Evidently something happened while upgrading to 18.

Hope this helps some folks.
Comment 21 D. Charles Pyle 2013-05-15 04:16:07 EDT
Happening again on Fedora 19 Beta TC2 x86_64.
Comment 22 D. Charles Pyle 2013-05-21 03:33:02 EDT
Still happening with yumex-3.0.10-2.fc19.noarch
Comment 23 D. Charles Pyle 2013-05-21 03:33:44 EDT
Abrt will not allow me to report this.
Comment 24 D. Charles Pyle 2013-05-21 03:47:25 EDT
Reason:

backend-launcher.py:36:dispatcher:AttributeError: 'exceptions.IOError' object has no attribute 'err'

Core backtrace:

28d3cce6a27368b2b9524a45fa454903c805a40c 0x24 dispatcher /usr/share/yumex/backend-launcher.py -
28d3cce6a27368b2b9524a45fa454903c805a40c 0x38 <module> /usr/share/yumex/backend-launcher.py -

Backtrace:

backend-launcher.py:36:dispatcher:AttributeError: 'exceptions.IOError' object has no attribute 'err'

Traceback (most recent call last):
  File "/usr/share/yumex/backend-launcher.py", line 56, in <module>
    rc = dispatcher()
  File "/usr/share/yumex/backend-launcher.py", line 36, in dispatcher
    err, msg = (e.err, e.msg)
AttributeError: 'exceptions.IOError' object has no attribute 'err'

Local variables in innermost frame:
e: IOError(5, 'Input/output error')
Comment 25 D. Charles Pyle 2013-05-28 01:14:16 EDT
Caused this time by trying to update libgcj and libgcj-devel packages using yumex.  After a long list of 404 messages and a listing of missing repositories in red colored font the crash would bring down yumex.
Comment 26 al morris 2013-06-12 02:30:06 EDT
yo tambien (me too)

[Still happening with yumex-3.0.10-2.fc19.noarch]
[Abrt will not allow me to report this.]

don't know why it is happening but it is not regularly happening.
so maybe this is useful??

adios,
@
Comment 27 Heiko Adams 2013-06-13 06:52:59 EDT
I've got the same problem. It happens if there are missing dependencies and the yum aliases plugin is installed. I'm using Fedora 19
Comment 28 D. Charles Pyle 2013-06-13 15:09:14 EDT
I don't have yum-plugin-aliases installed and never have.  I'm also not missing dependencies for yum.  I also am using Fedora 19.
Comment 29 Peter Trenholme 2013-08-21 16:29:25 EDT
I just triggered this bug in Rawhide (F20), and was referred here with a claim that the bug was a duplicate.

I suspect that the automatic bug reporting tool needs some more smarts...
Comment 30 D. Charles Pyle 2013-09-04 00:10:57 EDT
Just got hit with this again using yumex to install gtk3 themes.
Comment 31 Tim Lauridsen 2013-09-10 08:10:49 EDT
*** Bug 1000667 has been marked as a duplicate of this bug. ***
Comment 32 Tim Lauridsen 2013-09-12 07:26:00 EDT
AttributeError: 'exceptions.IOError' object has no attribute 'err' 

has been fixed upstream 

https://github.com/timlau/yumex/commit/fa1eb6a8cde50885ec2ff09d49db412f72350c4c

It dont solve the IOError, but should handle it nicer
Comment 33 Tim Lauridsen 2013-09-19 06:08:20 EDT
*** Bug 1009322 has been marked as a duplicate of this bug. ***
Comment 34 Fedora Update System 2013-09-22 06:25:11 EDT
yumex-3.0.12-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/yumex-3.0.12-1.fc20
Comment 35 Fedora Update System 2013-09-22 06:26:06 EDT
yumex-3.0.12-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/yumex-3.0.12-1.fc19
Comment 36 Fedora Update System 2013-09-22 20:04:54 EDT
Package yumex-3.0.12-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yumex-3.0.12-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17378/yumex-3.0.12-1.fc19
then log in and leave karma (feedback).
Comment 37 Tim Lauridsen 2013-09-30 00:35:24 EDT
*** Bug 1013354 has been marked as a duplicate of this bug. ***
Comment 38 Fedora Update System 2013-09-30 22:02:54 EDT
yumex-3.0.12-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 39 Fedora Update System 2013-10-12 00:26:39 EDT
yumex-3.0.12-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 40 D. Charles Pyle 2013-10-12 00:38:02 EDT
I'm still seeing strange behavior in this version of yumex.  It shows a list of updates available.  On selecting all of them or any of them, one can run the update.  However, the error is generated as follows and nothing gets updated.

Dependency Resolution Errors:  Success - empty transaction

Each time if I want to get it to update, I have to rebuild the rpm databases, run yum clean all, and have about a 50% chance of installing anything.  If I try this twice and still cannot install updates, I run yum without yumex.  It then either will update everything or yum will report that there are no updates even though yumex shows that there are updates available.

Note You need to log in before you can comment on or make changes to this bug.