Bug 823341 - In advanced search when you change the product sometimes you get a component called [object HTMLSelectElement]
In advanced search when you change the product sometimes you get a component ...
Status: CLOSED DUPLICATE of bug 823339
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-20 20:25 EDT by Simon Baird
Modified: 2014-10-12 18:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 21:35:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Baird 2012-05-20 20:25:02 EDT
Try changing the product a few times and you should see this.

Mightbe some kind of bug in:
https://bugzilla.redhat.com/js/productform.js

That text usually indicates a dom element or some other object is being incorrectly treated as a string.

The dom ends up looking like this:
<option value="">[object HTMLSelectElement]</option>
Comment 1 Simon Green 2012-08-13 21:35:39 EDT
Bug 823339 goes back to the old 'click to refresh' component list option. Upstream's code does not work too well when you have 13,000 components in a single product.

*** This bug has been marked as a duplicate of bug 823339 ***

Note You need to log in before you can comment on or make changes to this bug.